Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289901 - xf86-input-evdev 2.3.0 incorrect mouse moving
Summary: xf86-input-evdev 2.3.0 incorrect mouse moving
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Piotr Jaroszyński (RETIRED)
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-20 19:04 UTC by Dmitriy
Modified: 2009-11-15 22:10 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
my Xorg's log (Xorg.0.log,11.64 KB, text/plain)
2009-10-21 10:28 UTC, PM
Details
ebuild with a hack for X-750F (evdev-2.3.0-hacked-ebuild.tar.bz2,1.26 KB, application/x-tar)
2009-11-09 13:54 UTC, Bartosz Brachaczek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitriy 2009-10-20 19:04:12 UTC
after upgrade to xf86-input-evdev 2.3.0 mouse starts work incorrect. Cursor is jumping on the screen chaotically when I moving mouse. xorg-server-1.6.5 

Reproducible: Always




emerge --info
Portage 2.1.7.1 (default/linux/amd64/10.0/desktop, gcc-4.3.2, glibc-2.10.1-r0, 2.6.31-gentoo-r3 x86_64)
=================================================================                                      
System uname: Linux-2.6.31-gentoo-r3-x86_64-AMD_Athlon-tm-_64_Processor_3500+-with-gentoo-2.0.1        
Timestamp of tree: Tue, 20 Oct 2009 17:25:01 +0000                                                     
ccache version 2.4 [disabled]                                                                          
app-shells/bash:     4.0_p33                                                                           
dev-java/java-config: 2.1.9-r1                                                                         
dev-lang/python:     2.4.4-r13, 2.5.4-r3, 2.6.3, 3.1.1-r1                                              
dev-python/pycrypto: 2.0.1-r6                                                                          
dev-util/ccache:     2.4-r8                                                                            
dev-util/cmake:      2.6.4-r3                                                                          
sys-apps/baselayout: 2.0.1                                                                             
sys-apps/openrc:     0.5.2-r1                                                                          
sys-apps/sandbox:    2.1                                                                               
sys-devel/autoconf:  2.13, 2.63-r1                                                                     
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11                                                            
sys-devel/binutils:  2.20                                                                              
sys-devel/gcc-config: 1.4.1                                                                            
sys-devel/libtool:   2.2.6a                                                                            
virtual/os-headers:  2.6.30-r1                                                                         
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                         
CBUILD="x86_64-pc-linux-gnu"                                                                           
CFLAGS="-march=native -O2 -pipe"                                                                       
CHOST="x86_64-pc-linux-gnu"                                                                            
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                                       
CXXFLAGS="-march=native -O2 -pipe"                                                                                                           
DISTDIR="/usr/portage/distfiles"                                                                                                             
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                                                                                                                           
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.mneisen.org/ "            
LANG="ru_RU.UTF-8"                                                                                                                           
LC_ALL="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/zugaina /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus divx dri dts dvd dvdr eds emboss enca encode evo fam firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde lame ldap libnotify mad matroska mikmod mmx mmx2 modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime rar readline reflection samba sdl session spell spl srt sse sse2 ssl startup-notification svg sysfs tcpd threads thunar tiff truetype unicode usb vorbis x264 xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="usb-audio emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

lsusb
Bus 002 Device 005: ID 09da:000e A4 Tech Co., Ltd
Bus 002 Device 002: ID 041e:3040 Creative Technology, Ltd SoundBlaster Live! 24-bit External SB0490
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Comment 1 Rafał Mużyło 2009-10-20 19:08:04 UTC
Fabulously.
Now, attaching your xorg.conf, your fdi input settings
and xorg log would be nice
Comment 2 Wojciech Szymski 2009-10-21 07:38:49 UTC
(In reply to comment #0)
> after upgrade to xf86-input-evdev 2.3.0 mouse starts work incorrect. Cursor is
> jumping on the screen chaotically when I moving mouse. xorg-server-1.6.5 
> 
> Reproducible: Always
> 
> 
> 
> 
> emerge --info
> Portage 2.1.7.1 (default/linux/amd64/10.0/desktop, gcc-4.3.2, glibc-2.10.1-r0,
> 2.6.31-gentoo-r3 x86_64)
> =================================================================               
> System uname:
> Linux-2.6.31-gentoo-r3-x86_64-AMD_Athlon-tm-_64_Processor_3500+-with-gentoo-2.0.1 
> Timestamp of tree: Tue, 20 Oct 2009 17:25:01 +0000                              
> ccache version 2.4 [disabled]                                                   
> app-shells/bash:     4.0_p33                                                    
> dev-java/java-config: 2.1.9-r1                                                  
> dev-lang/python:     2.4.4-r13, 2.5.4-r3, 2.6.3, 3.1.1-r1                       
> dev-python/pycrypto: 2.0.1-r6                                                   
> dev-util/ccache:     2.4-r8                                                     
> dev-util/cmake:      2.6.4-r3                                                   
> sys-apps/baselayout: 2.0.1                                                      
> sys-apps/openrc:     0.5.2-r1                                                   
> sys-apps/sandbox:    2.1                                                        
> sys-devel/autoconf:  2.13, 2.63-r1                                              
> sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11                                     
> sys-devel/binutils:  2.20                                                       
> sys-devel/gcc-config: 1.4.1                                                     
> sys-devel/libtool:   2.2.6a                                                     
> virtual/os-headers:  2.6.30-r1                                                  
> ACCEPT_KEYWORDS="amd64 ~amd64"                                                  
> CBUILD="x86_64-pc-linux-gnu"                                                    
> CFLAGS="-march=native -O2 -pipe"                                                
> CHOST="x86_64-pc-linux-gnu"                                                     
> CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
> /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
> CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/
> /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild
> /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                 
> CXXFLAGS="-march=native -O2 -pipe"                                              
> DISTDIR="/usr/portage/distfiles"                                                
> FEATURES="assume-digests distlocks fixpackages news parallel-fetch
> protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"    
> GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/
> ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/
> ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
> ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo
> http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/
> ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/
> http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.mneisen.org/
> "            
> LANG="ru_RU.UTF-8"                                                              
> LC_ALL="ru_RU.UTF-8"
> LDFLAGS="-Wl,-O1"
> LINGUAS="ru en"
> MAKEOPTS="-j2"
> PKGDIR="/usr/portage/packages"
> PORTAGE_CONFIGROOT="/"
> PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
> --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles
> --exclude=/local --exclude=/packages"
> PORTAGE_TMPDIR="/var/tmp"
> PORTDIR="/usr/portage"
> PORTDIR_OVERLAY="/usr/local/portage/layman/zugaina /usr/local/portage"
> SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
> USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 berkdb bluetooth branding
> bzip2 cairo cdr cli consolekit cracklib crypt cups dbus divx dri dts dvd dvdr
> eds emboss enca encode evo fam firefox flac fortran gdbm gif gnome gpm
> gstreamer gtk hal iconv ipv6 isdnlog jpeg kde lame ldap libnotify mad matroska
> mikmod mmx mmx2 modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly
> nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4
> quicktime rar readline reflection samba sdl session spell spl srt sse sse2 ssl
> startup-notification svg sysfs tcpd threads thunar tiff truetype unicode usb
> vorbis x264 xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="usb-audio
> emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty
> extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw
> multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias
> auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm
> authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache
> dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache
> filter headers include info log_config logio mem_cache mime mime_magic
> negotiation rewrite setenvif speling status unique_id userdir usertrack
> vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux"
> LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses
> text" LINGUAS="ru en" SANE_BACKENDS="plustek" USERLAND="GNU"
> VIDEO_CARDS="nvidia nv"
> Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK,
> PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
> 
> lsusb
> Bus 002 Device 005: ID 09da:000e A4 Tech Co., Ltd
> Bus 002 Device 002: ID 041e:3040 Creative Technology, Ltd SoundBlaster Live!
> 24-bit External SB0490
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> 

Same bug here. Also some more info: Simple Logitech mouse works (pid HS84212), but a4Tech X7 (s/n 090500283) refuses to, so mouse-dependent bug.
Comment 3 PM 2009-10-21 10:13:19 UTC
I confirm. I have a4tech X7 mouse too. It looks like moving the mouse up and down works, but moving it sideways jumps the cursor to the bottom of the screen.

A cheap wireless no-name mouse work well.

My xorg.conf:

Section "ServerLayout"                   
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0     
#       InputDevice    "Mouse0" "CorePointer"
#       InputDevice    "Keyboard0" "CoreKeyboard"
EndSection                                       

Section "Files"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/" 
        FontPath     "/usr/share/fonts/OTF"  
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi/"
        FontPath     "/usr/share/fonts/75dpi/" 
EndSection                                     

Section "Module"
        Load  "dbe"
        Load  "record"
        Load  "glx"
        Load  "dri"
        Load  "xtrap"
        Load  "extmod"
        Load  "freetype"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
EndSection

Section "ServerFlags"
        Option "DontZap" "false"
EndSection


What are "fdi input settings"?

I'll attach xorg log in a sec.
Comment 4 PM 2009-10-21 10:28:31 UTC
Created attachment 207798 [details]
my Xorg's log
Comment 5 Rafał Mużyło 2009-10-21 12:46:24 UTC
Does 'xinput test' ran on the mouse show anything interesting
(like a wrongly mapped button/axis) ?
Comment 6 Henning Rohlfs 2009-10-23 08:51:00 UTC
(In reply to comment #5)
> Does 'xinput test' ran on the mouse show anything interesting
> (like a wrongly mapped button/axis) ?

I'm quite sure my problem is related: even though the mouse is not really jumping around chaotically with 2.3.0, it is jumping straight down a random amount whenever I move the mouse horizontally but not vertically.

mouse buttons are mapped properly and there's nothing out of the ordinary in any log either. the only curiousity is xinput test showing 3 axis instead of 2:


motion a[1]=2 a[2]=0 
motion a[1]=1 a[2]=0 
motion a[1]=1 a[2]=0 
motion a[1]=1 a[2]=0 
motion a[0]=2 a[1]=626 a[2]=64078 
motion a[1]=2 a[2]=-64078 
motion a[1]=1 a[2]=0 
motion a[1]=1 a[2]=0 
motion a[1]=1 a[2]=0 
motion a[1]=1 a[2]=0 
Comment 7 foomor 2009-10-23 12:15:05 UTC
Same here with A4Tech X-750F. In addition getting error next error message in Xorg.0.log:
(EE) RADEON(0): Unable to reserve offscreen area for back buffer, you might experience screen corruption

xorg-1.6.5
xf86-video-ati-6.14.4
Comment 8 Rémi Cardona gentoo-dev 2009-10-24 11:29:39 UTC
Please file a bug upstream [1] and paste the URL here so I can track the issue.

Thanks

[1] https://bugs.freedesktop.org/
Comment 9 Nils Larsson 2009-10-26 16:15:15 UTC
Reported upstream: https://bugs.freedesktop.org/show_bug.cgi?id=24737
Comment 10 Rémi Cardona gentoo-dev 2009-10-26 18:13:54 UTC
Reopening
Comment 11 Rémi Cardona gentoo-dev 2009-10-26 18:14:26 UTC
Let's track the bug upstream directly.

Closing with the correct resolution.

Thanks
Comment 12 Surovskiy 2009-10-30 16:02:42 UTC
i also have this problem. someone solve this problem?
Comment 13 Dmitriy 2009-10-31 10:13:59 UTC
(In reply to comment #12)
> i also have this problem. someone solve this problem?
> 

Yep, mask it :)
Comment 14 Surovskiy 2009-10-31 11:51:03 UTC
with Xserver 1.7.1 evdev 2.2.5 don compile. Yesterday I made the experiment with two mouse and found that problem remained with A4tech X7
Comment 15 foomor 2009-10-31 16:15:03 UTC
(In reply to comment #14)
> with Xserver 1.7.1 evdev 2.2.5 don compile.
xorg-setver 1.7.1 won't even work with evdev <= 2.3.0.
So the solution is to downgrade xorg as well, what i couldn't did neither :D
On upstream bugtracker is silence.
Comment 16 Dmitry Baranov 2009-11-04 21:07:23 UTC
Same problem. A4Tech X7.
Comment 17 Dmitry Baranov 2009-11-05 14:03:51 UTC
X7 works fine with USE -hal.
Comment 18 Rémi Cardona gentoo-dev 2009-11-05 15:36:56 UTC
Please comment in the _upstream_ bug. The more of you go there, the better chance you'll have of getting this fixed.

There's absolutely nothing to be done here.

Thanks
Comment 19 Bartosz Brachaczek 2009-11-09 13:53:32 UTC
In case someone wants to use evdev-2.3.0, not 2.2.5 for some reason, I attach a tarball with modified ebuild and a small (bit really dirty) hack that makes X-750F work again. Simply unpack this to your PORTDIR_OVERLAY (probably /usr/local/portage) and emerge.
Comment 20 Bartosz Brachaczek 2009-11-09 13:54:55 UTC
Created attachment 209733 [details]
ebuild with a hack for X-750F
Comment 21 Rémi Cardona gentoo-dev 2009-11-09 16:43:00 UTC
Care to show us the _patch_ instead?

Thanks
Comment 22 Rémi Cardona gentoo-dev 2009-11-09 16:53:32 UTC
Nvm, I hadn't read fd.o bug mail yet.

Thanks
Comment 23 Bartosz Brachaczek 2009-11-09 18:27:35 UTC
To clarify things, the tarball attached here contains an ebuild AND a patch, but not a proper patch - just a dirty workaround. After posting this hack here, I found a real bug and sent a real patch to fd.o.
Comment 24 Dmitriy 2009-11-09 18:36:20 UTC
another path from https://bugs.freedesktop.org/ please make an ebuild.

--- evdev.c     2009-10-15 05:36:49.000000000 +0400
+++ evdev.c.new 2009-11-09 20:09:21.000000000 +0300
@@ -710,7 +710,7 @@
 EvdevProcessSyncEvent(InputInfoPtr pInfo, struct input_event *ev)
 {
     int num_v = 0, first_v = 0;
-    int v[MAX_VALUATORS];
+    int v[MAX_VALUATORS] = {};
     EvdevPtr pEvdev = pInfo->private;

     EvdevProcessValuators(pInfo, v, &num_v, &first_v);
Comment 25 Bartosz Brachaczek 2009-11-09 18:42:20 UTC
(In reply to comment #24)
> another path from https://bugs.freedesktop.org/ please make an ebuild.
> 
> --- evdev.c     2009-10-15 05:36:49.000000000 +0400
> +++ evdev.c.new 2009-11-09 20:09:21.000000000 +0300
> @@ -710,7 +710,7 @@
>  EvdevProcessSyncEvent(InputInfoPtr pInfo, struct input_event *ev)
>  {
>      int num_v = 0, first_v = 0;
> -    int v[MAX_VALUATORS];
> +    int v[MAX_VALUATORS] = {};
>      EvdevPtr pEvdev = pInfo->private;
> 
>      EvdevProcessValuators(pInfo, v, &num_v, &first_v);
> 

It's my own patch. If the ebuild attached here works for you, you don't need this new patch. When upstream will commit a proper patch, probably some dev would put it into the portage tree.
Comment 26 PM 2009-11-15 17:14:51 UTC
thanks, the attached ebuild fixes thew issue for me ;)
Comment 27 Nikolaos Chatzidakis 2009-11-15 21:54:37 UTC
Same problem here... I have a microsoft wireless laser v5000 mouse, and many times it jumes on the upper left corner of the screen. BUT, when i check the X.log, i get this:

...(same error)
Mouse0: dropping event due to full queue!
Mouse0: dropping event due to full queue!
Mouse0: dropping event due to full queue!
...(same error)

I get this, everytime the mouse "jumps"... 
Comment 28 Bartosz Brachaczek 2009-11-15 22:10:21 UTC
(In reply to comment #27)
> Same problem here... I have a microsoft wireless laser v5000 mouse, and many
> times it jumes on the upper left corner of the screen. BUT, when i check the
> X.log, i get this:
> 
> ...(same error)
> Mouse0: dropping event due to full queue!
> Mouse0: dropping event due to full queue!
> Mouse0: dropping event due to full queue!
> ...(same error)
> 
> I get this, everytime the mouse "jumps"... 
> 

Did you try ebuild attached here? Probably it's an unrelated bug, though introduced in the same commit (previously there were no queues in evdev). If the ebuild attached here doesn't help you (almost certainly it won't), report this bug upstream ( https://bugs.freedesktop.org/enter_bug.cgi?product=xorg ).