Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289110 - [QA] app-cdr/cdrtools-2.01.01_alpha78 doesn't respect LDFLAGS
Summary: [QA] app-cdr/cdrtools-2.01.01_alpha78 doesn't respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2009-10-14 21:00 UTC by Davide Pesavento
Modified: 2010-08-09 21:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info cdrtools (emerge--info,5.01 KB, text/plain)
2010-03-02 19:53 UTC, Nikos Chantziaras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Pesavento gentoo-dev 2009-10-14 21:00:16 UTC
QA Notice: Files built without respecting LDFLAGS have been detected
 Please include the following list of files in your report:
/usr/lib64/libdeflt.so.1.0
/usr/lib64/libschily.so.1.0
/usr/lib64/libparanoia.so.1.0
/usr/lib64/libcdrdeflt.so.1.0
/usr/lib64/libfile.so.1.0
/usr/lib64/libmdigest.so.1.0
/usr/lib64/libedc_ecc.so.1.0
/usr/lib64/libedc_ecc_dec.so.1.0
/usr/lib64/libscg.so.1.0
/usr/lib64/libscgcmd.so.1.0
/usr/lib64/librscg.so.1.0
/usr/lib64/libsiconv.so.1.0
/usr/lib64/libhfs.so.1.0
/usr/lib64/libfind.so.1.0
Comment 1 Daniel Pielmeier gentoo-dev 2009-10-16 08:36:09 UTC
Does not occur on 32bit x86. Can you please post emerge --info.
Comment 2 Davide Pesavento gentoo-dev 2009-10-16 09:48:37 UTC
Portage 2.2_rc46 (default/linux/amd64/10.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.31-wl-38300-ge4546cc-dirty x86_64)
=================================================================
System uname: Linux-2.6.31-wl-38300-ge4546cc-dirty-x86_64-Intel-R-_Core-TM-2_CPU_T7600_@_2.33GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 15 Oct 2009 16:15:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p33
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.3
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.1-r1
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -ggdb -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -ggdb -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/                 ftp://ftp.unina.it/pub/linux/distributions/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--human-readable --prune-empty-dirs"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/java-overlay /usr/portage/local/underlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avahi bash-completion berkdb bluetooth branding bzip2 cairo caps cdda cddb cdr cli consolekit cracklib crypt curl dbus djvu dri dts dv dvd dvdr emacs emboss encode evo exif expat fam ffmpeg fftw flac fontconfig ftp gd gdbm gif glut gmp gnutls gpm graphviz hal iconv icu idn imagemagick ipod ipv6 isdnlog jabber java5 java6 jingle jpeg jpeg2k kde lame latex lcms ldap libsamplerate lm_sensors lua lzo mad matroska mikmod mmap mmx mng modules mozilla mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz ncurses networkmanager nls nptl nptlonly offensive ogg opengl openmp pam pch pcre pdf plasma png policykit ppds pppd pulseaudio qt3support qt4 quicktime readline reflection rss samba sasl sdl session slang sndfile socks5 speex spell spl sqlite sqlite3 sse sse2 ssl startup-notification svg sysfs syslog taglib tcpd theora threads thunar tiff truetype unicode usb v4l2 vcd vorbis wmf x264 xattr xcb xcomposite xine xinerama xml xorg xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="radeonhd vesa" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 3 Daniel Pielmeier gentoo-dev 2009-11-04 18:32:19 UTC
Can you please check if this also happens with cdrtools-2.01.01_alpha67 which should be available in a few hours.

Also please check if this also happens with the following part of the ebuild removed:

	# Respect CC/CXX variables
	local tcCC=$(tc-getCC)
	local tcCXX=$(tc-getCXX)
	sed -i -e "/cc-config.sh/s/\$(C_ARCH:%64=%) \$(CCOM_DEF)/${tcCC} ${tcCC}/" \
		rules1.top || die "sed rules1.top failed"
	sed -i -e "/^\(CC\|DYNLD\|LDCC\|MKDEP\)/s/gcc/${tcCC}/" \
		-e "/^\(CC++\|DYNLDC++\|LDCC++\|MKC++DEP\)/s/g++/${tcCXX}/" \
		cc-gcc.rul || die "sed cc-gcc.rul failed"
	sed -i -e "s/^#CONFFLAGS +=\t-cc=\$(XCC_COM)$/CONFFLAGS +=\t-cc=${tcCC}/g" \
		rules.cnf || die "sed rules.cnf failed"
Comment 4 Daniel Pielmeier gentoo-dev 2009-11-04 20:47:24 UTC
(In reply to comment #3)
> Can you please check if this also happens with cdrtools-2.01.01_alpha67 which
> should be available in a few hours.
> 
> Also please check if this also happens with the following part of the ebuild
> removed:
> 
>         # Respect CC/CXX variables
>         local tcCC=$(tc-getCC)
>         local tcCXX=$(tc-getCXX)
>         sed -i -e "/cc-config.sh/s/\$(C_ARCH:%64=%) \$(CCOM_DEF)/${tcCC}
> ${tcCC}/" \
>                 rules1.top || die "sed rules1.top failed"
>         sed -i -e "/^\(CC\|DYNLD\|LDCC\|MKDEP\)/s/gcc/${tcCC}/" \
>                 -e "/^\(CC++\|DYNLDC++\|LDCC++\|MKC++DEP\)/s/g++/${tcCXX}/" \
>                 cc-gcc.rul || die "sed cc-gcc.rul failed"
>         sed -i -e "s/^#CONFFLAGS +=\t-cc=\$(XCC_COM)$/CONFFLAGS
> +=\t-cc=${tcCC}/g" \
>                 rules.cnf || die "sed rules.cnf failed"
> 

I did check the above myself and experienced the same issue. Actually i should set some LDFLAGS in make.conf :-)

This must have been introduced in cdrtools-2.01.01_alpha66 as cdrtools-2.01.01_alpha65 is fine.
Comment 5 Daniel Pielmeier gentoo-dev 2009-11-04 22:36:22 UTC
I have just committed cdrtools-2.01.01_alpha67-r1 which should fix the problem. Please try this version.
Comment 6 Davide Pesavento gentoo-dev 2009-11-05 21:00:41 UTC
Yep, fixed in 2.01.01_alpha67-r1. Thanks!
Comment 7 Daniel Pielmeier gentoo-dev 2009-11-05 21:05:56 UTC
(In reply to comment #6)
> Yep, fixed in 2.01.01_alpha67-r1. Thanks!
> 

Thank you for the report and testing.
Comment 8 Nikos Chantziaras 2010-03-02 00:28:30 UTC
app-cdr/cdrtools-2.01.01_alpha77:

* QA Notice: Files built without respecting LDFLAGS have been detected
*  Please include the following list of files in your report:
* /usr/lib64/libedc_ecc.so.1.0
* /usr/lib64/libschily.so.1.0
Comment 9 Steve Kutnar 2010-03-02 01:28:33 UTC
I get the same as comment #8.  Can we get this reopened?
Comment 10 Daniel Pielmeier gentoo-dev 2010-03-02 01:46:02 UTC
(In reply to comment #9)
> I get the same as comment #8.  Can we get this reopened?
> 

Yes we can. Is this the first version where this occurs again? I guess you are both on amd64?
Comment 11 Steve Kutnar 2010-03-02 02:30:43 UTC
Yes, ~amd64

Portage 2.2_rc63 (default/linux/amd64/10.0/no-multilib, gcc-4.4.3-asneeded, glibc-2.10.1-r1, 2.6.32-gentoo-r7 x86_64)                 
=================================================================                                                                     
                        System Settings                                                                                               
=================================================================                                                                     
System uname: Linux-2.6.32-gentoo-r7-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4400+-with-gentoo-2.0.1                          
Timestamp of tree: Tue, 02 Mar 2010 00:00:01 +0000                                                                                    
app-shells/bash:     4.1_p2                                                                                                           
dev-java/java-config: 2.1.10                                                                                                          
dev-lang/python:     2.6.4-r1, 3.1.1-r1                                                                                               
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20-r1
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.32
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests distlocks fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.mirrors.tds.net/gentoo ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--sort-common"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/vmware /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 ao bash-completion branding bzip2 cairo caps cdda cddb cdparanoia cli consolekit cracklib crypt css cups curl cxx dbus dga dri dv dvd dvdr encode exif expat faac faad fam fbcon ffmpeg fftw flac fontconfig fortran geoip ggi gif glib gmp gnutls gphoto2 gpm gs gtk hal iconv icu id3tag idn ieee1394 imagemagick imlib ipv6 ithreads java jfs joystick jpeg jpeg2k kde kdehiddenvisibility kontact lame lcms libsamplerate lm_sensors lzo mad matroska mbox mjpeg mmap mmx mmxext mng modplug modules motif mp3 mpeg mplayer msn mtp mudflap musepack musicbrainz ncurses network network-cron nls nptl nptlonly nsplugin ntfs offensive ogg openal opengl openmp openssl oscar oss pam pcre pdf perl plasma plotutils png policykit pppd qt3support qt4 quicktime rar readline reflection rle ruby samba schroedinger sdl semantic-desktop session smp sndfile speex spell spl sse sse2 sse3 ssl startup-notification stats subversion suid svg sysfs syslog tcl tcpd theora threads tiff truetype twolame udev unicode usb vcd vdpau vim-syntax vnc vorbis wavpack wmf wxwidgets x264 xcb xcomposite xfs xft xine xml xorg xpm xscreensaver xv xvid xvmc zlib" ALSA_CARDS="emu10k1 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-cdr/cdrtools-2.01.01_alpha77 was built with the following:
USE="unicode -acl"
CFLAGS="-march=native -O2 -pipe -finput-charset=ISO-8859-1 -fexec-charset=UTF-8 -DNO_ACL"
CXXFLAGS="-march=native -O2 -pipe -finput-charset=ISO-8859-1 -fexec-charset=UTF-8"
Comment 12 Nikos Chantziaras 2010-03-02 02:52:01 UTC
(In reply to comment #10)
> Is this the first version where this occurs again?

I've just emerged all versions currently in portage:

  2.01.01_alpha57-r1
  2.01.01_alpha75
  2.01.01_alpha76
  2.01.01_alpha77

and the same QA notice occurs with all of them.


> I guess you are both on amd64?

AMD64 here too.
Comment 13 Daniel Pielmeier gentoo-dev 2010-03-02 09:20:27 UTC
I don't experience any issues on x86 and I test with --as-needed before bumping. This is probably something 64bit specific.
Comment 14 Davide Pesavento gentoo-dev 2010-03-02 11:27:22 UTC
You need "--hash-style=gnu" in your LDFLAGS to be able to reproduce.
Comment 15 Daniel Pielmeier gentoo-dev 2010-03-02 18:59:04 UTC
(In reply to comment #14)
> You need "--hash-style=gnu" in your LDFLAGS to be able to reproduce.
> 

I test with: LDFLAGS="-Wl,-O1,--as-needed,--hash-style=gnu" and there are no errors.
Comment 16 Nikos Chantziaras 2010-03-02 19:53:35 UTC
Created attachment 221843 [details]
emerge --info cdrtools

My LDFLAGS are "-Wl,-O1,--hash-style=gnu,--sort-common,--as-needed"

I am attaching emerge --info cdrtools
Comment 17 Davide Pesavento gentoo-dev 2010-03-02 21:14:03 UTC
Weird. I just synced and I can't reproduce on ~amd64 with LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu".
Comment 18 Daniel Pielmeier gentoo-dev 2010-03-07 18:52:20 UTC
Okay I was able to reproduce it with
LDFLAGS="-Wl,-O1,-Wl,--as-needed,-Wl,--sort-common,-Wl,--hash-style=gnu"
which results in a complete fail-over.

 * QA Notice: Files built without respecting LDFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/sbin/rscsi
 * /usr/lib/libhfs.so.1.0
 * /usr/lib/libedc_ecc_dec.so.1.0
 * /usr/lib/libscgcmd.so.1.0
 * /usr/lib/libfile.so.1.0
 * /usr/lib/libschily.so.1.0
 * /usr/lib/libfind.so.1.0
 * /usr/lib/libscg.so.1.0
 * /usr/lib/librscg.so.1.0
 * /usr/lib/libmdigest.so.1.0
 * /usr/lib/libsiconv.so.1.0
 * /usr/lib/libparanoia.so.1.0
 * /usr/lib/libcdrdeflt.so.1.0
 * /usr/lib/libdeflt.so.1.0
 * /usr/lib/libedc_ecc.so.1.0
 * /usr/bin/mkisofs
 * /usr/bin/isovfy
 * /usr/bin/cdda2wav
 * /usr/bin/isoinfo
 * /usr/bin/scgskeleton
 * /usr/bin/isodebug
 * /usr/bin/readcd
 * /usr/bin/btcflash
 * /usr/bin/scgcheck
 * /usr/bin/cdrecord
 * /usr/bin/isodump
 * /usr/bin/devdump

It seems to be a matter of how the LDFLAGS are defined as it is fine with
LDFLAGS="-Wl,-O1,--as-needed,--sort-common,--hash-style=gnu" Apparently -Wl is needed as separator for all LDFLAGS passed, this is also mentioned in the ld man page. 

From my investigations all combinations which include -Wl,-O1,-Wl,--hash-style=gnu seem to be ignored by cdrtools. Personal I must confess that I am not able to fix it nor will spend time on this issue. If someone wants to fix it, patches are welcome.
Comment 19 Nikos Chantziaras 2010-03-08 03:53:04 UTC
(In reply to comment #18)
> Okay I was able to reproduce it with
> LDFLAGS="-Wl,-O1,-Wl,--as-needed,-Wl,--sort-common,-Wl,--hash-style=gnu"
> which results in a complete fail-over.

I don't think that's a legal option format anyway.  Maybe you meant to try:

LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu"

Otherwise, you're passing "-Wl" to the linker, which doesn't understand this option, only GCC does.
Comment 20 Nikos Chantziaras 2010-03-08 04:12:45 UTC
Another thing:  portage doesn't seem to really check all LDFLAGS. AFAICT, it is only able to check whether binaries have been linked with "--hash-style=gnu".  The LDFLAGS used to create a binary are actually not retrievable.  Portage uses a hack here; if it sees that the user has "--hash-style=gnu" in LDFLAGS, it uses the scanelf utility to check whether the hash is actually GNU-style.  If not, it assumes that LDFLAGS haven't been respected.  From Portage's misc-functions.sh, line 169:

  # Check for files built without respecting LDFLAGS
  if [[ "${LDFLAGS}" == *--hash-style=gnu* ]] && [[ "${PN}" != *-bin ]] ; then
     # ...

It's not a thorough check, but it works *if* the user has "--hash-style=gnu" in LDFLAGS.  I guess most user's don't (the default LDFLAGS for profiles is just "-Wl,-O1"), since the amount of bug reports related to this seem low, even though I get this QA warning for quite a few packages, but I usually don't bother reporting them :P
Comment 21 Daniel Pielmeier gentoo-dev 2010-03-08 07:28:20 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > Okay I was able to reproduce it with
> > LDFLAGS="-Wl,-O1,-Wl,--as-needed,-Wl,--sort-common,-Wl,--hash-style=gnu"
> > which results in a complete fail-over.
> 
> I don't think that's a legal option format anyway.  Maybe you meant to try:
> 
> LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu"
> 
> Otherwise, you're passing "-Wl" to the linker, which doesn't understand this
> option, only GCC does.
> 

Yeah you are right! I was a bit overenthusiastic with the commas:) So the following is equally the the same as I suspected before.

LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu"
LDFLAGS="-Wl,-O1,--as-needed,--sort-common,--hash-style=gnu"

So why do Davide and do I not have problems but you and others do? What is different?
Comment 22 Daniel Pielmeier gentoo-dev 2010-03-13 13:26:21 UTC
This is really strange, now I am also unable to reproduce it.
Comment 23 Daniel Pielmeier gentoo-dev 2010-04-06 18:46:57 UTC
Nikos, do you still experience this bug? Or anybody else? I can not reproduce it anymore so I am thinking of closing this bug.
Comment 24 Nikos Chantziaras 2010-04-07 14:55:33 UTC
(In reply to comment #23)
> Nikos, do you still experience this bug?

Yes, /usr/lib64/libedc_ecc.so.1.0 and /usr/lib64/libschily.so.1.0 still get the QA warning.
Comment 25 Daniel Pielmeier gentoo-dev 2010-04-07 17:51:48 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > Nikos, do you still experience this bug?
> 
> Yes, /usr/lib64/libedc_ecc.so.1.0 and /usr/lib64/libschily.so.1.0 still get the
> QA warning.
> 

Okay I did another compile today and got the same warnings as you. So we leave this bug in this state now. Patches welcome of course.
Comment 26 Daniel Pielmeier gentoo-dev 2010-05-18 19:00:53 UTC
+*cdrtools-2.01.01_alpha79 (18 May 2010)
+
+  18 May 2010; Daniel Pielmeier <billie@gentoo.org>
+  -cdrtools-2.01.01_alpha57-r1.ebuild, -cdrtools-2.01.01_alpha77.ebuild,
+  +cdrtools-2.01.01_alpha79.ebuild,
+  -files/cdrtools-2.01.01_alpha34-asneeded.patch,
+  -files/cdrtools-2.01.01_alpha50-asneeded.patch,
+  -files/cdrtools-2.01.01a03-warnings.patch:
+  Version bump. This also fixes bug #289110. Remove old.

Fixed in cdrtools-2.01.01_alpha79. Don't ask how :)