Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289083 - System hangs when I attempt to login: all nvidia drivers EXCEPT 180.29
Summary: System hangs when I attempt to login: all nvidia drivers EXCEPT 180.29
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-14 19:01 UTC by Slava
Modified: 2010-10-12 19:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Slava 2009-10-14 19:01:56 UTC
Hello.  I have a very strange issue.  My pc freezes on any nvidia drivers except version 180.29.  this started happening with kde 4.2.2 on kernel 2.6.29, it happened with kde 4.2.4 and kernel 2.6.30 and now it happened with kde 4.3.2 and kernel 2.6.31 with nvidia drivers 190.x.   I rolled back to 2.6.30.3 and nvidia 180.29 and kde 4.3.2 works.  All the other setups just freeze when i try to log in.  

This isn't an issue where my mouse and keyboard stop working; the whole system hangs, I can't ssh into it or anything.  any thoughts???

I'm running 2 Nvidia 7900 GTX cards in SLI, I use vanilla kernels and the nvidia drivers in portage.  I tried nvidia binaries also, same thing happens.

Reproducible: Always

Steps to Reproduce:
1. set up 2 7900 GTX video cards in SLI
2. set up kde version 4.2.x or higher
3. install nvidia drivers 180.60 or higher

Actual Results:  
The system hangs when you try to log into KDE

Expected Results:  
I should be able to log in and use my computer like I usually do.

As I mentioned before, I'm running 2x7900 GTX cards in SLI.  I have an nforce4 chipset and I'm running nvidia raid 0.  Everything works fine with nvidia 180.29  drivers, the problem happens with any other version (earlier and later),  I posted emerge --info, xorg.conf and errors from the xorg.log below (I don't think the xorg errors are relevant, but maybe someone things otherwise.  The errors are logged when the system is in working state also).



emerge --info
Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.2, glibc-2.10.1-r0, 2.6.30.3 x86_64)
=================================================================
System uname: Linux-2.6.30.3-x86_64-Intel-R-_Pentium-R-_D_CPU_3.00GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 14 Oct 2009 13:45:03 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.4.4-r13, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo ftp://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://lug.mtu.edu/gentoo/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/jokey"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 berkdb blender-game bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr dvdread eds emboss encode evo fam firefox flac foomaticdb fortran ftp gdbm gif gnome gpm gstreamer hal iconv ieee1394 ipv6 isdnlog java joystick jpeg kde ldap libnotify lm_sensors mad mcrypt mhash mikmod mmx modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl php png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vorbis webkit x264 xcb xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS





xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder62)  Wed May 27 01:58:49 PDT 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"    
EndSection                                   

Section "Files"
EndSection     

Section "Module"

#    Load           "freetype"
    Load           "dbe"
    Load           "extmod"
#    Load           "type1"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "SLI" "on"
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "1"
EndSection




errors from Xorg.0.log

(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(EE) Microsoft Comfort Curve Keyboard 2000: failed to initialize for relative axes.
(EE) PreInit returned NULL for "Logitech Logitech Cordless RumblePad 2"
(EE) config/hal: NewInputDeviceRequest failed (8)



If this is an nvidia specific bug and I shouldn't be logging it here, please let me know how I can log a bug with them.
Comment 1 Andreas K. Hüttel gentoo-dev 2010-04-30 18:26:11 UTC
Is this still happening with kde 4.3.5 or 4.4.2?
Please attach your full Xorg.0.log, and your kernel .config and boot messages!

Cc'ing x11 team
Comment 2 Rémi Cardona gentoo-dev 2010-05-01 11:26:09 UTC
The X11 herd doesn't maintain the nvidia binary driver, CCing Doug instead.

Please attach the output of nvidia-bug-report.sh with the latest driver *and* with the one that works for you.

Cheers
Comment 3 Andreas K. Hüttel gentoo-dev 2010-10-12 19:50:20 UTC
No reply for half a year, resolving NEEDINFO.