Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289027 - app-arch/tar-1.20: doesn't create /bin/tar
Summary: app-arch/tar-1.20: doesn't create /bin/tar
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-14 10:10 UTC by Rustam Gubaydullin
Modified: 2009-10-14 12:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rustam Gubaydullin 2009-10-14 10:10:56 UTC
I tried to "emerge -v tar bzip2 gzip". There was a problem - no "tar" application exists in system

Reproducible: Didn't try

Steps to Reproduce:
1. emerge -v tar gzip bzip2 rar unzip zip p7zip xarchiver
Actual Results:  
Emerge failed with error. In log there was a line - "...tar: command not found"

Expected Results:  
Emerge should install tar and other progs

After that I copied "/bin/tar" from my Arch installation and tried to "emerge -v tar"

krypt ~ # equery f tar
[ Searching for packages matching tar... ]
* Contents of app-arch/tar-1.20:
/bin
/bin/gtar
/usr
/usr/sbin
/usr/sbin/gbackup-tar
/usr/sbin/gbackup.sh
/usr/sbin/gdump-remind
/usr/sbin/grestore-tar
/usr/sbin/grmt
/usr/share
/usr/share/doc
/usr/share/doc/tar-1.20
/usr/share/doc/tar-1.20/AUTHORS.bz2
/usr/share/doc/tar-1.20/ChangeLog.1.bz2
/usr/share/doc/tar-1.20/ChangeLog.bz2
/usr/share/doc/tar-1.20/NEWS.bz2
/usr/share/doc/tar-1.20/PORTS.bz2
/usr/share/doc/tar-1.20/README.bz2
/usr/share/doc/tar-1.20/THANKS.bz2
/usr/share/info
/usr/share/info/tar.info-1.bz2
/usr/share/info/tar.info-2.bz2
/usr/share/info/tar.info.bz2
/usr/share/locale
/usr/share/locale/ru
/usr/share/locale/ru/LC_MESSAGES
/usr/share/locale/ru/LC_MESSAGES/tar.mo
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/gtar.1.bz2

There is no "/bin/tar". After I tried "emerge -v =app-arch/tar-1.22" and got the same result's
Comment 1 Rustam Gubaydullin 2009-10-14 10:14:35 UTC
Portage 2.1.6.13 (arch/amd64, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Pentium-R-_Dual_CPU_T2370_@_1.73GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 14 Oct 2009 08:30:02 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib acl acpi alsa amd64 apm atm bcmath big-tables bluetooth bzip2 calendar cdb cgi cleartype consolekit cracklib cryct ctype cups curl curlwrappers dbus dga dhcp directfb djvu elibc_glibc elisp exif fam ffmpeg fortran ftp gd gdbm gif gmp gnutls gstreamer gtk hal hardened iconv idn imap imlib input_devices_evdev input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_synaptics input_devices_wacom ipv6 java jpeg jpeg2k kernel_linux lapack laptop latex libcaca libnotify libssh2 linguas_en linguas_ru mbox mhash mmx mp3 multilib mysql mysqli nas ncurses network networking nis nls nptl nsplugin odbc ogg openal opengl openmp pcntl png posix ppds pulseaudio python qt3support qt4 readline recode samba sasl sdl session sharedext sharedmem simplexml slp smp snmp sockets spell spl sql sse sse2 ssl startup-notification suid svg symlink sysfs syslog tcl tcpd test test-programs threads thunar tidy tiff tk tokenizer truetype unicode usb v4l v4l2 video_cards_radeon wddx xattr xcomposite xml xmlreader xmlrpc xmlwriter xorg xrandr xv zip zlib"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-14 10:25:13 UTC
There's the possibility to use tar from busybox as well:

> /bin/busybox tar --help
BusyBox v1.14.2 (2009-07-10 07:04:44 CEST) multi-call binary

Usage: tar -[czjaZxtvO] [-X FILE] [-f TARFILE] [-C DIR] [FILE(s)]...

Create, extract, or list files from a tar file

Options:
        c       Create
        x       Extract
        t       List
Archive format selection:
        z       Filter the archive through gzip
        j       Filter the archive through bzip2
        a       Filter the archive through lzma
        Z       Filter the archive through compress
File selection:
        f       Name of TARFILE or "-" for stdin
        O       Extract to stdout
        exclude File to exclude
        X       File with names to exclude
        C       Change to directory DIR before operation
        v       Verbose
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2009-10-14 10:45:58 UTC
This bug is INVALID.

arch/amd64 is not a valid profile to use.

Use "eselect profile" to pick a profile from default/linux/
Comment 4 Rustam Gubaydullin 2009-10-14 11:05:20 UTC
(In reply to comment #3)
> This bug is INVALID.
> 
> arch/amd64 is not a valid profile to use.
Please show me where it is written

I'm using arch/amd64 profile in long time with no problem
----
(In reply to comment #2)
> There's the possibility to use tar from busybox as well:
> 
> > /bin/busybox tar --help
Should I create alias?
Comment 5 Rustam Gubaydullin 2009-10-14 11:21:25 UTC
As I reviewed now there is really small differences from default/linux/amd64/10.0 and arch/amd64
(really, arch/amd64 included in default/linux/amd64/10.0; some things in package definitions are missed missed, but they are not so important)
---
Ok, but there is no problem resolve. Emerging busybox doesn't create "/bin/tar" too
Please tell me package name that creates "/bin/tar" and I'll get calm
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2009-10-14 12:12:43 UTC
Don't reopen this again. The tar's ebuild is making decisions based on your profile, and using a invalid profile, like arch/amd64, is causing it to misbehave.
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2009-10-14 12:16:02 UTC
tar's ebuild has: use userland_GNU || myconf="--program-prefix=g"
and userland_GNU is defined in profiles/base/ which you don't get
at all if using invalid profile.
Comment 8 Samuli Suominen (RETIRED) gentoo-dev 2009-10-14 12:26:15 UTC
(In reply to comment #4)
> Please show me where it is written

profiles/profiles.desc lists the valid ones.
Comment 9 Rustam Gubaydullin 2009-10-14 12:50:25 UTC
ok, thanks