Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288660 - net-wireless/rt73-firmware-1.8 patch to add license for redistribution
Summary: net-wireless/rt73-firmware-1.8 patch to add license for redistribution
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mobile Herd (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-11 23:15 UTC by David Abbott
Modified: 2009-10-12 22:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
license.patch (license.patch,1.10 KB, patch)
2009-10-11 23:17 UTC, David Abbott
Details | Diff
license.patch (license.patch,1.06 KB, patch)
2009-10-12 00:11 UTC, David Abbott
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Abbott gentoo-dev 2009-10-11 23:15:06 UTC
Currently the Live DVD can not include the firmware because the license is not included.

Reproducible: Always
Comment 1 David Abbott gentoo-dev 2009-10-11 23:17:01 UTC
Created attachment 206818 [details, diff]
license.patch
Comment 2 David Abbott gentoo-dev 2009-10-12 00:11:26 UTC
Created attachment 206820 [details, diff]
license.patch
Comment 3 David Abbott gentoo-dev 2009-10-12 00:31:04 UTC
Sorry for the noise, the license is included in ${PORTDIR}/licenses
Comment 4 David Abbott gentoo-dev 2009-10-12 21:50:50 UTC
I was a bit premature, seems the license does need to be installed from the tar ball that is downloaded and we can us dodoc just to make it easier. A generic license in ${PORTDIR}licenses is not sufficient. robbat2 did a revision bump for this firmware net-wireless/rt73-firmware-1.8-r1
Comment 5 solar (RETIRED) gentoo-dev 2009-10-12 22:04:03 UTC
(In reply to comment #4)
> I was a bit premature, seems the license does need to be installed from the tar
> ball that is downloaded and we can us dodoc just to make it easier. A generic
> license in ${PORTDIR}licenses is not sufficient. robbat2 did a revision bump
> for this firmware net-wireless/rt73-firmware-1.8-r1

As it's common for "nodoc noinfo noman" to used in live media. The /usr/share/{info,doc,man} dirs often get dropped with those options. 
Looks like ubuntu installs some of them directly in the firmware dirs.