Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288450 - "emerge --depclean" losts set
Summary: "emerge --depclean" losts set
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 288446 288454 (view as bug list)
Depends on:
Blocks: 144480
  Show dependency tree
 
Reported: 2009-10-10 16:16 UTC by Evgeny
Modified: 2011-01-30 14:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeny 2009-10-10 16:16:33 UTC
1. Add set named mygnome with anyone content, for i.e. "gnome-base/gnome-desktop"
2. Install this set: emerge @mygnome
3. Delete this set
4. Reinstall package: emerge gnome-base/gnome-desktop
5. Execute command and look error:

# emerge --depclean -p

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 * 
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence, it is often necessary to run `emerge --update
 * --newuse --deep @system @world` prior to depclean.
Traceback (most recent call last):
  File "/usr/bin/emerge", line 42, in <module>
    retval = emerge_main()
  File "/usr/lib64/portage/pym/_emerge/main.py", line 1368, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 2312, in action_uninstall
    opts, action, valid_atoms, spinner)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 598, in action_depclean
    myopts, action, args_set, spinner)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 643, in calc_depclean
    initial_atoms=getSetAtoms(s))
  File "/usr/lib64/portage/pym/portage/sets/__init__.py", line 179, in getSetAtoms
    raise PackageSetNotFound(s)
PackageSetNotFound: mygnome

6. Add file in sets directory: # touch mygnome
7. emerge --depclean -p — works fine
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-10 16:22:30 UTC
*** Bug 288454 has been marked as a duplicate of this bug. ***
Comment 2 Zac Medico gentoo-dev 2009-10-10 18:34:46 UTC
I case you didn't know, removing mygnome from /var/lib/portage/world_sets will make the error go away.
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-10-11 14:18:59 UTC
*** Bug 288446 has been marked as a duplicate of this bug. ***
Comment 4 Sebastian Luther (few) 2011-01-30 14:02:54 UTC
This bug is no longer present. It now prints:

>>> These are the packages that would be unmerged:
 * Unknown set '@deleted_set' in /var/lib/portage/world_sets

and keeps working.