Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288193 - Put an indicator on how many time a compilation will approximately take
Summary: Put an indicator on how many time a compilation will approximately take
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-08 11:59 UTC by Plopmaster
Modified: 2009-10-08 14:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Plopmaster 2009-10-08 11:59:05 UTC
I make some tests to make compilation faster. For this, I play with a package I know to take some time but not too much : bash. I "knwo" that bash take "some time" to compile. More time that some packages (wget, curl) and less than others (vlc), but I don't know how many time less or more it takes.
I think providing a mean to know how many time a compilation will take should be a good idea. Not in time, as it depends on many stuffs, but for example in 'stars', or range from 1 to 10.
This notation could also help to give an idea on how many time an emerge -DNuv world will approximately takes (so that I can choose to make just a tea or I have the time to make some pastas while upgrading :) )

What do you think ? Is it (easily) feasible ?

Reproducible: Always
Comment 1 Gef 2009-10-08 12:56:39 UTC
Use either genlop from app-portage/genlop or qlop from app-portage/portage-util. Both scripts parse  emerge logs to estimate the time. Genlop can query a remote base (http://gentoo.linuxhowtos.org/compiletimeestimator/) if a package has not been emerged on the system before.
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-10-08 14:56:51 UTC
This is pretty much impossible. So, 1 minute to compile bash on my 8 core box is fast, but what about on my 600mhz laptop? What about the other arches? What about your weird CFLAG that causes compilation to take 3x longer. What about ccache? Catch my drift here?

Resolving as CANTFIX because there are too many variables that makes this request not feasible. Sorry. If you have a better idea, it is more appropriate to bring it up on the respective mailing list(s).