Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287746 - net-misc/drivel-3.0.0 fails to build.
Summary: net-misc/drivel-3.0.0 fails to build.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: fortify-source werror
  Show dependency tree
 
Reported: 2009-10-05 11:55 UTC by Joost Ruis
Modified: 2009-10-11 02:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
log. (log.txt,12.25 KB, text/plain)
2009-10-05 11:55 UTC, Joost Ruis
Details
/var/tmp/portage/net-misc/drivel-3.0.0/temp/build.log (build.log,40.15 KB, text/plain)
2009-10-05 18:51 UTC, Justin Lecher
Details
emerge.info (emerge.info,12.24 KB, text/plain)
2009-10-05 18:51 UTC, Justin Lecher
Details
log after reopening the bug. (log.txt,12.50 KB, text/plain)
2009-10-06 07:31 UTC, Joost Ruis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joost Ruis 2009-10-05 11:55:28 UTC
I also tried with MAKEOPTS="-j1" but still fails, no clue here.

Attached a log.

Reproducible: Always




Portage 2.2_rc42 (default/linux/amd64/2008.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.25-sabayon x86_64)
=================================================================
System uname: Linux-2.6.25-sabayon-x86_64-Intel-R-_Xeon-R-_CPU_X3220_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 04 Oct 2009 16:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p33
dev-java/java-config: 1.3.7-r1, 2.1.9-r1
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r5
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=x86-64 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/entropy /opt/openfire/resources/security/ /usr/lib64/fax /usr/share/config /usr/share/config/kdm /usr/share/xbmc/userdata /var/bind /var/lib/hsqldb /var/spool/fax/etc /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=x86-64 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests collision-protect distcc distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo/ http://130.59.10.35/ftp/mirror/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://212.219.56.139/sites/www.ibiblio.org/gentoo/"
LANG="en_US"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1,--as-needed"
LINGUAS="en en_US af ar az bg bn br bs ca cs cy da de el en_GB eo es et eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta tg tr uk uz vi zh_CN zh_TW es_AR es_ES fy_NL ga_IE gu gu_IN nb_NO nn_NO pt_PT sv_SE zh"
MAKEOPTS="-s -j20"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/enlightenment /usr/local/portage/layman/sabayon"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7Zip X a52 aac aalib accessibility acl acpi aiglx aim alsa amd64 artswrappersuid audiofile avahi bash-completion berkdb bidi bluetooth bzip2 cairo cdda cddb cdr chm cjk cli config_wizard consolekit cpudetection cracklib crypt css cups dbox2 dbus dga dri dts dv dvb dvd dvdr dvdread dvi dxr3 emboss encode extramodules fam fame fat ffmpeg fftw firefox flac flash foomatic-db fortran freetype gcj gdbm gif gimpprint gmp gnutls gphoto2 gpm gs gsm gstreamer gtk hal hfs iconv icq ieee1394 imap inotify ipod ipv6 irc irda isdnlog jabber jack jfs jingle joystick jpeg kde kdeenablefinal kdehiddenvisibility kerberos kipi lame lcd ldap libnotify live lj lm_sensors logitech-mouse lzo mad mail matroska mikmod mjpeg mmx mng modules mozdevelop mp3 mp3rtp mp4 mpeg msn mudflap multilib musepack musicbrainz ncurses network new-login nls nptl nptlonly nsplugin ntfs ogg openal openexr opengl openmp pam pcmcia pcre pda pdf perl png policykit povray ppds pppd pulseaudio python qt3support qt4 quicktime quotas rar rdesktop readline reflection reiserfs rss scanner sdl session slp sms speex spell spl sse sse2 ssl startup-notification stream svg sysfs tcpd theora thunar tiff tracker truetype udev unicode usb v4l v4l2 visualization voice vorbis weather wifi wmf x264 xcb xfs xine xinerama xml xorg xpm xprint xulrunner xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="emu10k1x darla20 darla24 emu10k1 gina20 gina24 hdsp hdspm ice1712 indigo indigoio layla20 layla24 mia mixart mona pcxhr rme32 rme96 sb16 sbawe sscape usbusx2y vx222 usb-usx2y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11 adc65 aox barbie canon clicksmart310 digigr8 digita directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 konica largan lg_gsm mars mustek pccam300 pccam600 ptp2 ricoh samsung sierra smal sonix soundvision spca50x sq905 stv0674 stv0680 sx330z template" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US af ar az bg bn br bs ca cs cy da de el en_GB eo es et eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta tg tr uk uz vi zh_CN zh_TW es_AR es_ES fy_NL ga_IE gu gu_IN nb_NO nn_NO pt_PT sv_SE zh" LIRC_DEVICES="audio audio_alsa serial" USERLAND="GNU" VIDEO_CARDS="fbdev vesa radeonhd" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Joost Ruis 2009-10-05 11:55:42 UTC
Created attachment 206073 [details]
log.
Comment 2 Justin Lecher gentoo-dev 2009-10-05 18:50:14 UTC
I can reproduce it.
Surely a -Werror thing.
Comment 3 Justin Lecher gentoo-dev 2009-10-05 18:51:28 UTC
Created attachment 206163 [details]
/var/tmp/portage/net-misc/drivel-3.0.0/temp/build.log

build.log
Comment 4 Justin Lecher gentoo-dev 2009-10-05 18:51:34 UTC
Created attachment 206165 [details]
emerge.info
Comment 5 Hans de Graaff gentoo-dev 2009-10-05 18:57:48 UTC
(In reply to comment #2)
> I can reproduce it.
> Surely a -Werror thing.

Yes, this is a harmless warning that manifests with gcc 4.4.x. I've just committed a fix to the ebuild to turn on the error-on-warning stuff, so that this is again a warning and the build should succeed, as per upstream's recommendation. Will be fixed upstream for the next release.
Comment 6 Joost Ruis 2009-10-06 06:56:42 UTC
Not fixed. 
Still getting same problem.
Comment 7 Justin Lecher gentoo-dev 2009-10-06 07:02:14 UTC
PLease attach a build.log from the reemerge with a synced tree. Thanks.
Comment 8 Joost Ruis 2009-10-06 07:31:26 UTC
Created attachment 206221 [details]
log after reopening the bug.
Comment 9 Justin Lecher gentoo-dev 2009-10-06 07:47:13 UTC
Still not fixed,
it is still using
 -Wdeclaration-after-statement -Wcast-align -Wsign-compare  -Wmissing-prototypes -Wmissing-declarations _-Werror_ -Wmissing-include-dirs  -Winline -Wnested-externs -Wpointer-arith  -Wmissing-field-initializers.

Was it tested before commit? Just have to ask!
Comment 10 Romain Perier (RETIRED) gentoo-dev 2009-10-06 09:57:31 UTC
+06 Oct 2009; Romain Perier <mrpouet@gentoo.org>
+  drivel-3.0.0.ebuild, +files/drivel-3.0.0-compile-warnings.patch:
+  Fix bug #287746, compile-warnings support was automagic, which forced
+  -Werror cflag to be used (and compilation to fail). Fix some QA.

Fixed in the main tree without a bump, I tested it of course and it should work now, thanks for reporting ;)

graaff: as backup herd, we fixed it :)

I also fixed some QA :

- G2CONF was in global scope (put in portage's cache), that's so bad because $(use_with dbus) is dynamic, all things in the cache must be static.
 
Comment 11 Hans de Graaff gentoo-dev 2009-10-06 09:59:15 UTC
(In reply to comment #9)

> Was it tested before commit? Just have to ask!

Yes, I tested it, but it turns out that there were two separate things adding -Werror, and I missed the second one, which Romain now fixed.
Comment 12 Mart Raudsepp gentoo-dev 2009-10-11 02:02:30 UTC
Upstream shouldn't enable -Werror by default in stable release versions, maybe you can get them to change that if they still do it.