Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287710 - sys-power/pm-utils-1.2.5 failed to wake up the machine after suspending
Summary: sys-power/pm-utils-1.2.5 failed to wake up the machine after suspending
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-05 06:36 UTC by peng shao
Modified: 2010-01-25 00:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
the log part from /var/log/messages (suspend.log,30.63 KB, text/plain)
2009-10-05 06:36 UTC, peng shao
Details
pm-suspend.log (pm-suspend.log,3.12 KB, text/plain)
2009-10-05 06:37 UTC, peng shao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peng shao 2009-10-05 06:36:05 UTC
My machine is desktop computer with a nvidia gtx9800+ card with driver
x11-drivers/nvidia-drivers-185.18.31  USE="acpi gtk (multilib) -custom-cflags
and I found I could successfully suspend my machine through system-->shutdown-->suspend. But when I tried to wakeup my machine by pressing the power button, I could not re-start the X normally. Sometimes the whole system just crashed down with a black screen of no response, sometimes I could return my gnome desktop, but could not launch many applications normaly and when I tried to press ctrl+alt+backspace to restart the X, I was promoted to the errror messages showed in my attachment. 

I am not sure it has anything to do with my nvidia card.. I found the following wiki article
http://www.gentoo-wiki.info/Pm-utils
but unfortunately all of the urls to freedesktop seem to be dead.


I checked through my /var/log/messages and copied a part of logs of typical failure to wake-up my machine. It seems that I met trouble at line 262, and at the last line of that log I have to press the reset button to restart my machine because at that time I have nothing but a black screen.

I wish I have provided enough information to my problem, and please tell me what else I can provide for you to better examine my problem, Thank you very much

Reproducible: Always

Steps to Reproduce:
1.suspend
2.press the power buttom
3.

Actual Results:  
the system crashed down with a black screen, or some problem as in the description

Expected Results:  
the machine is waked up normally

emerge --info 
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.30-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r6-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 03 Oct 2009 01:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p33
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.4.4-r13, 2.6.3, 3.1.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://www.cyberuse.com/gentoo/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dvd dvdr eds emboss encode esd evo fam firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv isdnlog jpeg ldap libnotify mad mikmod mmx modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png policykit ppds pppd python qt3support quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vim-syntax vorbis x264 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ice1712" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

related packages
sys-apps/hal-0.5.13-r2  USE="X acpi apm consolekit crypt laptop policykit -debug -dell -disk-partition -doc (-selinux)" 
sys-power/pm-utils-1.2.5  USE="alsa -debug -networkmanager -ntp" VIDEO_CARDS="-intel -radeon"
gnome-extra/gnome-power-manager-2.26.4  USE="X policykit -debug -doc -test"
Comment 1 peng shao 2009-10-05 06:36:50 UTC
Created attachment 206059 [details]
the log part from /var/log/messages

I cut this typical part from /var/log/messages
Comment 2 peng shao 2009-10-05 06:37:32 UTC
Created attachment 206061 [details]
pm-suspend.log

it seems that at least the suspending is normal
Comment 3 Rémi Cardona (RETIRED) gentoo-dev 2009-10-05 06:49:22 UTC
Please either set the assign field correctly or let bug wranglers do it.

Thanks
Comment 4 peng shao 2009-10-05 06:54:42 UTC
(In reply to comment #3)
> Please either set the assign field correctly or let bug wranglers do it.
> 
> Thanks
> 

I apologize for an inconvenience but I am sorry that I did not understand what 
you suggested me to do :( Could you please tell me where I made the mistakes? Thank you very much.
Comment 5 Jonathan Callen (RETIRED) gentoo-dev 2009-10-05 07:27:05 UTC
The reason this bug was assigned improperly is because it was filed under component "GNOME", and I do not believe that the filer has appropriate privileges to change the assignee to anything other than the default of gnome@g.o (most components default to bug-wranglers@g.o, but Games, GNOME, Hardened, Java, KDE, and Printing default to their respective herds, which can result in incorrect assignments).

Long story short, I don't think the bug filer actually did anything wrong, except for placing the bug under the wrong component, which is not completely unheard of.
Comment 6 peng shao 2009-10-05 07:37:16 UTC
(In reply to comment #5)
> The reason this bug was assigned improperly is because it was filed under
> component "GNOME", and I do not believe that the filer has appropriate
> privileges to change the assignee to anything other than the default of
> gnome@g.o (most components default to bug-wranglers@g.o, but Games, GNOME,
> Hardened, Java, KDE, and Printing default to their respective herds, which can
> result in incorrect assignments).
> 
> Long story short, I don't think the bug filer actually did anything wrong,
> except for placing the bug under the wrong component, which is not completely
> unheard of.
> 

Thank you very much for pointing out my mistake. My wild guess is this might be a bug about the kernel, so I changed it into Core System. I wish I did not make mistake again. I apologize for my mistake again.

By the way, I do not know if I met the same bug as the one mentioned below:

http://bugzilla.kernel.org/show_bug.cgi?id=13149

Thank you.


Comment 7 Anton Bolshakov 2009-11-05 00:41:48 UTC
I managed to fix it using workaround described in https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/417599

Basically, there are 2 bugs in have_kms function. First, it detects KMS falsely, second there is a typo fixed by upstream (http://cgit.freedesktop.org/pm-utils/commit/?id=e5cdb5bb6a573a36b0c872c889c8b8f25009cc45).

So, I put "return 1" in front of that function and resume has started to work.

ps. echo "mem" > /sys/power/state worked fine.

Freedesktop, this bug might lead to filesystem corruption, please consider fixing it rather urgent.
Comment 8 Gilles Dartiguelongue gentoo-dev 2010-01-24 21:54:34 UTC
fixed in 1.2.6.1, thanks for reporting.
Comment 9 Anton Bolshakov 2010-01-25 00:26:55 UTC
(In reply to comment #8)
> fixed in 1.2.6.1, thanks for reporting.
> 

It would be nice if you could bump this version to the portage then. Thanks..