Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 287053 - [gnome overlay] gnome-base/gnome-control-center-2.28.0 does not compile/link gnome_bg_changes_with_time
Summary: [gnome overlay] gnome-base/gnome-control-center-2.28.0 does not compile/link ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-09-30 11:11 UTC by Michael Weber (RETIRED)
Modified: 2009-10-30 18:58 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,117.02 KB, text/plain)
2009-09-30 11:12 UTC, Michael Weber (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weber (RETIRED) gentoo-dev 2009-09-30 11:11:28 UTC
The fbuild from gnome overlay does not compile, maybe missing depenency.

Reproducible: Always

Steps to Reproduce:
upgrade fromgnome-base/gnome-control-center-2.27.91 to gnome-base/gnome-control-center-2.28.0
Actual Results:  

/bin/sh ../../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -DGNOME_DESKTOP_USE_UNSTABLE_API -march=core2 -mfpmath=sse -mieee-fp -O2 -pipe -Wall -export-dynamic -Wl,-O1 -o gnome-appearance-properties appearance-desktop.o appearance-font.o appearance-main.o appearance-themes.o appearance-style.o appearance-ui.o gedit-message-area.o gnome-wp-info.o gnome-wp-item.o gnome-wp-xml.o theme-installer.o theme-save.o theme-util.o ../../libwindow-settings/libgnome-window-settings.la ../../capplets/common/libcommon.la ../../capplets/common/libcommon.la -lgconf-2 -lxml2 -lgnome-desktop-2 -lgtk-x11-2.0 -lstartup-notification-1 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0    -lSM -lICE  -lX11  -lXcursor   -lXi   -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0   -lgconf-2 -lxml2 -lgnome-desktop-2 -lgtk-x11-2.0 -lstartup-notification-1 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lXft -lXrender -lfontconfig -lfreetype -lX11   -lmetacity-private -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0
libtool: link: x86_64-pc-linux-gnu-gcc -DGNOME_DESKTOP_USE_UNSTABLE_API -march=core2 -mfpmath=sse -mieee-fp -O2 -pipe -Wall -Wl,-O1 -o .libs/gnome-appearance-properties appearance-desktop.o appearance-font.o appearance-main.o appearance-themes.o appearance-style.o appearance-ui.o gedit-message-area.o gnome-wp-info.o gnome-wp-item.o gnome-wp-xml.o theme-installer.o theme-save.o theme-util.o -Wl,--export-dynamic  ../../libwindow-settings/.libs/libgnome-window-settings.so -L/usr/lib64 ../../capplets/common/.libs/libcommon.a /var/tmp/portage/gnome-base/gnome-control-center-2.28.0/work/gnome-control-center-2.28.0/libwindow-settings/.libs/libgnome-window-settings.so /usr/lib64/libgnome-menu.so /usr/lib64/libxml2.so /usr/lib64/libgnome-desktop-2.so /usr/lib64/libXft.so /usr/lib64/libmetacity-private.so /usr/lib64/libgconf-2.so /usr/lib64/libORBit-2.so /usr/lib64/libgthread-2.0.so -lrt /usr/lib64/libdbus-glib-1.so -lnsl /usr/lib64/libdbus-1.so /usr/lib64/libstartup-notification-1.so /usr/lib64/libXcomposite.so /usr/lib64/libXdamage.so /usr/lib64/libXcursor.so /usr/lib64/libXfixes.so /usr/lib64/libXrandr.so /usr/lib64/libXinerama.so /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgdk-x11-2.0.so /usr/lib64/libatk-1.0.so /usr/lib64/libgdk_pixbuf-2.0.so /usr/lib64/libgio-2.0.so -lresolv /usr/lib64/libpangocairo-1.0.so /usr/lib64/libpangoft2-1.0.so /usr/lib64/libcairo.so /usr/lib64/libpixman-1.so /usr/lib64/libdirectfb.so /usr/lib64/libfusion.so /usr/lib64/libdirect.so /usr/lib64/libglitz-glx.so /usr/lib64/libGL.so /usr/lib64/libXmu.so /usr/lib64/libXt.so /usr/lib64/libSM.so -luuid /usr/lib64/libICE.so /usr/lib64/libXi.so /usr/lib64/libXext.so -lpthread /usr/lib64/libglitz.so /usr/lib64/libpng12.so /usr/lib64/libxcb-render-util.so /usr/lib64/libxcb-render.so /usr/lib64/libXrender.so /usr/lib64/libX11.so /usr/lib64/libxcb-xlib.so /usr/lib64/libxcb.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so /usr/lib64/libpango-1.0.so -lm /usr/lib64/libfontconfig.so /usr/lib64/libfreetype.so -lz /usr/lib64/libexpat.so /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so -ldl /usr/lib64/libglib-2.0.so -pthread
appearance-desktop.o: In function `buttons_cell_data_func':
appearance-desktop.c:(.text+0x1fbe): undefined reference to `gnome_bg_changes_with_time'
gnome-wp-item.o: In function `gnome_wp_item_update_description':
gnome-wp-item.c:(.text+0x105): undefined reference to `gnome_bg_changes_with_time'
gnome-wp-item.o: In function `gnome_wp_item_get_frame_thumbnail':
gnome-wp-item.c:(.text+0x2dc): undefined reference to `gnome_bg_create_frame_thumbnail'
gnome-wp-item.c:(.text+0x2ed): undefined reference to `gnome_bg_changes_with_time'
collect2: ld returned 1 exit status

Expected Results:  
clean install

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.31-gentoo-io.4 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-io.4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 30 Sep 2009 10:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mfpmath=sse -mieee-fp -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -mfpmath=sse -mieee-fp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 2 --keep-going"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://nash.fs.lmu.de/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--ipv6"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/sunrise /usr/local/portage/layman/gnome /usr/local/portage/layman/xmw /usr/local/portage/layman/x11"
SYNC="rsync://nash.fs.lmu.de/gentoo-portage/"
USE="X a54 aac aalib acl acpi alsa amd64 bash-completion berkdb bluetooth bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt cups dbus dga directfb djvu doc dri dts dv dvb dvd dvdr dvdread encode exif fbcon ffmpeg fftw flac fontconfig fortran gdbm gif gimp glut gnome gnome-keyring gnutls gphoto2 gpm gs gtk hal iconv id3tag imagemagick ipod ipv6 isdnlog java java6 jbig joystick jpeg jpeg2k lame latex lcms libsamplerate lm_sensors lzma lzo mad mikmod mmap mmx mng modules mp3 mpeg mplayer mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg openal openexr opengl openmp pam pch pcmcia pcre pdf perl png postgres pppd python qt3 qt4 quicktime raw readline reflection rle samba sdl session smp speex spell spl sqlite sse sse2 ssl subversion svg symlink sysfs syslog tcl tcpd theora threads tiff tk truetype unicode usb vim-syntax vorbis wavpack x264 xcb xine xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="intel-hda" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Michael Weber (RETIRED) gentoo-dev 2009-09-30 11:12:47 UTC
Created attachment 205652 [details]
build.log
Comment 2 Romain Perier (RETIRED) gentoo-dev 2009-09-30 12:01:59 UTC
- What is your version of gnome-desktop ?

- Could you paste the output of the following command line  ? :
$ objdump -T /usr/lib64/libgnome-desktop-2.so | grep gnome_bg_changes_with_time 
Comment 3 Michael Weber (RETIRED) gentoo-dev 2009-09-30 12:23:13 UTC
(In reply to comment #2)
> - What is your version of gnome-desktop ?
> 
> - Could you paste the output of the following command line  ? :
> $ objdump -T /usr/lib64/libgnome-desktop-2.so | grep gnome_bg_changes_with_time 
> 
I hav two machines, the first already head gnome-desktop-2.28.0 and the objdump does not report the gnome_bg_changes_with_time.
pandora ~ # la /usr/lib64/libgnome-desktop*
-rw-r--r-- 1 root root 2.1K 2009-09-30 03:43 /usr/lib64/libgnome-desktop-2.la
lrwxrwxrwx 1 root root   28 2009-09-30 03:43 /usr/lib64/libgnome-desktop-2.so -> libgnome-desktop-2.so.11.4.2
lrwxrwxrwx 1 root root   28 2009-09-30 03:43 /usr/lib64/libgnome-desktop-2.so.11 -> libgnome-desktop-2.so.11.4.2
-rwxr-xr-x 2 root root 162K 2009-09-30 03:43 /usr/lib64/libgnome-desktop-2.so.11.2.6
-rwxr-xr-x 2 root root 162K 2009-09-30 03:43 /usr/lib64/libgnome-desktop-2.so.11.4.2
Ok, two versions. revdep-rebuild -i states consitency. 
rm /usr/lib64/libgnome-desktop-2.so.11.2.6
The problem still exists.

The second had gnome-desktop-2.27.91, I've upgraded manually to 2.28.0, but the error was still there. I've reinstalled the gnome-desktop with emerge -avC && emerge -av1, and now gnome-control-center-2.28.0 compiles fine.

I would suggest to update the dependency.
 --- gnome-control-center-2.28.0.ebuild.orig     2009-09-30 13:51:10.000000000 +0200
+++ gnome-control-center-2.28.0.ebuild  2009-09-30 13:51:25.000000000 +0200
@@ -27,7 +27,7 @@
        >=x11-wm/metacity-2.23.1
        >=gnome-base/gnome-panel-2.0
        >=gnome-base/libgnomekbd-2.27.4
-       >=gnome-base/gnome-desktop-2.25.1
+       >=gnome-base/gnome-desktop-2.28.0
        >=gnome-base/gnome-menus-2.11.1
        gnome-base/gnome-settings-daemon

But I have no glue which file caches the nonexistence of the new functions.
Comment 4 Romain Perier (RETIRED) gentoo-dev 2009-09-30 12:35:45 UTC
That's not exactly a dep on gnome-desktop-2.28.0 but on 2.27.91 :) (see upstream bug above)
Comment 5 Tommaso Pasini 2009-09-30 15:03:09 UTC
Same problem here (I'm on x86), but the fix doesn't work, I have gnome-desktop-2.28.

objdump -T /usr/lib/libgnome-desktop-2.so | grep gnome_bg_changes_with_time doesn't show anything.
Comment 6 Romain Perier (RETIRED) gentoo-dev 2009-09-30 16:59:06 UTC
(In reply to comment #5)
> Same problem here (I'm on x86), but the fix doesn't work.

It's a upstream fix, and 2.28.0 >= 2.27.91 so the configure script works it's normal...
Comment 7 Tommaso Pasini 2009-09-30 22:36:28 UTC
I'm sorry, I didn't read the fix correctly: re-emerging gnome-desktop didn't work, but unmerging and emerging it back did. That's quite weird, but as long as it works it's ok for me.
Comment 8 Patrick Fourniols 2009-10-01 06:54:51 UTC
remerging gnome-desktop don't work for me until i do:
rm /usr/lib/libgnome-desktop-2.so.11.2.6
before compiling gnome-control-center or do 
revddep-rebuild --library /usr/lib/libgnome-deskop-2.so
gnome-desktop reinstall /usr/lib/libgnome-desktop-2.so.11.2.6 and that seems to be the pb (circular dependency?)
Comment 9 Romain Perier (RETIRED) gentoo-dev 2009-10-01 16:57:54 UTC
(In reply to comment #7)
> I'm sorry, I didn't read the fix correctly: re-emerging gnome-desktop didn't
> work, but unmerging and emerging it back did. That's quite weird, but as long
> as it works it's ok for me.
> 

@herd: portage or paludis issue ? ... I meant that's a bit weird...
Comment 10 Zsolti 2009-10-01 22:02:23 UTC
unmerging gnome-base/gnome-desktop, re-merging and revdep-rebuild --library libgnome-desktop-2.so.11 did it for me.
Comment 11 Jose daLuz 2009-10-01 22:48:26 UTC
(In reply to comment #9)
> @herd: portage or paludis issue ? ... I meant that's a bit weird...
> 
I had the build issue with gnome-control-center 2.28.0, used paludis to uninstall/reinstall gnome-desktop, ran reconcilio --library libgnome-desktop-2.so.11, and gnome-control-center 2.28.0 built with no problem. So I don't think that is a paludis issue.
Comment 12 Rémi Cardona (RETIRED) gentoo-dev 2009-10-02 06:15:00 UTC
probably a gnome-desktop upgrade that changed ABI (again...) but without a proper soname bump. Or maybe revdep-rebuild wasn't properly executed after the upgrade.

Or something like that.

IMHO, nothing we can really do about.
Comment 13 Flo Gravo 2009-10-05 13:54:57 UTC
(In reply to comment #10)
> unmerging gnome-base/gnome-desktop, re-merging and revdep-rebuild --library
> libgnome-desktop-2.so.11 did it for me.
> 
Worked for me, too.
Comment 14 Gilles Dartiguelongue gentoo-dev 2009-10-26 23:12:59 UTC
fixed in overlay and upstream. Closing.
Comment 15 walt 2009-10-30 18:58:01 UTC
FWIW, I just got hit with this today on ~AMD64, and I'm very happy I found this
bug report :o)  The same fix worked for me, too.