Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 286174 - mail-client/evolution-2.26.3 failed to compile due to linking problem with libSM.so
Summary: mail-client/evolution-2.26.3 failed to compile due to linking problem with li...
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-24 07:57 UTC by darkgrave
Modified: 2009-09-28 07:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (mail-client:evolution-2.26.3:20090925-073603.log,449.77 KB, text/plain)
2009-09-25 08:47 UTC, darkgrave
Details

Note You need to log in before you can comment on or make changes to this bug.
Description darkgrave 2009-09-24 07:57:48 UTC
mail-client/evolution-2.26.3 failed to compile with the following error:

/usr/lib64/libSM.so: undefined reference to `uuid_unparse_lower@UUID_1.0'
/usr/lib64/libSM.so: undefined reference to `uuid_generate@UUID_1.0'
ld returned 1 exit status

Reproducible: Always

Steps to Reproduce:
1.emerge evolution
Actual Results:  
It fails to compile

Expected Results:  
Compile successfully

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.4.1, glibc-2.10.1-r0, 2.6.31-gentoo-dark-20090923 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-dark-20090923-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-gentoo-2.0.1
Timestamp of tree: Thu, 24 Sep 2009 06:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p33
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r2, 3.1.1-r1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/                                    http://gentoo.mirror.solnet.ch                                                http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/                          http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/                          http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/                    http://ftp.snt.utwente.nl/pub/os/linux/gentoo                                 http://gentoo.supp.name/                                                      http://ftp.ntua.gr/pub/linux/gentoo/                                          http://ftp.heanet.ie/pub/gentoo/                                              http://ftp.romnet.org/gentoo/                                 "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 bash-completion berkdb bzip2 cairo cdr cli cracklib crypt cups custom-optimization dbus dvd dvdr emacs gdbm gif gnome gpm gtk gtk2 hal iconv isdnlog jpeg keyring libnotify mmx mmxext mng modules mp3 mpeg mplayer mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf png python readline session sockets spl sse sse2 ssl svg sysfs szip tcpd tiff truetype unicode usb vorbis xinerama xml xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authz_host authz_user charset_lite                    deflate dir env filter headers include mime mime_magic                         negotiation rewrite setenvif                                  " ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-09-24 08:31:46 UTC
did you just upgraded to libxcb-1.4 ? In this case please follow the upgrade guide to the letter and to the end [1]. If it's not the case, please run revdep-rebuild and then retry building evolution.

[1] http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml
Comment 2 darkgrave 2009-09-24 14:55:57 UTC
(In reply to comment #1)
I have ollowed the guide and my system is updated. revdep-rebuild says all is up-to-date. The problem is that when I launch eveolution it says:

evolution: error while loading shared libraries: libssl3.so.12: cannot open shared object file: No such file or directory

Trying to recompile it fails with the original error.
Comment 3 Rémi Cardona gentoo-dev 2009-09-24 15:10:42 UTC
Please run the following command :

  revdep-rebuild -L libssl3.so.12

Running just revdep-rebuild with no arguments won't be enough.

Thanks
Comment 4 darkgrave 2009-09-24 17:54:12 UTC
(In reply to comment #3)

I've run revdep-rebuild -L libssl3.so.12 and the output was:



* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries using libssl3.so.12
* will be emerged.

* Collecting system binaries and libraries
* Found existing 1_files.rr
* Checking dynamic linking 
* Found existing 3_broken.rr.
* Assigning files to packages
*  !!! /usr/libexec/gnome-screensaver/webcollage-helper not owned by any package is broken !!!
*   /usr/libexec/gnome-screensaver/webcollage-helper -> (none)
* Generated new 4_raw.rr and 4_owners.rr
* Found some broken files, but none of them were associated with known packages
* Unable to proceed with automatic repairs.
* The broken files are listed in 4_owners.rr

The error about the screensaver is not relevant here.

Evolution still does not work or compile!
Comment 5 Sankara Krishnamoorthy 2009-09-24 18:03:43 UTC
Can the reporter add the info for the following command?
ldd /usr/lib64/libSM.so.6.0.0
Comment 6 darkgrave 2009-09-25 06:52:40 UTC
I have libSM version 6.0.1, so my lib file is named 'libSM.so.6.0.1'.
Files matching 'libSM' installed on /usr/lib64:

libSM.a
libSM.la
libSM.so -> libSM.so.6.0.1
libSM.so.6 -> libSM.so.6.0.1
libSM.so.6.0.1

Output of ldd /usr/lib64/libSM.so.6.0.1
linux-vdso.so.1 =>  (0x00007fff2eb8c000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00007febd042a000)
libuuid.so.1 => /lib/libuuid.so.1 (0x00007febd0225000)
libc.so.6 => /lib/libc.so.6 (0x00007febcfed5000)
/lib64/ld-linux-x86-64.so.2 (0x00007febd0871000)
Comment 7 Rémi Cardona gentoo-dev 2009-09-25 07:00:21 UTC
Could you rebuild whichever package libuuid belongs too (qfile /usr/lib/...) and libSM ?

Thanks
Comment 8 darkgrave 2009-09-25 07:26:15 UTC
# qfile /usr/lib64/libSM.so.6.0.1
x11-libs/libSM (/usr/lib64/libSM.so.6.0.1)

# qfile /usr/lib64/libuuid.so
sys-apps/util-linux (/usr/lib64/libuuid.so)

# emerge util-linux libSM

Made! Evolution still fails to compile with the same:

/usr/lib64/libSM.so: undefined reference to `uuid_unparse_lower@UUID_1.0'
/usr/lib64/libSM.so: undefined reference to `uuid_generate@UUID_1.0'
collect2: ld returned 1 exit status
make[3]: *** [test-dateedit] Error 1
make[3]: *** Waiting for unfinished jobs....
/usr/lib64/libSM.so: undefined reference to `uuid_unparse_lower@UUID_1.0'
/usr/lib64/libSM.so: undefined reference to `uuid_generate@UUID_1.0'
collect2: ld returned 1 exit status
make[3]: *** [test-calendar] Error 1
Comment 9 Rémi Cardona gentoo-dev 2009-09-25 07:29:48 UTC
$ objdump -T /usr/lib/libSM.so.6.0.1 | grep uuid
00000000      DF *UND*	00000000  UUID_1.0    uuid_generate
00000000      DF *UND*	00000000  UUID_1.0    uuid_unparse_lower

Could you run the same command and paste the output here?

Oh and could you rebuild util-linux and libSM without ccache enabled?

Thanks
Comment 10 darkgrave 2009-09-25 07:49:54 UTC
Output of 'objdump -T /usr/lib/libSM.so.6.0.1 | grep uuid' on my computer:
0000000000000000      DF *UND*	0000000000000000  UUID_1.0    uuid_generate
0000000000000000      DF *UND*	0000000000000000  UUID_1.0    uuid_unparse_lower

ccache is now disabled!
remerged util-lix and libSM with no problems.
Trying to remerge evolution it failed again with the same error.

libuuid files on my computer:
/usr/lib64/libuuid.so
/usr/lib64/libuuid.a
/usr/lib32/libuuid.so
/lib64/libuuid.so.1.2
/lib64/libuuid.so.1
/lib64/libuuid.so.1.3.0
/lib64/libuuid.so
/lib32/libuuid.so.1.2
/lib32/libuuid.so.1
/lib32/libuuid.so
Comment 11 Rémi Cardona gentoo-dev 2009-09-25 08:08:28 UTC
Please attach the full build.log

Thanks
Comment 12 darkgrave 2009-09-25 08:47:46 UTC
Created attachment 205190 [details]
Build log
Comment 13 Sankara Krishnamoorthy 2009-09-25 15:40:32 UTC
i have libuuid from e2fsprogs;
$ qfile /usr/lib64/libuuid.so  
sys-libs/e2fsprogs-libs (/usr/lib64/libuuid.so)
$ evolution --version
GNOME evolution 2.26.3

As you can see my setup can compile evolution successfully, it may be worthwhile to get rid of the libuuid from util-linux and try the one from e2fsprogs-libs.
Comment 14 Rémi Cardona gentoo-dev 2009-09-25 16:32:16 UTC
(In reply to comment #13)
> As you can see my setup can compile evolution successfully, it may be
> worthwhile to get rid of the libuuid from util-linux and try the one from
> e2fsprogs-libs.

No, newer versions of e2fsprogs-libs no longer have libuuid.

@darkgrave, could you run qfile on each libuuid file you mentioned earlier to see if any don't belong to any package?

Thanks
Comment 15 Romain Perier (RETIRED) gentoo-dev 2009-09-25 16:45:50 UTC
e2fsprogs-libs version ?

sys-libs/e2fsprogs-libs-1.41.9 for me.

$ qlist e2fsprogs-libs | grep '\.so$'
 /usr/lib64/libcom_err.so
 /usr/lib64/libss.so

As remi said, the newer e2fsprogs-libs no longer have libuuid
Comment 16 darkgrave 2009-09-25 16:52:22 UTC
I remember that I've recently switch libuuid from e2fsprogs to util-linux.

10 files matching libuuid
-------------------------
4 files bound to util-linux
4 files bound to emul-linux-x86-baselibs
2 orphan files

# qfile                       \
    /usr/lib64/libuuid.so     \
    /usr/lib64/libuuid.a      \
    /usr/lib32/libuuid.so     \
    /lib64/libuuid.so.1.2     \
    /lib64/libuuid.so.1       \
    /lib64/libuuid.so.1.3.0   \
    /lib64/libuuid.so         \
    /lib32/libuuid.so.1.2     \
    /lib32/libuuid.so.1       \
    /lib32/libuuid.so

Output:
sys-apps/util-linux (/usr/lib64/libuuid.a)
sys-apps/util-linux (/usr/lib64/libuuid.so)
sys-apps/util-linux (/lib64/libuuid.so.1)
sys-apps/util-linux (/lib64/libuuid.so.1.3.0)
app-emulation/emul-linux-x86-baselibs (/usr/lib32/libuuid.so)
app-emulation/emul-linux-x86-baselibs (/lib32/libuuid.so.1.2)
app-emulation/emul-linux-x86-baselibs (/lib32/libuuid.so.1)
app-emulation/emul-linux-x86-baselibs (/lib32/libuuid.so)


I guess these are orphan files:
  /lib64/libuuid.so.1.2
  /lib64/libuuid.so
Comment 17 Rémi Cardona gentoo-dev 2009-09-25 17:00:58 UTC
(In reply to comment #16)
> I guess these are orphan files:
>   /lib64/libuuid.so.1.2
>   /lib64/libuuid.so

Please remove those files and try to rebuild libSM and evo.

If that doesn't work, please temporarily unmerge emul-linux-x86-baselibs (use quickpkg to make a binary package) and try rebuilding libSM and evo.

If that doesn't work, then I'm out of ideas.

Thanks
Comment 18 darkgrave 2009-09-28 07:42:48 UTC
Files removed:
  /lib64/libuuid.so.1.2
  /lib64/libuuid.so

libSM recompiled and, finally, evolution compiled and runs ok!

Very thanks to everybody.
I'm marking this bug as CLOSED, but it's actually RESOLVED.