Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 285048 - sys-kernel/gentoo-sources: order of slots
Summary: sys-kernel/gentoo-sources: order of slots
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-15 05:10 UTC by Oleh Kravchenko
Modified: 2010-02-24 23:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleh Kravchenko 2009-09-15 05:10:56 UTC
Every new version of kernel sources receive unique slots, it problem to me :)

I think better can be when kernel branches have unique slot like that:
(2.6.16) 2.6.16-r13
(2.6.25) 2.6.25-r9
(2.6.26) 2.6.26-r4
(2.6.27) 2.6.27-r8 2.6.27-r10
(2.6.28) 2.6.28-r5 2.6.28-r6
(2.6.29) 2.6.29 2.6.29-r1 2.6.29-r2 2.6.29-r3 2.6.29-r4 2.6.29-r5 2.6.29-r6
(2.6.30) 2.6.30 2.6.30-r3 2.6.30-r4 2.6.30-r5 2.6.30-r6
(2.6.31) 2.6.31


Reproducible: Always
Comment 1 Sebastian Luther (few) 2009-09-15 12:08:37 UTC
Could you pleases explain why the current system is a problem for you?
Comment 2 Oleh Kravchenko 2009-09-15 12:56:01 UTC
(In reply to comment #1)
> Could you pleases explain why the current system is a problem for you?
> 

Because if i want stay on 2.6.28 branch I need mask all version >=sys-devel/gentoo-sources-2.6.29 in /etc/portage/package.mask

But I think better solution can be if /var/lib/portage/world contain sys-devel/gentoo-sources:2.6.28
Comment 3 Sebastian Luther (few) 2009-09-15 13:05:33 UTC
You could mask
Comment 4 Mike Pagano gentoo-dev 2009-09-18 12:16:07 UTC
There are no plans at this time to slot gentoo-sources
Comment 5 Oleh Kravchenko 2009-09-18 13:59:44 UTC
(In reply to comment #4)
> There are no plans at this time to slot gentoo-sources
> 

Bad :)