Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 284750 - app-crypt/seahorse-2.22.3: seahorse-agent dies on startup
Summary: app-crypt/seahorse-2.22.3: seahorse-agent dies on startup
Status: RESOLVED DUPLICATE of bug 281729
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-13 11:25 UTC by Andrey Vihrov
Modified: 2009-09-18 14:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
.xsession-errors as produced by starting Gnome with empty home directory (.xsession-errors,2.37 KB, text/plain)
2009-09-13 12:49 UTC, Andrey Vihrov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Vihrov 2009-09-13 11:25:04 UTC
seahorse-agent dies immediately after being started by gnome-session. Moreover, gnome-session doesn't wait on it and seahorse-agent process becomes a zombie.

Running seahorse-agent from command line outputs "** Message: Another GPG agent already running". Starting Gnome with empty home directory behaves the same.

The system affected is stable amd64, in particular, gnome-base/gnome is 2.24.1 and gnome-base/gnome-session is 2.22.3-r1.

Reproducible: Always

Steps to Reproduce:
1. Emerge Gnome
2. Start Gnome session

Actual Results:  
seahorse-agent dies.

Expected Results:  
Should function as designed.

Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-1.12.11.1
Timestamp of tree: Sat, 12 Sep 2009 13:30:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -msse4.1 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -msse4.1 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask --jobs=2 --load-average=3"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.tups.lv/source/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru en lv"
MAKEOPTS="-j3 -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/armagetron /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 avahi bash-completion berkdb bluetooth bonjour branding bzip2 cairo cdr cli cracklib crypt cups dbus djvu dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif gnome gnome-keyring gpm gstreamer gtk hal hddtemp iconv id3tag ieee1394 ipod isdnlog jpeg libnotify lm_sensors mad matroska mikmod mmx mmxext mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection rtc samba sdl session smp spell spl sqlite sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg symlink sysfs tcpd theora threads thunar tiff totem truetype unicode upnp usb v4l2 vim-syntax vorbis x264 xml xorg xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en lv" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-09-13 12:20:00 UTC
please attach .xsession-errors and reopen.
Comment 2 Andrey Vihrov 2009-09-13 12:49:21 UTC
Created attachment 203928 [details]
.xsession-errors as produced by starting Gnome with empty home directory

Doesn't look so suspicious... If only the "1252845429.160951 Session manager: disconnected..." line.
Comment 3 Andrey Vihrov 2009-09-13 12:51:05 UTC
Reopening.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-09-13 16:32:52 UTC
Could you log into a console before starting your graphical session and start seahorse-agent by hand, if it dies, please start it in gdb and provide a backtrace [1]

[1] http://www.gentoo.org/proj/en/qa/backtraces.xml
Comment 5 Robert Trace 2009-09-18 05:37:26 UTC
(In reply to comment #4)
> Could you log into a console before starting your graphical session and start
> seahorse-agent by hand, if it dies, please start it in gdb and provide a
> backtrace [1]
> 
> [1] http://www.gentoo.org/proj/en/qa/backtraces.xml
> 

I don't know about the original poster, but I was also seeing this behavior on the same configuration (amd64, gnome 2.24, seahorse-2.22.3).  I debugged it down to the same problem as bug #281729 (improper initialization of gpgme 1.2.0).  The patch attached in that bug fixed this problem for me.
Comment 6 Andrey Vihrov 2009-09-18 12:08:30 UTC
(In reply to comment #5)

The patch fixes the problem indeed, thanks.
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-09-18 14:32:28 UTC

*** This bug has been marked as a duplicate of bug 281729 ***