Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 28376 - Ebuild for geeklog, a weblog powered by PHP and MySQL.
Summary: Ebuild for geeklog, a weblog powered by PHP and MySQL.
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: web-apps Herd
URL:
Whiteboard: [webapp-overlay]
Keywords: EBUILD, InOverlay
Depends on:
Blocks:
 
Reported: 2003-09-10 12:02 UTC by Federico Moro
Modified: 2006-06-12 05:05 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
geeklog-1.3.8-r1.ebuild (geeklog-1.3.8-r1.ebuild,1.17 KB, text/plain)
2003-09-10 12:03 UTC, Federico Moro
Details
geeklog-1.3.8.1_p2.ebuild (geeklog-1.3.8.1_p2.ebuild,1.17 KB, text/plain)
2003-10-18 04:08 UTC, Federico Moro
Details
geeklog-1.3.9.ebuild (geeklog-1.3.9.ebuild,1.81 KB, text/plain)
2004-03-19 23:22 UTC, Paul Handly
Details
First cut geeklog ebuild using webapp (geeklog-1.3.11.ebuild,2.71 KB, text/plain)
2005-05-07 12:14 UTC, Nathan Horter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Moro 2003-09-10 12:02:03 UTC
This is an ebuild for Geeklog.
Geeklog is a weblog powered by PHP and MySQL.

Reproducible: Always
Steps to Reproduce:
Comment 1 Federico Moro 2003-09-10 12:03:05 UTC
Created attachment 17455 [details]
geeklog-1.3.8-r1.ebuild

This is the ebuild for geeklog version 1.3.8-1
Comment 2 Stuart Herbert (RETIRED) gentoo-dev 2003-10-04 07:35:53 UTC
Hi,

The web-apps herd is currently working on delivering some important changes
to the way that web-based applications are installed and managed on Gentoo
Linux.  Until this work is complete, we're not commiting ebuilds for new
web-based packages.

I've marked this bug as 'LATER'.  As soon as we are able to, we will come
back to this bug and help you convert your ebuild to our new approach.

Many thanks for your patience,
Stu
Comment 3 Federico Moro 2003-10-18 04:08:55 UTC
Created attachment 19392 [details]
geeklog-1.3.8.1_p2.ebuild

New ebuild for new version that solve a seriusly bug.
This version contains changes in users.php since Jouko Pynnonen found a way
to
trick the new "forgot password" feature, introduced in 1.3.8, into letting
an
attacker change the password for _any_ account. This release addresses this
issue - there were no other changes.
For more information about Geeklog hisotry Changes see
http://www.geeklog.net/docs/history
Comment 4 Paul Handly 2004-03-19 23:22:06 UTC
Created attachment 27677 [details]
geeklog-1.3.9.ebuild

This is my first ebuild ever - I'm quite familiar with geeklog, and thought
it'd be nice to make an ebuild for it.	Please check over my layout - only a
few files should be present inside the web root, so I put the support files in
<webroot>/../geeklog.  Let me know what you think.
Comment 5 Stuart Herbert (RETIRED) gentoo-dev 2004-04-23 01:24:47 UTC
Hi,

Sorry for the delay in replying.  We've been very busy putting a new
framework in place for ebuilds for web-based applications.  This has
now been added to Portage.

We need you to update your ebuild to use the new framework before we
can accept your ebuild.

Please emerge net-www/webapp-config (make sure you get version 1.2 or
later), and update your ebuild to work with this new tool.  You can
use 'man 5 webapp.eclass', 'man 5 webapp-config' and 'man 8 webapp-config'
to learn more about how your ebuild needs to work.

You can find an example ebuild, for phpmyadmin, in

	/usr/share/doc/webapp-config-1.2/
	
If you encounter any difficulties with the new framework (and we
apologise, but there are sure to be a few at first), please let us know
and we'll do our best to help you.

Best regards,
Stu
Comment 6 Lance Albertson (RETIRED) gentoo-dev 2004-09-24 11:27:29 UTC
I was just wondering the status of this bug. Seems to have gotten forgotten :) I may be able to test these ebuilds (with newer versions) later today or tomorrow.

Cheers!
Comment 7 Renat Lumpau (RETIRED) gentoo-dev 2004-09-24 13:47:13 UTC
These ebuilds need to be converted to use webapp.eclass. webapp-apache will be obsoleted soon.
Comment 8 Lance Albertson (RETIRED) gentoo-dev 2004-09-24 19:29:43 UTC
I'll work on getting the ebuilds updated unless someone else beats me too it. Do you have a good example to go by to convert this ebuild to use that eclass? 
Comment 9 Renat Lumpau (RETIRED) gentoo-dev 2004-09-25 02:13:35 UTC
Read the manpages (see above), and read a few ebuilds in web-apps. squirrelmail and anything recent by me. Also, take a look at http://140.247.153.209/cgi-bin/automaton.py
Comment 10 Tony Bibbs 2005-01-27 11:11:27 UTC
I'm one of the maintainers of Geeklog and have converted to using Gentoo over the course of the last year or so.  Can someone point me to information about the webapps.eclass reference below?  The gentoo doc page below didn't reference that at all:

http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1

The jist of my issue is I want to build the ebuild for it but this is my first so I'm not fully understanding if there is something for web-based apps that is missing from that documentation or can I follow it reliably or what?

--Tony
Comment 11 Nathan Horter 2005-05-07 12:14:14 UTC
Created attachment 58292 [details]
First cut geeklog ebuild using webapp

The ebuild gets geeklog installed using webapp-config.

Geeklog wants some of it's files out of the htroot and this ebuild will put
them in the hostroot, but as it stands doing multiple installs will be
difficult.

I can't wrap my head around a good solution, any suggestions or patches are
appreciated.
Comment 12 Renat Lumpau (RETIRED) gentoo-dev 2005-12-09 17:23:13 UTC
Hola,

geeklog is now in our unofficial overlay:
http://svn.gnqs.org/projects/gentoo-webapps-overlay/browser/www-apps/geeklog/

Please note that the overlay is unofficial, not a Gentoo project, and not
supported. Detailed instructions for use are forthcoming. That said, I rewrote
the ebuild and it seems to work just fine.