Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283008 - net-im/skype-2.1.0.47 version bump
Summary: net-im/skype-2.1.0.47 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
: 283009 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-28 08:33 UTC by Ivan Ivanich
Modified: 2010-01-02 02:19 UTC (History)
44 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
This ebuild works. (skype-2.1.0.47.ebuild,2.48 KB, text/plain)
2009-08-28 19:27 UTC, Jason A. Donenfeld
Details
skype-2.1.0.47.ebuild.diff (skype-2.1.0.47.ebuild.diff,351 bytes, patch)
2009-09-11 16:14 UTC, Jouni Rinne
Details | Diff
skype-2.1.0.47.ebuild (skype-2.1.0.47.ebuild,2.43 KB, text/plain)
2009-09-22 16:42 UTC, Tomáš Chvátal (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Ivanich 2009-08-28 08:33:44 UTC
Beta version http://www.skype.com/intl/en/download/skype/linux/choose/


Reproducible: Always
Comment 1 Mike Auty gentoo-dev 2009-08-28 09:19:22 UTC
*** Bug 283009 has been marked as a duplicate of this bug. ***
Comment 2 Mike Auty gentoo-dev 2009-08-28 09:21:25 UTC
Note, a version bump won't quite work, because the new skype has a bit more checking in it, and now notices not only stripping as a "damaged binary", but also PaX marking, so the PaX line needs commenting out...
Comment 3 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2009-08-28 19:27:08 UTC
Created attachment 202547 [details]
This ebuild works.

Should deal with PaX fine now.
Comment 4 Jesse Adelman 2009-08-28 20:37:47 UTC
Installed fine here with just-posted ebuild. Running (mostly) x86 (stable), and -qt-static. Thanks!
Comment 5 Lukas Polacek 2009-08-29 11:41:55 UTC
Skype doesn't work for me on amd64 with pulseaudio-0.9.15-r2. When I try the test call Skype crashes with
skype: pulsecore/pstream-util.c:38: pa_pstream_send_tagstruct_with_creds: Assertion `p' failed.

Also pulseaudio crashes and this line was in syslog:
[pulseaudio] source.c: Assertion 'pa_cvolume_compatible(volume, &s->sample_spec)' failed at pulsecore/source.c:666, function pa_source_set_volume(). Aborting.
Comment 6 Mike Auty gentoo-dev 2009-08-29 11:55:14 UTC
There are some know issues with Skype-2.1.  Please see https://developer.skype.com/LinuxSkype/ReleaseNotes.  It's been reported that skype-2.1 works better if you disable the automatic volume settings (which you can do by unticking the box at Options > Sound Devices > Allow Skype to automatically adjust my mixer settings).  Please let us know if that helps or not.
Comment 7 Lukas Polacek 2009-08-29 14:52:31 UTC
Disabling "Options > Sound Devices > Allow Skype to automatically adjust my mixer settings" worked for me.

BTW, I think there should be pulseaudio USE flag.
Comment 8 Maciej Piechotka 2009-08-29 16:06:08 UTC
(In reply to comment #7)
> Disabling "Options > Sound Devices > Allow Skype to automatically adjust my
> mixer settings" worked for me.
> 

For me enabling it turned on...
Comment 9 Dieter Ries 2009-08-29 22:25:46 UTC
works here on amd64, too. all configuration was still intact after upgrading.
Comment 10 hirakendu 2009-08-30 17:34:08 UTC
The ebuild works fine (on amd64). As reported on phoronix forums, there is also a native 64-bit binary available, and as I see on Skype's website, it is only for Ubuntu-8.10+. Would be nice to get that working too. (Currently, running a ldd on the skype-static shows it linked to 32-bit libs.)
Comment 11 hirakendu 2009-08-30 17:40:01 UTC
Oops, I take back what I said above. It is all 32-bit :(.
Comment 12 Gef 2009-08-31 12:11:34 UTC
Worksforme, ~x86, thanks.
Comment 13 Fabio Correa 2009-08-31 14:17:22 UTC
Thank you, keep up the great work.
Comment 14 PaX Team 2009-08-31 21:50:08 UTC
(In reply to comment #2)
> Note, a version bump won't quite work, because the new skype has a bit more
> checking in it, and now notices not only stripping as a "damaged binary", but
> also PaX marking, so the PaX line needs commenting out...

actually skype is fine as it is since it doesn't have a PT_PAX_FLAGS program header and therefore no protections will be enabled on it if only that control method is enabled in the kernel. only people enabling the obsolete EI_PAX control method have problems, one more reason they should abandon it for good.
Comment 15 Lori 2009-09-02 19:57:40 UTC
I have been using it for a few days now, x86, -qt-static, it works great, thanks!
Comment 16 Tobias Roeser 2009-09-09 15:40:05 UTC
Works for me, x86, -qt-static.
Comment 17 Evgeny Mandrikov 2009-09-10 00:41:06 UTC
Works for me too (x86, -qt-static).
Comment 18 Silas Stingy 2009-09-10 09:44:16 UTC
Works fine for me.
Comment 19 Silas Stingy 2009-09-10 09:45:47 UTC
erm, sry, too fast forgot my specs :(
x86, -qt-static
Comment 20 Jouni Rinne 2009-09-11 16:14:36 UTC
Created attachment 203800 [details, diff]
skype-2.1.0.47.ebuild.diff

I noticed that this version of skype already ships with the correct skype.conf (for /etc/dbus-1/system.d/), so the one within files/ is unnecessary. Patch for ebuild is above.
Comment 21 Dirk Olmes 2009-09-16 07:18:56 UTC
Using this "in production" for two weeks now, just works

x86, -qt-static
Comment 22 Tomáš Chvátal (RETIRED) gentoo-dev 2009-09-22 16:42:39 UTC
Created attachment 204938 [details]
skype-2.1.0.47.ebuild

Updated and tested to work here.

Also still throws QA and i cant remember which QA_ call is used to hide this one:
 * QA Notice: The following files contain writable and executable sections
 *  Files with such sections will not work properly (or at all!) on some  
 *  architectures/operating systems.  A bug should be filed at            
 *  http://bugs.gentoo.org/ to make sure the issue is fixed.              
 *  For more information, see http://hardened.gentoo.org/gnu-stack.xml    
 *  Please include the following list of files in your report:            
 *  Note: Bugs should be filed for the respective maintainers             
 *  of the package in question and not hardened@g.o.                      
 * --- --- RWX opt/skype/skype
Comment 23 Martin Gerdzhev 2009-09-23 23:31:36 UTC
Tried the ebuild, but pulseaudio doesn't work for me. I'm getting te following:
*** PULSEAUDIO: Unable to connect: Connection refused
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
*** PULSEAUDIO: Unable to connect: Connection refused
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM null
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM null
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
*** PULSEAUDIO: Unable to connect: Connection refused

This is on AMD64.
Comment 24 Eric Smith 2009-09-24 22:45:01 UTC
I just installed skype with the qt-static flag in a 32bit chroot I set up for it, and it seems that it's missing a depedency on dev-libs/glib.  Most people probably already have this installed, so maybe that's why it was missed?

gentoo tmp # ldd /opt/skype/skype 
        linux-gate.so.1 =>  (0xffffe000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0xf7ea6000)
        libXv.so.1 => /usr/lib/libXv.so.1 (0xf7ea0000)
        libXss.so.1 => /usr/lib/libXss.so.1 (0xf7e9c000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xf7e93000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xf7e7b000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xf7e71000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf7e66000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf7e5d000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf7dc3000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf7d88000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xf7d75000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xf7c48000)
        libz.so.1 => /lib/libz.so.1 (0xf7c34000)
        libgthread-2.0.so.0 => not found
        libglib-2.0.so.0 => not found
        librt.so.1 => /lib/librt.so.1 (0xf7c2c000)
        libdl.so.2 => /lib/libdl.so.2 (0xf7c28000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf7c10000)
        libstdc++.so.6 => /usr/lib/gcc/i486-pc-linux-gnu/4.1.2/libstdc++.so.6 (0xf7b27000)
        libm.so.6 => /lib/libm.so.6 (0xf7b01000)
        libgcc_s.so.1 => /usr/lib/gcc/i486-pc-linux-gnu/4.1.2/libgcc_s.so.1 (0xf7af5000)
        libc.so.6 => /lib/libc.so.6 (0xf79c5000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xf79be000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xf799d000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf7982000)
        /lib/ld-linux.so.2 (0xf7f69000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xf797e000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xf7978000)
Comment 25 Eric Smith 2009-09-26 12:32:12 UTC
After installing glib, I still had a problem with skype seg faulting on start.  Debugging with gdb didn't really help, but googling suggested that it was a font problem.  After installing media-fonts/freefont-ttf everything is working fine.  

I'm sure other font packages would have worked, but there really should be some kind of dependency on a font package to prevent the seg faults.  Again, most people would have these packages installed, but because I am using this 32bit chroot solely for skype, I did not have them installed.
Comment 26 Flo Gravo 2009-10-05 13:52:20 UTC
(In reply to comment #23)

> E: shm.c: Invalid shared memory segment size
> E: shm.c: Invalid shared memory segment size
> E: shm.c: Invalid shared memory segment size
> *** PULSEAUDIO: Unable to connect: Connection refused

I get this, too. ~amd64 qt-static pulseaudio
Maybe connected to:
http://www.pulseaudio.org/ticket/401

Also reported here:
http://forums.gentoo.org/viewtopic-p-5949094.html
Comment 27 Erik Boritsch 2009-10-06 22:55:11 UTC
As for pulseaudio, you need correct 32-bit libraries. I have solved that problem by building 32-bit chroot and using its libraries by emerging same version of pulseaudio and alsa-plugins.

After an update though, I cannot start skype anymore due to the writable and executable sections. The error I get is "/usr/bin/skype: line 10: /opt/skype/skype: No such file or directory". The file is there though.
Comment 28 Maciej Piechotka 2009-11-22 05:41:23 UTC
After some time that skype working all I can get is:
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
*** PULSEAUDIO: Unable to connect: Connection refused

And no sound (both in 2.0 and 2.1). ~amd64
Comment 29 Martin Swift 2009-12-04 20:02:24 UTC
(In reply to comment #22)

Builds and runs here with -qt-static. Cheers.
Comment 30 Marco DR 2009-12-07 19:05:17 UTC
If I understand the problem correctly, skype 2.1 needs 32bit pulseaudio. Therefore, in order for it to work on amd64, it needs pulseaudio libraries. There is a bug already filed for this: Bug 186820. Can someone please mark this bug depending on it?
Comment 31 Alexander Bezrukov 2009-12-07 19:12:01 UTC
(In reply to comment #30)
> If I understand the problem correctly, skype 2.1 needs 32bit pulseaudio.

This is perhaps true, but only if skype is used with pulseaudio server. It can work without pulseaudio (with plain alsa) very well. I am using skype-2.1.0.47 almost since its release, I don't have pulseaudio and it works very well on amd64.
Comment 32 Andrey Vihrov 2009-12-07 19:26:39 UTC
(In reply to comment #30)

It works for me, and I don't have PulseAudio installed. If you examine readelf output of the Skype binary, you'll see it is only linked to libasound.so.2.
Comment 33 Alexander Bezrukov 2009-12-07 19:32:02 UTC
According to the developers (I read this in a blog entry which accompanied the beta release on skype.com), skype uses PulseAudio if skype detects it (perhaps, if skype can dlopen it) and PulseAudio takes priority over libasound. But use of PulseAudio is merely optional.
Comment 34 Felix Leimbach 2009-12-30 15:35:36 UTC
(In reply to comment #22)

This ebuild works well for me on amd64 after I applied the workaround described in bug 298990.
I think Tomáš' ebuild is ready for portage, isn't it?
Comment 35 Zsombor G. 2009-12-30 17:23:42 UTC
It would be nice, if the following line could be added to the /usr/bin/skype
"export LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so"
This will help in some cases, where the new v4l2 driver doesnt support some image conversion. This shared library comes from the libv4l2 library.
Comment 36 Andrey Vihrov 2009-12-30 22:42:37 UTC
(In reply to comment #34)

I think it needs a little more work. Surely most dependencies need not be in DEPEND; more error handling needs to be added. Additionally, Skype works fine for me even without the "#Fix for no sound notifications". Finally, comment #22 states one more problem.

I hope someone knowing more about Qt than me will take this into consideration and improve the ebuild.
Comment 37 Felix Leimbach 2009-12-31 11:38:36 UTC
(In reply to comment #34)

bug 298990 has been resolved and has nothing to do with the skype ebuild, so that's not an issue.
Comment 38 Gef 2009-12-31 21:53:49 UTC
(In reply to comment #22)
> Also still throws QA and i cant remember which QA_ call is used to hide this
> one:
>  * QA Notice: The following files contain writable and executable sections
>  *  Files with such sections will not work properly (or at all!) on some  
>  *  architectures/operating systems.

According to [1], needed call would be QA_EXECSTACK_arch or QA_EXECSTACK, "the former overrides the former".

Happy new year!

[1] http://sources.gentoo.org/viewcvs.py/portage/main/tags/2.1.7.16/bin/misc-functions.sh?rev=15152&view=markup
Comment 39 Tony Vroon gentoo-dev 2010-01-02 00:29:09 UTC
+*skype-2.1.0.47 (02 Jan 2010)
+
+  02 Jan 2010; <chainsaw@gentoo.org> +skype-2.1.0.47.ebuild:
+  Version bump, closes bug #283008 by Ivan Ivanich. Minor changes by me,
+  major QA fixes by Samuli Suominen.
Comment 40 Omar Saleem 2010-01-02 02:02:53 UTC
(In reply to comment #25)
> After installing glib, I still had a problem with skype seg faulting on start. 
> Debugging with gdb didn't really help, but googling suggested that it was a
> font problem.  After installing media-fonts/freefont-ttf everything is working
> fine.  
> 
> I'm sure other font packages would have worked, but there really should be some
> kind of dependency on a font package to prevent the seg faults.  Again, most
> people would have these packages installed, but because I am using this 32bit
> chroot solely for skype, I did not have them installed.
> 

hmm i have installed glib and freefont-ttf but skype still segfaults. curious, since downloading the binaries from skype and running them locally worked fine. i have no idea why skype is segfaulting now :/
Comment 41 Omar Saleem 2010-01-02 02:19:55 UTC
sorry to double post, but i had to disable split and strip in the build options, and then skype works. i don't know how stable or safe this is...but at least skype doesn't segfault.