Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 282431 - sci-biology/seaview: fails to build with glibc-2.10
Summary: sci-biology/seaview: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Andrey Kislyuk (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-08-23 12:32 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-04 09:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (seaview-20071113:20090823-123147.log,11.34 KB, text/plain)
2009-08-23 12:35 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-23 12:32:44 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-23 12:35:20 UTC
Created attachment 202022 [details]
Build log
Comment 2 Martin Mokrejš 2009-08-28 12:49:48 UTC
So I started hitting this on ~x86 with seaview-20071113. :(
Comment 3 Samuli Suominen gentoo-dev 2009-09-04 09:22:46 UTC
+  04 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+  seaview-20071113.ebuild, +files/seaview-20071113-glibc-2.10.patch:
+  Fix building with GLIBC 2.10+ wrt #282431.