Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 282048 - glibc-2.8 and Brother DCP-135C printer driver incompatible
Summary: glibc-2.8 and Brother DCP-135C printer driver incompatible
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2009-08-19 21:30 UTC by Klaas Decanniere
Modified: 2009-08-26 21:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Klaas Decanniere 2009-08-19 21:30:59 UTC
glibc-2.8_p20080602-r1 and the manufacturer printer driver for the Brother DCP-135C don't work together.

The driver segfaults:
brcupsconfpt1[4787]: segfault at 523d6b63 ip 00000000f7ed1b34 sp 00000000ff8e09d0 error 6 in[f7e60000+135000]

Printing a cups test page works fine, printing a pdf-file from acrobat reader, version 9.1.3 (both with level 2 and level 3 postscript)

Not sure anymore how I got the printer driver to work in the first place, but it worked fine _before_ installing glibc-2.8_p20080602 (without the r1)

Reproducible: Always

I installed version 2.8_p20080602-r1 to try and get icedtea6 going with firefox 3.5 (in vain)

Had to print my boarding pass using a windows virtual machine. Yuk. I have a plane to catch now - .

emerge --info gives:

Portage (default/linux/amd64/2008.0, gcc-4.4.1, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r5 x86_64)
System uname: Linux-2.6.29-gentoo-r5-x86_64-AMD_Athlon-tm-_64_Processor_3500+-with-gentoo-
Timestamp of tree: Sun, 16 Aug 2009 10:15:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.4.4-r14, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=k8 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl alsa amd64 berkdb bitmap-fonts bzip2 cairo cdparanoia cdr cli cracklib crypt cups divx dri dvd fftw fortran gcj gdbm gif gimp glitz gmp gphoto2 gpm gtk iconv imagemagick ipv6 isdnlog java joystick jpeg kde lame lapack lcms mad mbrola mmx mp3 mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia ogg openexr opengl openmp oss pam pcre pcsc-lite pdf perl png povray ppds pppd python qt3support quicktime readline realmedia reflection scanner session smartcard spl sse sse2 ssl svg sysfs tcpd threads tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vorbis xinerama xorg xulrunner zlib" ALSA_CARDS="atiixp intel8x0 via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse vmmouse joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vesa nv vmware fbdev"
Comment 1 Patrick Lauer gentoo-dev 2009-08-20 07:42:28 UTC
Try updating to something more recent maybe. glibc-2.9_p20081201-r2 is marked stable on amd64 ...
Comment 2 Klaas Decanniere 2009-08-24 19:38:09 UTC
(In reply to comment #1)
> Try updating to something more recent maybe. glibc-2.9_p20081201-r2 is marked
> stable on amd64 ...

Updated glibc as suggested.
I now get brcupsconfpt1[10991]: segfault at 523d6b63 ip 00000000f7ed60f4 sp 00000000ffde9ed0 error 6 in[f7e64000+138000].

Seems to be the same error.

I did verify that I have the latest driver version installed. 

Found a reference on an opensuse list for a different Brother printer (bug 440903) where they suggest pushing Brother to fix things. 

I will try contacting Brother, but other suggestions still more than welcome.

thanks for the help

Comment 3 Patrick Lauer gentoo-dev 2009-08-26 07:46:22 UTC
I don't see how we can do anything to fix a proprietary driver. Good luck getting it to work!
Comment 4 Klaas Decanniere 2009-08-26 21:38:40 UTC
(In reply to comment #3)
> I don't see how we can do anything to fix a proprietary driver. Good luck
> getting it to work!

If somebody else runs into this problem - there is a workaround: the lpr driver still works. So if the printer is connected locally: save the pdf to disk and use "lpr file.pdf" to print. Acroread uses the cups driver which segfaults.