Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 281493 - Set shortcut not set anymore after restart of KMail
Summary: Set shortcut not set anymore after restart of KMail
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-14 19:49 UTC by Sami Näätänen
Modified: 2010-04-04 17:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Paludis --info kmail (paludis_info.txt,13.76 KB, text/plain)
2009-08-14 19:55 UTC, Sami Näätänen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sami Näätänen 2009-08-14 19:49:18 UTC
When I set the "Empty all Trash folders" shortcut to ctrl+T it will work as long as the current KMail instance is running, but if I quit and launch it again the shortcut is not set anymore.

Reproducible: Always

Steps to Reproduce:
1. Set "Empty all Trash folders" shortcut to ctrl+T from KMail
2. Quit KMail
3. Open KMail --> the previosly set shortcut is not set anymore




Parts of KDE that I have installed:
Kmail, Ktorrent and Amarok with their deps.

KDE BUG about same problems:
http://bugs.kde.org/show_bug.cgi?id=137484

I will test some of my ideas and report back when I have done so.
Comment 1 Sami Näätänen 2009-08-14 19:55:33 UTC
Created attachment 201275 [details]
Paludis --info kmail
Comment 2 Sami Näätänen 2009-08-14 20:20:32 UTC
Allright so my first idea was at least so far correct.

This seams to be caused by old kde configs as if I delete all ~/.kde* files and folders everything seams to work as they should.
I also killed any processes having kde or kwallet etc in their name.

After the launch and mail account configuration I can set shortcuts from the  kmail menu and those remain set after multiple quit relaunch cycles.

So it seams that either my config was corrupted or that some old config stuff prevented this kde shortcut code from saving the modification.

Might bee a good idea to put some general info about old configs to the KDE ebuilds maybe?
Comment 3 Sami Näätänen 2009-08-14 20:59:33 UTC
This was the thing that made the difference

FILE: .kde/share/apps/kmail/kmmainwin.rc

-<kpartgui version="412" name="kmmainwin" >
+<kpartgui version="414" name="kmmainwin" >

After this change the shortcut was saved correctly.


Comment 4 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-02 20:01:53 UTC
OK there is nothing to fix here from our side, apart from document those dirty fixes by erasing the .kde* folders, which we do in our docs. If there is any news on the upstream bug please reopen with the fix. Thanks for the report though.
Comment 5 Sami Näätänen 2010-04-04 17:38:38 UTC
(In reply to comment #4)
> OK there is nothing to fix here from our side, apart from document those dirty
> fixes by erasing the .kde* folders, which we do in our docs. If there is any
> news on the upstream bug please reopen with the fix. Thanks for the report
> though.
> 

As I have blundered to this problem later I have found out that it is sufficient to just delete this

FILE: .kde/share/apps/kmail/kmmainwin.rc

as the other kmail configs are updated properly.

This also seams to be the case for other KDE applications too. Just the general shortcut etc configs need to be updated/replaced. The application specific configurations are properly updated.

Some kind of a kwin configuration updater would help these cases, but it would not be that trivial to do, so maybe that's why KDE devs have't done so.