Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 281447 - x11-base/xorg-server-1.5.3-r6: crash at reboot (with nvidia and vmware)
Summary: x11-base/xorg-server-1.5.3-r6: crash at reboot (with nvidia and vmware)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Doug Goldstein (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-14 09:34 UTC by Thomas Kohler
Modified: 2012-07-16 10:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Log after reboot: X was crashed (Xorg.0.log.nvidia_no,14.17 KB, text/plain)
2009-08-14 09:36 UTC, Thomas Kohler
Details
Log after "killall kdm", "kdm" (Xorg.0.log.nvidia_ok,14.11 KB, text/plain)
2009-08-14 09:37 UTC, Thomas Kohler
Details
Log with "nv" instead of "nvidia" after reboot (Xorg.0.log.nv_ok,28.27 KB, text/plain)
2009-08-14 09:37 UTC, Thomas Kohler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kohler 2009-08-14 09:34:57 UTC
After upgrade to version 1.5 (same problem with older <1.5.3-rc6) X crash after each reboot. 

Reproducible: Always

Steps to Reproduce:
1. using xorg-server-1.5.3-rc6 (or any 1.5), kdm, nvidia (older and last), vmware (older and last)
2. reboot the system

Actual Results:  
black screen will shown at x console (7), after a while the system switch to first console 


You can login at terminal and "killall kdm", than start "kdm" and X run ok.

After some tests I have found some Workarrounds for the problem:
1.) use "nv" instead of "nvidia"
2.) delete xdm from loading at boot time (rc-update del xdm) and start kdm manually after reboot
3.) delete "vmware" from loading at boot time (rc-update del vmware) will be at the moment the best workarround

In my opinion load of X and vmware at the same time will cause the problem. How can we force that vmware will be loaded after or before X?

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r5-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-1.12.11.1
Timestamp of tree: Thu, 13 Aug 2009 17:15:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2-r1
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer -mmmx -msse -msse3 -m3dnow"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/X11/xorg.conf /etc/conf.d/clock /etc/conf.d/consolefont /etc/conf.d/domainname /etc/conf.d/gpm /etc/conf.d/hostname /etc/conf.d/keymaps /etc/conf.d/net /etc/conf.d/net.pppoa /etc/conf.d/net.pppoe /etc/conf.d/nfs /etc/conf.d/ntp-client /etc/conf.d/ntpd /etc/conf.d/rc /etc/conf.d/xdm /etc/crontab /etc/cups/printers.conf /etc/env.d/02locale /etc/exports /etc/flexbackup.conf /etc/fstab /etc/gnokiirc /etc/init.d/alsasound /etc/init.d/ntp-client /etc/locale.gen /etc/logrotate.d/syslog-ng /etc/make.conf /etc/modprobe.conf /etc/modprobe.d/blacklist /etc/modules.conf /etc/modules.d/alsa /etc/portage/package.keywords /etc/portage/package.mask /etc/portage/package.use /etc/rc.conf /etc/rsyncd.conf /etc/sane.d/dll.conf /etc/sane.d/net.conf /etc/squid/squid.conf /etc/sysctl.conf /etc/udev/rules.d/10-thkoh.rules /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/kdmrc /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/DIR_COLORS /etc/X11/gdm/Init/Default /etc/X11/gdm/PostLogin/Default.sample /etc/X11/gdm/PostSession/Default /etc/X11/gdm/PreSession/Default /etc/X11/gdm/Xsession /etc/X11/gdm/locale.alias /etc/X11/gdm/modules/AccessDwellMouseEvents /etc/X11/gdm/modules/AccessKeyMouseEvents /etc/X11/gdm/modules/factory-AccessDwellMouseEvents /etc/X11/gdm/modules/factory-AccessKeyMouseEvents /etc/X11/xorg.conf.example /etc/atmsigd.conf /etc/bash/bashrc /etc/ca-certificates.conf /etc/colordiffrc /etc/colordiffrc-lightbg /etc/conf.d/portmap /etc/conf.d/rc /etc/conf.d/squid /etc/conf.d/wireless.example /etc/cups/cupsd.conf.default /etc/cups/mime.convs /etc/cups/mime.types /etc/dbus-1/session.conf /etc/dbus-1/system.conf /etc/dbus-1/system.d/ConsoleKit.conf /etc/dbus-1/system.d/hal.conf /etc/default/rscsi /etc/default/rscsi.dfl /etc/dispatch-conf.conf /etc/eclean/distfiles.exclude /etc/env.d /etc/env.d/java/ /etc/eselect/compiler/x86_64-pc-linux-gnu-4.1.2.conf /etc/fonts/conf.avail/ /etc/fonts/fonts.conf /etc/fonts/fonts.dtd /etc/gai.conf /etc/gconf /etc/gimp/2.0/ /etc/gtk-2.0/gdk-pixbuf.loaders /etc/host.conf /etc/hotplug/usb/libsane.usermap /etc/idmapd.conf /etc/init.d/ /etc/inputrc /etc/login.defs /etc/logrotate.d/elog-save-summary /etc/lxdvdrip.conf /etc/make.conf.example /etc/man.conf /etc/mke2fs.conf /etc/modprobe.d/nvidia /etc/modprobe.d/pnp-aliases /etc/modules.d/nvidia /etc/mplayer/mplayer.conf /etc/nanorc /etc/ntp.conf /etc/openldap/DB_CONFIG.example /etc/openldap/schema /etc/openldap/slapd.conf /etc/openldap/slapd.conf.default /etc/pam.d/ /etc/ppp/ip-down /etc/ppp/ip-up /etc/protocols /etc/rc.conf /etc/revdep-rebuild /etc/samba/lmhosts /etc/samba/smbusers /etc/sandbox.d /etc/sane.d/artec_eplus48u.conf /etc/sane.d/avision.conf /etc/sane.d/epson.conf /etc/sane.d/fujitsu.conf /etc/sane.d/gt68xx.conf /etc/sane.d/lexmark.conf /etc/sane.d/plustek.conf /etc/sane.d/snapscan.conf /etc/sarg/ /etc/sbclrc /etc/security/access.conf /etc/security/group.conf /etc/security/limits.conf /etc/security/namespace.init /etc/security/pam_env.conf /etc/security/time.conf /etc/sensors.conf /etc/services /etc/shells /etc/skel/.bashrc /etc/slsh.rc /etc/sound/events/ /etc/squid/squid.conf.default /etc/ssh/moduli /etc/ssh/ssh_config /etc/ssh/sshd_config /etc/ssmtp/ssmtp.conf /etc/sudoers /etc/terminfo /etc/udev/rules.d /etc/udev/rules.d/05-udev-early.rules /etc/udev/rules.d/50-udev.rules /etc/udev/rules.d/60-persistent-storage.rules /etc/udev/rules.d/75-cd-aliases-generator.rules /etc/udev/rules.d/75-persistent-net-generator.rules /etc/udev/rules.d/95-udev-late.rules /etc/udev/rules.d/hal.rules /etc/updatedb.conf /etc/wgetrc /etc/xdg/menus/applications.menu /etc/xdg/menus/preferences.menu /etc/xdg/menus/settings.menu /usr/kde/3.5/share/config/kdm/Xsession /usr/kde/3.5/share/config/klipperrc /usr/kde/3.5/share/config/libkleopatrarc /usr/kde/3.5/share/config/ui/ui_standards.rc /usr/share/X11/xkb/ /usr/share/config/kmyfirewallrc etc/conf.d/alsasound"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/java-overlay /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl alsa amd64 amr amrnb amrwb ansi atm avi berkdb bitmap-fonts bzip2 cdr cli cracklib crypt cups dri dvd dvdr dvdread encode ffmpeg flac foomaticdb fortran gdbm gif gimp gpm gtk2 iconv imagemagick ipv6 isdnlog jack joystick jpeg kde lame lm_sensors mad mikmod mmx mmxext mp3 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp oss pam pcre perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl sensord session slang spell spl sse sse2 ssl sysfs tcltk tcpd tiff truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 vcd vorbis x264 xorg xvid zlib" ALSA_CARDS="snd-hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nv nvidia v4l"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Thomas Kohler 2009-08-14 09:36:28 UTC
Created attachment 201214 [details]
Log after reboot: X was crashed
Comment 2 Thomas Kohler 2009-08-14 09:37:07 UTC
Created attachment 201215 [details]
Log after "killall kdm", "kdm"
Comment 3 Thomas Kohler 2009-08-14 09:37:46 UTC
Created attachment 201216 [details]
Log with "nv" instead of "nvidia" after reboot
Comment 4 Thomas Kohler 2009-08-16 09:27:51 UTC
The third workarround (without vmware) don't work properly. Yesterday I booting two times without success. Today one time it works. There is something wrong with timing.

Now I will add "after vmware" at boot script and add vmware to runlevel default again (it will be the last service to start).
Comment 5 Thomas Kohler 2009-08-16 09:43:26 UTC
(In reply to comment #4)
> Now I will add "after vmware" at boot script and add vmware to runlevel default
> again (it will be the last service to start).

I have changed "before alsasound" in "before local". The last boot was good.
Comment 6 Rémi Cardona gentoo-dev 2009-08-17 17:15:38 UTC
Hum, 2 binary-only kernel modules wreaking havoc. Shocker.

If removing both modules does fix the issue, then there's nothing for me to fix. And I doubt the other maintainers will be able to do anything about this.

Good luck.
Comment 7 Thomas Kohler 2009-08-18 19:11:39 UTC
(In reply to comment #6)
> Hum, 2 binary-only kernel modules wreaking havoc. Shocker.

Is this hint really serious? Which "2 binary-only kernel modules" do you mean?
Comment 8 Doug Goldstein (RETIRED) gentoo-dev 2012-07-14 20:39:09 UTC
Unfortunately this bug has gotten a little stale due to slipping between the cracks, please retest with the latest X, latest vmware, and latest nvidia-drivers and all should be well.
Comment 9 Thomas Kohler 2012-07-16 10:39:39 UTC
The problem is gone because change of hardware, I'm using an ATI now ;o}. So I can't retest, sorry.