Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280922 - media-libs/libdecodeqr: fails configure with forced --as-needed
Summary: media-libs/libdecodeqr: fails configure with forced --as-needed
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Robin Johnson
URL: http://www.gentoo.org/proj/en/qa/asne...
Whiteboard:
Keywords:
Depends on:
Blocks: as-needed
  Show dependency tree
 
Reported: 2009-08-09 21:13 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2015-01-05 17:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
robbat2: Bugday+


Attachments
Build log (libdecodeqr-0.9.3:20090809-210821.log,2.54 KB, text/plain)
2009-08-09 21:13 UTC, Diego Elio Pettenò (RETIRED)
Details
config.log (config.log,11.73 KB, text/plain)
2009-08-09 21:14 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-09 21:13:11 UTC
I'm reporting this bug because the package in summary fails to build when forcing --as-needed on through spec files (check out http://blog.flameeyes.eu/2008/11/14/problems-and-mitigation-strategies-for-as-needed for details).

Please note that this bug _might_ apply to -Wl,--as-needed in LDFLAGS as well; in both cases it should be fixed. Also, if this is due to the package in question not respecting user-defined LDFLAGS, you should get to fix that too.

Check the attached build log.

Thanks,
Diego

P.S.: in this case the problem is the test for opencv, so check the config.log as well; the problem is that cvCreateImage is not in libcv (-lcv) but rather in libcxcore.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-09 21:13:59 UTC
Created attachment 200730 [details]
Build log
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-09 21:14:22 UTC
Created attachment 200731 [details]
config.log
Comment 3 Samuli Suominen gentoo-dev 2010-06-28 10:26:45 UTC
After patching configure.in, AC_CHECK_LIB to find -lcv, it doesn't find the function it's looking from it:

checking for cvCreateImage in -lcv... no

Futhermore, the build will bail out long before that by setting *any* LDFLAGS to /etc/make.conf with:

checking for C++ compiler default output file name... 
configure: error: C++ compiler cannot create executables

Which is caused by this mess in the ebuild:

econf LDFLAGS="${LDFLAGS//-Wl,/ }" || die

Masked for removal, been in tree 2 years non-functional.
Comment 4 Samuli Suominen gentoo-dev 2010-07-21 12:48:55 UTC
Removed from tree.