Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280906 - net-libs/libsoup:2.2 removal request
Summary: net-libs/libsoup:2.2 removal request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard: Removal pending 2009-12-01
Keywords: PMASKED
: 292384 292525 (view as bug list)
Depends on:
Blocks: 226793
  Show dependency tree
 
Reported: 2009-08-09 18:58 UTC by Gilles Dartiguelongue
Modified: 2009-12-23 17:25 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2009-08-09 18:58:24 UTC
I everyone, we'd like to get rid of libsoup-2.2 since it isn't maintained upstream anymore and sufficient time was left for most packages out there to move to slot 2.4. The only 2 remaining packages in tree using 2.2 are:
 * dev-libs/libtranslate (maintainer-needed)
 * app-pda/libsyncml (pda, peper)

Is it possible for your packages to migrate to 2.4, is upstream still active for these packages ?
Comment 1 Víctor Ostorga (RETIRED) gentoo-dev 2009-09-02 16:37:33 UTC
checking for libsoup-2.2... configure: libsoup not found: forcing --disable-generic

Seems that dev-libs/libtranslate does not build with libsoup:2.4 out of the box, I'll check if is it possible to make it work later.
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-09-06 11:48:13 UTC
libtranslate is maintainer-needed, I have no problem punting it if it can't be ported.
libsyncml is somewhat maintainer-needed as well given peper is on away and pda isn't a much active herd but I guess this package has some use.
Comment 3 Víctor Ostorga (RETIRED) gentoo-dev 2009-09-06 21:54:27 UTC
+  06 Sep 2009; Víctor Ostorga <vostorga@gentoo.org>
+  libtranslate-0.99.ebuild, +files/libtranslate-0.99-libsoup24.diff:
+  Adding patch to build against net-libs/libsoup:2.4
+
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-09-21 14:25:16 UTC
@victor: thanks for patching this


@pda, @peper:
Ok, I just checked that libsyncml 0.5.* states that it supports libsoup:2.4, so I propose we fix the dep and remove all revisions if it's not causing any problem (it doesn't afa my search showed me). Please advise or I'll go ahead in about 10 days.
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-11-07 23:52:59 UTC
Dependencies cleaned up, mask in place.
Not planning to send a mail to dev because it's just a slot cleanup.
Comment 6 Greg Fitzgerald 2009-11-08 01:25:18 UTC
Correct me I'm wrong, but I think masking =net-libs/libsoup-2.2* is the wrong way to do this. This is is also masking versions with the 2.4 slot.

I think you wanted to do =net-libs/libsoup-2.2.*
Comment 7 Greg Fitzgerald 2009-11-08 01:44:08 UTC
Actually guess you can't do that so maybe =net-libs/libsoup-2.2
Comment 8 Mattia Rossi 2009-11-08 01:50:07 UTC
(In reply to comment #7)
> Actually guess you can't do that so maybe =net-libs/libsoup-2.2
> 

I think its more something like <net-libs/libsoup-2.24

Comment 9 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-11-08 02:09:26 UTC
Version fixed now, thanks for reporting.
Comment 10 Fabiano 2009-11-08 02:21:17 UTC
I've just sync my portage now to be sure and I am still getting all versions masked. Mask is =net-libs/libsoup-2.2* and it matches all versions in slot 2.4 (2.26.3-r1 and ~2.28.1).

Isn't it better to change the mask to net-libs/libsoup:2.2 instead?
Comment 11 Greg Fitzgerald 2009-11-08 02:23:50 UTC
Mirror probably has not updated yet, might take a little while. Just add an unmask temporarily till it's resolved.
Comment 12 Mark Loeser (RETIRED) gentoo-dev 2009-11-08 21:41:27 UTC
(In reply to comment #4)
> @pda, @peper:
> Ok, I just checked that libsyncml 0.5.* states that it supports libsoup:2.4, so
> I propose we fix the dep and remove all revisions if it's not causing any
> problem (it doesn't afa my search showed me). Please advise or I'll go ahead in
> about 10 days.

Removing libsyncml-0.4.6-r1 broke app-pda/libopensync-plugin-syncml since it depended on that version.

I don't know how you want to proceed with that, but we need to do something :)
Comment 13 Mark Loeser (RETIRED) gentoo-dev 2009-11-08 21:48:24 UTC
*** Bug 292384 has been marked as a duplicate of this bug. ***
Comment 14 Gilles Dartiguelongue gentoo-dev 2009-11-08 22:04:24 UTC
This is due to:

  19 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
  libopensync-plugin-syncml-0.36.ebuild:
  Migrate to EAPI 2 in order to remove built_with_use usage. Don't allow
  libsyncml-0.5.0 to satisfy dependencies in order to fix bug #269187.

while it's not a recent change, it wasn't there when I first looked into this. I guess we need to make it user 0.5. libsoup-2.2 is really a dead end, and the sooner we get rid of it, the better.
Comment 15 Gilles Dartiguelongue gentoo-dev 2009-11-13 08:58:53 UTC
*** Bug 292525 has been marked as a duplicate of this bug. ***
Comment 16 Gilles Dartiguelongue gentoo-dev 2009-11-13 09:12:07 UTC
Ok guys, release 0.39 from 2009-09-21 (http://www.opensync.org/) depends on a minimum version of >=libsyncml-0.5 so I guess if pda/peper has no objection I'll start bumping all this opensync stuff asap.
Comment 17 Gilles Dartiguelongue gentoo-dev 2009-11-15 22:47:19 UTC
ok, bumped everything that needed to be, tree should be fine now.
Comment 18 Tomáš Chvátal (RETIRED) gentoo-dev 2009-12-23 17:25:19 UTC
Treecleaned.