I everyone, we'd like to get rid of libsoup-2.2 since it isn't maintained upstream anymore and sufficient time was left for most packages out there to move to slot 2.4. The only 2 remaining packages in tree using 2.2 are:
* dev-libs/libtranslate (maintainer-needed)
* app-pda/libsyncml (pda, peper)
Is it possible for your packages to migrate to 2.4, is upstream still active for these packages ?
checking for libsoup-2.2... configure: libsoup not found: forcing --disable-generic
Seems that dev-libs/libtranslate does not build with libsoup:2.4 out of the box, I'll check if is it possible to make it work later.
libtranslate is maintainer-needed, I have no problem punting it if it can't be ported.
libsyncml is somewhat maintainer-needed as well given peper is on away and pda isn't a much active herd but I guess this package has some use.
+ 06 Sep 2009; Víctor Ostorga <email@example.com>
+ libtranslate-0.99.ebuild, +files/libtranslate-0.99-libsoup24.diff:
+ Adding patch to build against net-libs/libsoup:2.4
@victor: thanks for patching this
Ok, I just checked that libsyncml 0.5.* states that it supports libsoup:2.4, so I propose we fix the dep and remove all revisions if it's not causing any problem (it doesn't afa my search showed me). Please advise or I'll go ahead in about 10 days.
Dependencies cleaned up, mask in place.
Not planning to send a mail to dev because it's just a slot cleanup.
Correct me I'm wrong, but I think masking =net-libs/libsoup-2.2* is the wrong way to do this. This is is also masking versions with the 2.4 slot.
I think you wanted to do =net-libs/libsoup-2.2.*
Actually guess you can't do that so maybe =net-libs/libsoup-2.2
(In reply to comment #7)
> Actually guess you can't do that so maybe =net-libs/libsoup-2.2
I think its more something like <net-libs/libsoup-2.24
Version fixed now, thanks for reporting.
I've just sync my portage now to be sure and I am still getting all versions masked. Mask is =net-libs/libsoup-2.2* and it matches all versions in slot 2.4 (2.26.3-r1 and ~2.28.1).
Isn't it better to change the mask to net-libs/libsoup:2.2 instead?
Mirror probably has not updated yet, might take a little while. Just add an unmask temporarily till it's resolved.
(In reply to comment #4)
> @pda, @peper:
> Ok, I just checked that libsyncml 0.5.* states that it supports libsoup:2.4, so
> I propose we fix the dep and remove all revisions if it's not causing any
> problem (it doesn't afa my search showed me). Please advise or I'll go ahead in
> about 10 days.
Removing libsyncml-0.4.6-r1 broke app-pda/libopensync-plugin-syncml since it depended on that version.
I don't know how you want to proceed with that, but we need to do something :)
*** Bug 292384 has been marked as a duplicate of this bug. ***
This is due to:
19 Sep 2009; Petteri Räty <firstname.lastname@example.org>
Migrate to EAPI 2 in order to remove built_with_use usage. Don't allow
libsyncml-0.5.0 to satisfy dependencies in order to fix bug #269187.
while it's not a recent change, it wasn't there when I first looked into this. I guess we need to make it user 0.5. libsoup-2.2 is really a dead end, and the sooner we get rid of it, the better.
*** Bug 292525 has been marked as a duplicate of this bug. ***
Ok guys, release 0.39 from 2009-09-21 (http://www.opensync.org/) depends on a minimum version of >=libsyncml-0.5 so I guess if pda/peper has no objection I'll start bumping all this opensync stuff asap.
ok, bumped everything that needed to be, tree should be fine now.