Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280697 - new ebuild for kde-misc/googledata-9999
Summary: new ebuild for kde-misc/googledata-9999
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Gentoo KDE team
URL: http://websvn.kde.org/trunk/extragear...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-07 20:07 UTC by P Purkayastha
Modified: 2011-01-02 13:18 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for app-misc/googledata-9999 (googledata-9999.ebuild,406 bytes, text/plain)
2009-08-07 20:12 UTC, P Purkayastha
Details
ebuild for googledata-9999 (googledata-9999.ebuild,398 bytes, text/plain)
2009-08-07 20:33 UTC, P Purkayastha
Details
ebuild for kde-misc/googledata-1.0 (googledata-1.0.ebuild,479 bytes, text/plain)
2009-08-08 05:18 UTC, P Purkayastha
Details
Updated ebuld for googledata-1.0 (googledata-1.0.ebuild,506 bytes, text/plain)
2009-08-22 17:14 UTC, P Purkayastha
Details
update ebuild for googledata-9999 (googledata-9999.ebuild,418 bytes, text/plain)
2009-08-22 17:15 UTC, P Purkayastha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description P Purkayastha 2009-08-07 20:07:46 UTC
This is a new ebuild submission for kde-misc/googledata-9999. It depends on app-pda/libgcal. The ebuild for libgcal is present in the following bug:
http://bugs.gentoo.org/show_bug.cgi?id=246121

I have tested this ebuild against libgcal-0.9.1 (the latest release of libgcal) on an amd64 system.

Reproducible: Always
Comment 1 P Purkayastha 2009-08-07 20:12:33 UTC
Created attachment 200537 [details]
ebuild for app-misc/googledata-9999
Comment 2 P Purkayastha 2009-08-07 20:33:53 UTC
Created attachment 200539 [details]
ebuild for googledata-9999

This fixes a problem with the DEPEND (removed SLOT from akonadi).
Comment 3 P Purkayastha 2009-08-08 05:18:22 UTC
Created attachment 200552 [details]
ebuild for kde-misc/googledata-1.0

Sorry for the bug spam. :-/

I just noticed that googledata-1.0 has been released as akonadi-googledata-1.0 in libgcal homepage. Attaching the googledata-1.0 ebuild.
Comment 4 P Purkayastha 2009-08-22 17:14:30 UTC
Created attachment 201947 [details]
Updated ebuld for googledata-1.0

Updated dependencies to include dev-libs/boost and dev-libs/libxslt
Comment 5 P Purkayastha 2009-08-22 17:15:59 UTC
Created attachment 201948 [details]
update ebuild for googledata-9999

Updated ebuild for googledata-9999 to 
1. include dev-libs/boost and dev-libs/libxslt as dependencies
2. set it to missing keywords (**) since it is a live package.
Comment 6 P Purkayastha 2009-09-09 04:34:53 UTC
googledata-1.0.1 has been released. Just renaming the googledata-1.0 ebuild works fine.
Comment 7 Phillip Merensky 2010-04-06 12:40:45 UTC
Builds and works for me. Thanks!

Portage 2.2_rc67 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r10 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-r10-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 05 Apr 2010 22:15:02 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1
dev-python/pycrypto: 2.1.0
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.3
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   9999
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://mirror.netcologne.de/gentoo/ ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portage/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/gfxboot_overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="16bit 7zip X a52 aac aalib accessibility acl acpi addressbook aim akonadi alsa amarok amd amd64 aoss apache2 asf autoipd automount autoreplace avahi avantgo bash-completion berkdb binary binfilter bl blender-game bluetooth bootsplash branding bzip2 cairo calendar ccache cdaudio cdda cddb cdparanoia cdr cdrom cgi chm cisco cleartype cli clucene connectionstatus consolekit contactnotes cpudetection cracklib crypt css cups cvs cxx dbcp dbus dga dhcp divx dmi dom4j dri dts dv dvd dvdr eap-sim eap-tls embedded emboss encode esx excel exif fam fastcgi fat fbcon fbcondecor fbsplash ffmpeg firefox firefox3 flac flash flv fontconfig fortran ftp fts3 gcj gd gdbm geldkarte gif gimp gimpprint glib glitz gmedia gnokii gnutls gphoto2 gpm gs gtk gvim gzip hal hash hbci hdaps hfs http ibmacpi ical iconv icq image imagemagick imap inifile innodb irc irda jabber java java5 java6 javascript jboss jcs jfs john jpeg jpeg2k jpgraph kcal kde kdm kipi kpathsea kqemu kvm lame laptop lastfm latex latex3 lcms libcaca libnotify libsamplerate lirc log4j logitech-mouse logrotate logwatch lucene lzma lzo mad mail maildir mcal mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng modplug modules moonlight mozdevelop mozilla moznocompose moznoirc moznomail mozsvg mozxmlterm mp3 mp4 mp4live mpeg mpeg2 mplayer msn msnextras mtp mudflap multilib mysql mysqli ncurses nfs njb nls nptl nptlonly nsplugin nss ntfs ntlm ocaml ofx ogg opengl openmp openssl oscar otr pam pango pcre pda pdf perl phonon php player plotutils png postscript povray ppds pppd pptp print python qemu qt3support qt4 rar rdesktop readline reflection reiser4 reiserfs resolvconf samba scanner sdl secure-delete semantic-desktop sensord session sharedmem sms spell spl sql sqlite sqlite3 sse sse2 sse3 sse4 ssl startup-notification subversion svg sysfs syslog tcpd templates texteffect tga theora threads threadsafe thumbnail tidy tiff tk tokenizer truetype unicode usb utempter v4l v4l2 vcd vde vim vim-pager vim-syntax visualization vnc vorbis webkit wifi wma wmp wps x264 x86emu xanim xcb xcomposite xfs xine xinerama xml xorg xrandr xscreensaver xulrunner xv xvid yv12 zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel vesa vga fbdev" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

(In reply to comment #6)
> googledata-1.0.1 has been released. Just renaming the googledata-1.0 ebuild
> works fine.
> 

Comment 8 Jochen Bauer 2010-05-07 19:42:43 UTC
I just tried to emerge googledata. But I didn't got it. There is a dependency libxml. Should be libxml2 now. There is a new ebuild for libgcal where that dependency is fixed. Shouldn't that be in the overlay already, since it is from month ago?
Comment 9 saft 2010-07-12 13:34:08 UTC
Was able to emerge googledata, works somehow, but it doesn't save the login data, so it fails after restart. Kwallet integration possible?

Thanks for your hard work!

greets saft
Comment 10 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-02 13:18:52 UTC
this is already in overlay as kde-misc/akonadi-googledata since Aug 3
http://git.overlays.gentoo.org/gitweb/?p=proj/kde.git;a=commit;h=3dd6e374eafa5522a0af522ad1a2dffcbac8773a