Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279972 - games-emulation/openmsx: fails to build with gcc-4.4
Summary: games-emulation/openmsx: fails to build with gcc-4.4
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-08-01 23:14 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-10 08:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (openmsx-0.7.0:20090801-225820.log,3.62 KB, text/plain)
2009-08-01 23:14 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-01 23:14:41 UTC
As per summary, check attached build log.

And _please_ try not to fix it in the wrong way: http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-01 23:14:56 UTC
Created attachment 199862 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-10 07:17:17 UTC
Diego, I can't reproduce this on x86_64. Could it be missing <stdint.h> or <cstdint> for x86?
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-10 08:41:33 UTC
OR was some dependency library that was fixed in the mean time (it's merged in the tinderbox as well).