Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 279765 - sys-apps/file-5.03 does not cross compile with "python" use flag
Summary: sys-apps/file-5.03 does not cross compile with "python" use flag
Status: RESOLVED DUPLICATE of bug 269111
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-31 07:15 UTC by Christopher Friedt
Modified: 2009-08-14 07:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Friedt 2009-07-31 07:15:26 UTC
When cross-compiling sys-apps/file-5.03, in the "python" subdirectory, the build systems attempts to use the build-compiler and the cross-CFLAGS together, which obviously does not work.

My suggestion is to apply some patch to python/Makefile.in if cross-compiling, so that it is sensetive to some variable like buildCFLAGS / or hostCFLAGS, whatever is appropriate. 

===================================================

make[1]: Leaving directory `/tmp/arm-softfloat-linux-gnueabi/portage/sys-apps/file-5.03/work/file-5.03'
running build
running build_ext
building 'magic' extension
creating build
creating build/temp.linux-i686-2.5
i686-pc-linux-gnu-gcc -pthread -fno-strict-aliasing -Os -pipe -march=armv5te -mtune=iwmmxt -fomit-frame-pointer -I/usr/arm-softfloat-linux-gnueabi/usr/include/ -I/usr/arm-softfloat-linux-gnueabi/include/ -D_GNU_SOURCE -fPIC -I./ -I../ -I../src -I/usr/include/ -I/usr/include/python2.5 -c -I./ -I../ -I../src -I/usr/include/ -I/usr/include/python2.5 -c py_magic.c -o build/temp.linux-i686-2.5/py_magic.o
py_magic.c:1: error: bad value (armv5te) for -march= switch
py_magic.c:1: error: bad value (iwmmxt) for -mtune= switch
error: command 'i686-pc-linux-gnu-gcc' failed with exit status 1
 * 
 * ERROR: sys-apps/file-5.03 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3126:  Called distutils_src_compile
 *             environment, line  907:  Called die
 * The specific snippet of code:
 *       ${python} setup.py build "$@" || die "compilation failed"
 *  The die message:
 *   compilation failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/tmp/arm-softfloat-linux-gnueabi/portage/sys-apps/file-5.03/temp/build.log'.
 * The ebuild environment file is located at '/tmp/arm-softfloat-linux-gnueabi/portage/sys-apps/file-5.03/temp/environment'.
 * 



Reproducible: Always
Comment 1 SpanKY gentoo-dev 2009-08-14 07:31:07 UTC
not a problem in the file package

*** This bug has been marked as a duplicate of bug 269111 ***