Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279038 - dev-python/docutils-0.4-r3 missing depend on setuptools
Summary: dev-python/docutils-0.4-r3 missing depend on setuptools
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Python Gentoo Team
Depends on:
Reported: 2009-07-25 12:32 UTC by Tymoteusz Paul
Modified: 2009-07-25 13:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Log from emerge (docustils.log,2.62 KB, text/plain)
2009-07-25 12:33 UTC, Tymoteusz Paul

Note You need to log in before you can comment on or make changes to this bug.
Description Tymoteusz Paul 2009-07-25 12:32:35 UTC
When i've tried to install docutils (via emerge docutils) emerge will crash because setuptools are not installed.

Reproducible: Always

Steps to Reproduce:
1. make sure that you've unmerged setuptools and docutils
2. try to emerge docutils
Actual Results:  
Error complaining about lack of docutils

Expected Results:  
It should install docutils and required dependency (setuptools in this case)
Comment 1 Tymoteusz Paul 2009-07-25 12:33:18 UTC
Created attachment 199113 [details]
Log from emerge
Comment 2 Tymoteusz Paul 2009-07-25 12:34:10 UTC
Emm i've made a "typo" there, actualy result should be: Error complaining about lack of setuptools.
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-25 13:15:18 UTC
# grep ^DEPEND= dev-python/docutils/docutils-0.4-r3.ebuild
Comment 4 Tymoteusz Paul 2009-07-25 13:19:24 UTC
I got the same result from grep on my local machine as you, but still for some reason docutils is not installing setuptools.
Comment 5 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-25 13:24:11 UTC
Maybe your dev-python/setuptools is broken or it's installed for different Python version.

Reinstall dev-python/setuptools.
If you recently switched Python version, run python-updater.