Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 278216 - media-gfx/yafray-0.9.0-r1: compilation error due to wrong use of strrchr (patch included)
Summary: media-gfx/yafray-0.9.0-r1: compilation error due to wrong use of strrchr (pat...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4 glibc-2.10
  Show dependency tree
 
Reported: 2009-07-18 00:17 UTC by Some stupid real name
Modified: 2010-01-09 16:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch solving the issue (yafray-0.0.9-r1-constchar.patch,96 bytes, patch)
2009-07-18 00:18 UTC, Some stupid real name
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Some stupid real name 2009-07-18 00:17:35 UTC
The developers used char* ext = strrchr(filename, '.') rather than CONST char* ext. Fixed. Please switch to Yafaray instead of Yafray in the portage tree (bug 273738).

Reproducible: Always

Steps to Reproduce:
1. Emerge yafray with GCC 4.4.

Actual Results:  
Compile error.

Expected Results:  
Clean compilation.

GCC 4.4.0-r1, rest unimportant.
Comment 1 Some stupid real name 2009-07-18 00:18:45 UTC
Created attachment 198367 [details, diff]
patch solving the issue
Comment 2 Samuli Suominen gentoo-dev 2010-01-09 16:35:48 UTC
Yep, that does the trick.

+  09 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
+  yafray-0.0.9-r1.ebuild, +files/yafray-0.0.9-gcc44.patch:
+  Fix building with GCC 4.4+ wrt #278216.

Since you didn't use realname in bugzilla, I left the credits out...