Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 278114 - Problem emerging media-video/vlc
Summary: Problem emerging media-video/vlc
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-17 06:20 UTC by Pierre
Modified: 2009-09-08 16:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log file (build.log,382.52 KB, text/plain)
2009-07-17 07:09 UTC, Pierre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre 2009-07-17 06:20:20 UTC
[...]
/bin/sh ../../libtool --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../..   -I../../include -I../../include  -DSYS_LINUX `top_builddir="../.." ../../vlc-config --cflags plugin libaout_sdl_plugin_la-sdl.lo` -O2 -pipe -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -MT libaout_sdl_plugin_la-sdl.lo -MD -MP -MF .deps/libaout_sdl_plugin_la-sdl.Tpo -c -o libaout_sdl_plugin_la-sdl.lo `test -f 'sdl.c' || echo './'`sdl.c
 x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -I../../include -I../../include -DSYS_LINUX -D_FILE_OFFSET_BITS=64 -D__USE_UNIX98 -D_LARGEFILE64_SOURCE -D_REENTRANT -D_THREAD_SAFE -D__LIBVLC__ -D__PLUGIN__ -DMODULE_NAME=aout_sdl -DMODULE_NAME_IS_aout_sdl -DMODULE_STRING=\"aout_sdl\" -O0 -I/usr/include/ -D_GNU_SOURCE=1 -D_REENTRANT -O2 -pipe -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -MT libaout_sdl_plugin_la-sdl.lo -MD -MP -MF .deps/libaout_sdl_plugin_la-sdl.Tpo -c sdl.c  -fPIC -DPIC -o .libs/libaout_sdl_plugin_la-sdl.o
sdl.c: In function 'Open':
sdl.c:185: warning: assignment discards qualifiers from pointer target type
sdl.c:201: warning: assignment discards qualifiers from pointer target type
sdl.c:204: warning: assignment discards qualifiers from pointer target type
mv -f .deps/libaout_sdl_plugin_la-sdl.Tpo .deps/libaout_sdl_plugin_la-sdl.Plo
/bin/sh ../../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -std=gnu99 `top_builddir="../.." ../../vlc-config --cflags plugin libaout_sdl_plugin.la` -O2 -pipe -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -rpath '/usr/lib64/vlc/audio_output' -avoid-version -module -no-undefined -export-symbol-regex ^vlc_entry -shrext .so `top_builddir="../.." ../../vlc-config --ldflags plugin libaout_sdl_plugin.la` -Wl,-O1 -o libaout_sdl_plugin.la  libaout_sdl_plugin_la-sdl.lo  `top_builddir="../.." ../../vlc-config -libs plugin libaout_sdl_plugin.la` ../../src/libvlccore.la 
grep: /usr/lib64/libcucul.la: No such file or directory
/bin/sed: can't read /usr/lib64/libcucul.la: No such file or directory
libtool: link: `/usr/lib64/libcucul.la' is not a valid libtool archive
make[4]: *** [libaout_sdl_plugin.la] Error 1
make[4]: Leaving directory `/var/tmp/portage/media-video/vlc-0.9.9a-r1/work/vlc-0.9.9a/modules/audio_output'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/media-video/vlc-0.9.9a-r1/work/vlc-0.9.9a/modules/audio_output'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-0.9.9a-r1/work/vlc-0.9.9a/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-0.9.9a-r1/work/vlc-0.9.9a'
make: *** [all] Error 2
 * 
 * ERROR: media-video/vlc-0.9.9a-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3942:  Called die
 * The specific snippet of code:
 *       emake || die "make of VLC failed"
 *  The die message:
 *   make of VLC failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-video/vlc-0.9.9a-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-0.9.9a-r1/temp/environment'.
 * 

>>> Failed to emerge media-video/vlc-0.9.9a-r1, Log file:

>>>  '/var/tmp/portage/media-video/vlc-0.9.9a-r1/temp/build.log'

 * Messages for package media-video/vlc-0.9.9a-r1:

 * USE=cddb requires either cdda or cddax, cddb will be disabled.
 * 
 * ERROR: media-video/vlc-0.9.9a-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3942:  Called die
 * The specific snippet of code:
 *       emake || die "make of VLC failed"
 *  The die message:
 *   make of VLC failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-video/vlc-0.9.9a-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-0.9.9a-r1/temp/environment'.
 *
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-17 06:36:52 UTC
Please post your "emerge --info" and attach the build.log file of the failed emerge to this bug.
Comment 2 Pierre 2009-07-17 07:09:29 UTC
Created attachment 198255 [details]
build.log file
Comment 3 Pierre 2009-07-17 07:10:32 UTC
# LC_ALL=C emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r5-x86_64-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-glibc2.2.5
Timestamp of tree: Fri, 17 Jul 2009 05:45:02 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.4.4-r14, 2.5.4-r3
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ "
LANG="fr_FR.UTF-8"
LC_ALL="C"
LDFLAGS="-Wl,-O1"
LINGUAS="fr en de nl"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib accessibility acl acpi afs aim alsa amd64 ao apache2 apm arts audiofile avahi bash-completion bcmath berkdb blas bzip2 cairo calendar cddb cdparanoia cdr cli cracklib crypt css ctype cups curl cxx dbus dbx dga directfb doc dri dts dvd dvdr dvdread emacs encode esd exif expat fam fbcon ffmpeg fftw firefox flac fontconfig foomaticdb fortran ftp gcj gd gdbm geoip ggi gif gimp gmp gnome gnutls gpm gsl gstreamer gtk hal hddtemp iconv icq icu idn imagemagick imap imlib innodb ipv6 isdnlog jabber jack javascript jbig jingle jpeg jpeg2k kde kerberos kolab krb4 ladspa lame lash latex lcms ldap libcaca libnotify libsamplerate libwww lirc lm_sensors lzo mad maildir matroska mbox mhash midi mikmod mime mmx mng modplug motif mozilla mp3 mpeg mplayer msn mudflap multilib musepack musicbrainz mysql mysqli nas ncurses nls nntp nptl nptlonly nsplugin odbc ogg openal opengl openmp osc oscar pam pcmcia pcre pda pdf perl php plotutils png portaudio posix postgres pppd pulseaudio python qt4 quicktime raw readline recode reflection rss samba sasl scanner sdl session sharedext sharedmem shorten simplexml sndfile sockets sox speex spell spl sqlite sse sse2 ssl startup-notification subversion svg symlink sysfs syslog sysvipc szip taglib tcl tcpd theora threads tidy tiff timidity tk truetype unicode usb vhosts vorbis wavpack wifi wmf wxwindows x264 xcb xcomposite xft xine xml xorg xosd xpm xprint xscreensaver xsl xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en de nl" USERLAND="GNU" VIDEO_CARDS="nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-17 07:31:02 UTC
did you run revdep-rebuild from app-portage/gentoolkit?
Comment 5 Wormo (RETIRED) gentoo-dev 2009-07-18 06:25:14 UTC
Sounds like same thing as bug 244350 (if it is the same, Lars' suggestion of revdep-rebuild will fix your problem)
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2009-07-18 17:02:50 UTC
libcucul.so & libcucul.la is no more, the functions got merged into libcaca itself
it's not a bug, it's the way upstream wanted it

solution is revdep-rebuild