Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 277981 - dev-python/apptools-3.2 and dev-python/envisagecore-3.1: circular dependencies
Summary: dev-python/apptools-3.2 and dev-python/envisagecore-3.1: circular dependencies
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-15 19:22 UTC by Martin Zibricky
Modified: 2009-07-15 19:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Zibricky 2009-07-15 19:22:41 UTC
When trying to emerge envisagecore it fails with error: circular depencencies

Reproducible: Always

Steps to Reproduce:
1. unmask dev-python/envisagecore-3.1 and related ebuilds
2. emerge envisagecore
3.

Actual Results:  
emerge envisagecore fails with error:

Calculating dependencies... done!


[nomerge      ] dev-python/envisagecore-3.1.0  USE="doc examples test" 
[ebuild  N    ]  dev-python/apptools-3.2.0  USE="test -doc -examples" 
[ebuild  N    ]   dev-python/envisagecore-3.1.0  USE="doc examples test" 

 * Error: circular dependencies:

('ebuild', '/', 'dev-python/envisagecore-3.1.0', 'merge') depends on
  ('ebuild', '/', 'dev-python/apptools-3.2.0', 'merge') (buildtime)
('ebuild', '/', 'dev-python/apptools-3.2.0', 'merge') depends on
  ('ebuild', '/', 'dev-python/envisagecore-3.1.0', 'merge') (runtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.


Expected Results:  
install requested ebuild

Step to resolve:

1. remove the dependency of apptool on envisagecore
Comment 1 Sebastian Luther (few) 2009-07-15 19:30:44 UTC
emerge --info please.
Comment 2 Sebastian Luther (few) 2009-07-15 19:49:02 UTC
(In reply to comment #1)
> emerge --info please

nvm.

(In reply to comment #0) 
[...]  
>  * Note that circular dependencies can often be avoided by temporarily
>  * disabling USE flags that trigger optional dependencies.

Install them first with "FEATURES=-test".

*** This bug has been marked as a duplicate of bug 175808 ***