Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277567 - kde-misc/kload: fails to build with glibc-2.10
Summary: kde-misc/kload: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Briesenick (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-12 23:56 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-08 22:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (kload-0.9.4-r1:20090712-092554.log,4.43 KB, text/plain)
2009-07-12 23:57 UTC, Diego Elio Pettenò (RETIRED)
Details
adds couple consts to make gcc44 + glibc210 combo happy (kload-0.9.4-glibc210.patch,986 bytes, patch)
2009-08-06 00:27 UTC, Arttu Valo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-12 23:56:57 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-12 23:57:41 UTC
Created attachment 197705 [details]
Build log
Comment 2 Arttu Valo 2009-08-06 00:27:54 UTC
Created attachment 200321 [details, diff]
adds couple consts to make gcc44 + glibc210 combo happy
Comment 3 Samuli Suominen gentoo-dev 2009-08-08 22:16:12 UTC
fixed, thanks