Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277564 - sci-libs/galib: fails to build with gcc-4.4
Summary: sci-libs/galib: fails to build with gcc-4.4
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-07-12 23:54 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-10 08:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (galib-2.4.7:20090712-084328.log,8.67 KB, text/plain)
2009-07-12 23:54 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-12 23:54:27 UTC
As per summary, check attached build log.

And _please_ try not to fix it in the wrong way: http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-12 23:54:50 UTC
Created attachment 197702 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-10 08:17:11 UTC
>>> Recording sci-libs/galib in "world" favorites file...

Can't reproduce on x86_64 with GLIBC 2.10+ and GCC 4.4+