Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277026 - app-misc/workrave: fails to build with glibc-2.10
Summary: app-misc/workrave: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-08 12:17 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-06 16:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (workrave-1.9.0:20090708-120738.log,74.64 KB, text/plain)
2009-07-08 12:18 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 12:17:59 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 12:18:23 UTC
Created attachment 197169 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-06 16:45:15 UTC
fixed, thanks