Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276500 - kde-misc/kgtk: fails to build with glibc-2.10
Summary: kde-misc/kgtk: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Schweizer (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-04 21:27 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-08 21:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (kgtk-0.10.1:20090704-190509.log,13.10 KB, text/plain)
2009-07-04 21:27 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-04 21:27:24 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-04 21:27:44 UTC
Created attachment 196677 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-08 21:57:43 UTC
+  08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> kgtk-0.10.1.ebuild,
+  +files/kgtk-0.10.1-glibc-2.10.patch:
+  Fix building with GLIBC 2.10+ wrt #276500.
+