Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276319 - x11-drivers/xf86-video-ati lost DRI from a recent update
Summary: x11-drivers/xf86-video-ati lost DRI from a recent update
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 287854 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-02 23:44 UTC by Peter
Modified: 2009-10-09 21:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
xorg xlog (xorgxlog.txt,17.36 KB, text/plain)
2009-07-02 23:45 UTC, Peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2009-07-02 23:44:22 UTC
I have no idea which update did this, I know I've had this for a while, but at this point it could be x or the kernel, though I suspect its the x ati driver.  I went only so far as to see that the kernel call to drm_agp_acquire fails.  So maybe console framebuffer is not releasing card or something?  I assume I'm overthinking something simple as usual.  I've tried with and without agpart in the kernel, I don't have kernel modules on, its all compiled in.  radeon driver is in the kernel, not ati.

Anyway, I'm particularly annoyed with it because it was working perfectly until quite recently.  Now some opengl apps fail (like qt gl apps) but not all, etc., etc.. but I assume that's all caused by the dri issues.  console frame buffer works fine.

This is an ATI Radeon x850 XT PE.

Further info is attached.
Comment 1 Peter 2009-07-02 23:45:13 UTC
Created attachment 196458 [details]
xorg xlog
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-07-05 20:06:16 UTC
(WW) RADEON(0): [agp] AGP not available (-19)
(EE) RADEON(0): [agp] AGP failed to initialize. Disabling the DRI.
(II) RADEON(0): [agp] You may want to make sure the agpgart kernel module

your kernel dont have agp enabled. Fix yourself :]
Comment 3 Peter 2009-07-06 01:26:20 UTC
Wow Tomas, way to read the comment: 

"I've tried with and without agpart in
the kernel, I don't have kernel modules on, its all compiled in."

Thanks.
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2009-07-07 11:40:35 UTC
Hm, i was really hoping that is the issue :]
So it is not working even if you compile in agp support and restart to that kernel?
Comment 5 Peter 2009-07-07 20:08:16 UTC
It was either going from 2.6.28r5 to 2.6.29r5 or it was some recent x ati driver changes.

Is there a recent why the console might not release the card?  Is that a possibility?
Comment 6 Rémi Cardona gentoo-dev 2009-09-24 08:08:58 UTC
Please file a bug over in FreeDesktop's bugzilla and paste the url here. There's little we can do to help you out here.

Thanks
Comment 7 Rémi Cardona gentoo-dev 2009-09-24 08:09:36 UTC
FreeDesktop's bugzilla being : https://bugs.freedesktop.org/

Thanks
Comment 8 Peter 2009-09-24 18:58:05 UTC
Well its frustrating because it worked before.  Now it doesn't.
Comment 9 Justin Lecher (RETIRED) gentoo-dev 2009-10-09 19:27:15 UTC
*** Bug 287854 has been marked as a duplicate of this bug. ***
Comment 10 Peter 2009-10-09 21:28:10 UTC
Forget it, I screwed this up.  I got the damn bridge wrong and I have no idea why it worked before but its not a bug.  Qt is still really slow with the new xorg server but that's something else.