Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274831 - kdeprefix use flag appears to be masked
Summary: kdeprefix use flag appears to be masked
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-20 16:10 UTC by Łukasz Siudut
Modified: 2009-07-02 21:57 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Łukasz Siudut 2009-06-20 16:10:46 UTC
After last sync it's impossible to set kdeprefix use flag. It appears to be masked.

# emerge -vp kdelibs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] kde-base/kdelibs-4.2.4-r3 [4.2.4-r1] USE="acl alsa bzip2 handbook mmx nls opengl semantic-desktop spell sse sse2 ssl -3dnow (-altivec) -bindist -debug -doc -fam -jpeg2k (-kdeprefix*) -kerberos -openexr -test -zeroconf" 0 kB [0]
[ebuild     U ] kde-base/kdebase-data-4.2.4-r1 [4.2.4] USE="(-kdeprefix*)" 0 kB [1=>0]
[ebuild   R   ] kde-base/kde-env-4.2.4  USE="(-kdeprefix*)" 0 kB [1=>0]


Reproducible: Always

Steps to Reproduce:
Comment 1 Dror Levin (RETIRED) gentoo-dev 2009-06-20 18:22:02 UTC
This was decided on the last KDE team meeting one June 18th as a step towards stabilizing kde4, as kdeprefix caused numerous problems for users. Those who really need it can unmask it in /etc/portage/profile — read man portage for more details.
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-06-20 20:05:20 UTC
As explained above,
this bug is invalid.
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-20 20:12:10 UTC
Yeah, and kept open for a reason, guess what :)
Comment 4 lopan 2009-06-22 16:38:45 UTC
Can I unmask the kdeprefix?
Comment 5 Joshua J. Berry 2009-06-23 00:05:22 UTC
During the last update on my system (emerge -uDNav @system @world), some packages (kdelibs, kde-env and a few others) got re-merged with USE=-kdeprefix, while most did not.  (I imagine this is a separate Portage bug.)

This left KDE on my work machine in an unusable state.  (KDM couldn't even start, because it could no longer find its greeter plugin.)  I'm rebuilding now with +kdeprefix, but I estimate I've lost at least an hour to this so far and will lose a couple more as kdelibs et al rebuilds.

I appreciate the massive amount of time and effort you guys have put in to produce a set of working, flexible KDE ebuilds for Gentoo.  I must say that until now, I've been impressed with their quality and stability.  I've gotten used to updates not breaking my system -- my mistake for not looking at emerge -p more closely. ;) 

But frankly, springing this change on users unannounced is unacceptable (to me, anyway -- I can't speak for anyone else).  It's a very large change, and has resulted in at least one broken machine.  The very least you could do is warn users, loudly, ahead of time that this change is coming, it may cause breakage, and explain what to do if it does.

In the meantime, please revert this change immediately.  Thank you.
Comment 6 Kevin Wilson 2009-06-23 03:20:09 UTC
It's trivial to unmask it if you really need to. I don't, however, think the decision to mask kdeprefix was a good one, as I've never had any problems with it and use it to keep kde3 and kde4 unaware of each other. It's even disabled by default.
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-29 19:01:37 UTC
http://www.gentoo.org/proj/en/desktop/kde/kde4-guide.xml
The guide has been updated, with a full explanation of pros and cons of kdeprefix, and the reasons that it is masked. I'm closing this bug.
Comment 8 Joshua J. Berry 2009-06-29 19:10:00 UTC
Thank you for updating the documentation.

I do want to repeat, however, that I feel a change as invasive as this one requires advance notice.  I hope the next time such a change needs to be made, the Gentoo KDE team will take this into consideration.

Thanks again.
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-29 19:21:28 UTC
I was away at the last meeting and since i usually take care of those kde pr issues, i was unaware of the masking of kdeprefix use flag. Also i was busy with my exams...
But of course that isn't an excuse, someone should have announced and documented that change. Nevertheless i'm writing an eselect news item right now to announce the guide, since it covers the kdeprefix issue as long as the problem with monolithic ebuilds in kde3. Thanks and sorry for the mess
Comment 10 Joshua J. Berry 2009-06-29 19:28:06 UTC
Thanks, Theo.  Fortunately all it took for me was an overnight rebuild with -kdeprefix and everything is happy again. (Stuff not getting rebuilt properly before turned out to be my fault -- I was missing some packages in @world. >.>)

Like I said earlier, I really appreciate all the work you guys put into packaging KDE for Gentoo.
Comment 11 Daniel Bahrdt 2009-07-02 21:57:11 UTC
There realy should be some kind of warning (big and fat) if you're upgrading some packages to -kdeprefix and some packages stay kdeprefix. This crashed a friends system and now he wants to switch back to windows. Mission accomplished.