Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274490 - media-libs/alsa-lib-1.0.18 - Unable to set hw-parameters: Broken pipe
Summary: media-libs/alsa-lib-1.0.18 - Unable to set hw-parameters: Broken pipe
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: http://www.sendspace.com/file/6qkbiq
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-17 10:21 UTC by Mariusz S
Modified: 2010-06-11 17:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mariusz S 2009-06-17 10:21:40 UTC
Every application launched from konsole (KDE Terminal) exits with:
aplay-1.0.18: set_params:1022: Unable to install hw params
mplayer-1.0_rc2_p20090322: [AO_ALSA] Unable to set hw-parameters: Broken pipe

The same commands work perfectly in console (session without X).
I use snd-usb-audio connected via USB hub.
Integrated hda-intel works in konsole & in console.

Reproducible: Always

Steps to Reproduce:
konsole
1. aplay -D hw:0,0 test.wav
2. aplay -D hw:1,0 test.wav

console
1. aplay -D hw:0,0 test.wav
2. aplay -D hw:1,0 test.wav
Actual Results:  
konsole
1. Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
2. aplay: set_params:1022: Unable to install hw params:

console
1. Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
2. Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Expected Results:  
It should work or doesn't work in both sessions. Because it doesn't in konsole only I assigned KDE category to this bug.

Configs & logs at url above.

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r5-x86_64-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-glibc2.2.5
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -mtune=core2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-O2 -march=core2 -mtune=core2 -pipe -fomit-frame-pointer"
MAKEOPTS="-j3"
USE="X a52 aac aalib acl acpi alsa amd64 apache apache2 asf automount battery berkdb bluetooth bzip2 ccache cdaudio cdda cddb cdparanoia cdr cli cracklib crypt ctype cups dirac divx dri dts dv dvd dvdr dvdread ffmpeg firefox flac fortran gdbm gif gpm hal iconv ifp ipv6 isdnlog jpeg kde kdeprefix ladspa libcaca lzo mad midi mmx mmxext mp3 mpeg mplayer mudflap multilib musepack mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl php png pppd pvr python qt qt3 qt3support qt4 quicktime readline realmedia reflection samba sdl session spell spl srt sse sse2 ssl ssse3 sysfs tcpd tiff tk truetype unicode v4l v4l2 vcd vorbis wav wma wmp xcomposite xml xorg xscreensaver xsl xulrunner xv xvid xvmc zlib"
ALSA_CARDS="usb-audio hda-intel"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"
ELIBC="glibc"
Comment 1 Mariusz S 2009-06-17 11:17:26 UTC
/etc/modprobe.d/alsa.conf
options snd-hda-intel index=0 model=laptop-hpsense
options snd-usb-audio index=1 vid=0x0d8c pid=0x0102

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio


lsmod
snd_seq_dummy           3020  0 
snd_seq_oss            29824  0 
snd_seq_midi_event      6616  1 snd_seq_oss
snd_seq                50064  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            37264  0 
snd_mixer_oss          14616  1 snd_pcm_oss
snd_usb_audio          91120  0 
snd_usb_lib            16056  1 snd_usb_audio
snd_rawmidi            20880  1 snd_usb_lib
snd_seq_device          6668  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_hda_codec_conexant    23784  1 
snd_hda_intel          27432  0 
snd_hda_codec          57912  2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep               7840  2 snd_usb_audio,snd_hda_codec
snd_pcm                72160  4 snd_pcm_oss,snd_usb_audio,snd_hda_intel,snd_hda_codec
snd_timer              20296  2 snd_seq,snd_pcm
snd                    58920  13 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_usb_audio,snd_rawmidi,snd_seq_device,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc          8808  2 snd_hda_intel,snd_pcm


equery l alsa
media-libs/alsa-lib-1.0.18
media-sound/alsa-headers-1.0.18
media-sound/alsa-utils-1.0.18

equery h alsa
app-cdr/k3b-1.0.5-r5
media-libs/libsdl-1.2.13-r1
media-libs/libsndfile-1.0.20
media-gfx/gimp-2.6.4
media-sound/audacity-1.3.7
kde-base/kmix-3.5.10
kde-base/kdelibs-3.5.10-r6
media-video/ffmpeg-0.5-r1
app-emulation/emul-linux-x86-soundlibs-20080418
Comment 2 Mariusz S 2009-06-17 14:09:47 UTC
Looks like its related to USB hub (attached usb sound card and logitech mouse).
It turned out usb sound card works properly if I unplug usb mouse from the hub.

I'm still trying to figure out how to make both working.
It's not hardware issue because there was no problem on Gentoo x86 before.
Comment 3 Maciej Blizinski 2009-09-24 20:45:31 UTC
Same problem here. When the external sound card is plugged into a USB hub, I'm getting the same error. Plugged the card directly into the computer -- works fine.
Comment 4 Andreas K. Hüttel gentoo-dev 2010-06-11 17:38:43 UTC
Not in tree anymore