Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274284 - media-video/mpeg4ip removal request (was: fails to build with glibc-2.10)
Summary: media-video/mpeg4ip removal request (was: fails to build with glibc-2.10)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo TreeCleaner Project
URL: http://forums.gentoo.org/viewtopic-t-...
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-15 20:30 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-02 10:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (mpeg4ip-1.5.0.1-r6:20090615-175528.log,59.19 KB, text/plain)
2009-06-15 20:30 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 20:30:23 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 20:30:41 UTC
Created attachment 194834 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-07-10 11:01:13 UTC
mpeg4ip is obsolete. libmp4v2 got new upstream and it's shipping a set of utils too.

adding treecleaners; this can be removed since nothing is using it, it doesn't compile and it has a replacement.
Comment 3 Víctor Ostorga (RETIRED) gentoo-dev 2009-07-10 16:14:02 UTC
# Víctor Ostorga <vostorga@gentoo.org> (10 Jul 2009)
# media-video/mpeg4ip doesn't build wrt #274284
# mpeg4ip is obsolete, libmp4v2 got new upstream.
# Removal scheduled in 2009-09-10
media-video/mpeg4ip
Comment 4 Kai Krakow 2009-07-11 12:03:10 UTC
I need the mp4creator utility from mpeg4ip. Comment #2 says that libmp4v2 ships with utilities. I installed that and found no utilities...
Comment 5 Samuli Suominen gentoo-dev 2009-07-11 12:23:53 UTC
(In reply to comment #4)
> I need the mp4creator utility from mpeg4ip. Comment #2 says that libmp4v2 ships
> with utilities. I installed that and found no utilities...
> 

http://mp4creator.sourceforge.net/ ?

Plus you need USE="utils" to get utilities..
Comment 6 Kai Krakow 2009-07-11 13:00:19 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > I need the mp4creator utility from mpeg4ip. Comment #2 says that libmp4v2 ships
> > with utilities. I installed that and found no utilities...
> > 
> 
> http://mp4creator.sourceforge.net/ ?

Yeah it looks like that though I only need the cli version to prepare mp4 files generated by ffmpeg for streaming. This is used in a video portal website project I am currently running in production - a rails application running rvideo gem to background encode video streams.

> Plus you need USE="utils" to get utilities..

The stable version does not have this. And the 1.9.0 version does not like my installed faac version.

If you suggest an alternative to mpeg4ip which works just now I would appreciate it. I don't bother much about mpeg4ip - i just installed it for having the mp4creator utility.
Comment 7 Samuli Suominen gentoo-dev 2009-07-11 13:04:03 UTC
The prob is that mpeg4ip has been abandoned by upstream long ago, but I'm not trying to jump any hoops to kill it.. We can leave it (yet again) in tree, if someone provides a patch so it even compiles.

I suggest however you leave a Feature request ticket on the new mp4v2's project's googlecode page. Maybe they can add this application?
Comment 8 Kai Krakow 2009-07-11 13:14:59 UTC
Alternatively I would like to provide an ebuild for mp4creator so I can probably/hopefully compile it even without gui (something which offended me in the mpeg4ip ebuild - it required gtk and pulled in parts of xorg) - so need no gui on a server. For so long please leave the mpeg4ip ebuild around.
Comment 9 Kai Krakow 2009-07-11 13:22:29 UTC
(In reply to comment #8)
> Alternatively I would like to provide an ebuild for mp4creator [...]

Other alternative: From the libmp4v2 1.9.0 documentation I found there's a utility "mp4file --optimize" which probably has exactly the function I need.

Sorry for the noise, I didn't find the google code page before (just some plain text page with older versions). So please make libmp4v2 stable before mpeg4ip removal.
Comment 10 Samuli Suominen gentoo-dev 2009-07-11 13:28:33 UTC
(In reply to comment #9)
> Sorry for the noise, I didn't find the google code page before (just some plain
> text page with older versions). So please make libmp4v2 stable before mpeg4ip
> removal.

No. Current mpeg4ip isn't stable, and I won't be removed at least for 30 days (or 60 days).

The timeframe gives us plenty to time to get libmp4v2 into stable in next 30 days, I've just unmasked it from package.mask into ~arch.
Comment 11 Samuli Suominen gentoo-dev 2009-07-11 13:43:04 UTC
Kai, if you can verify that the mp4creator in the sourceforge page does something useful for you, I can look into adding it.. I don't want to waste time on a application noone would need
Comment 12 Kai Krakow 2009-07-11 14:23:44 UTC
(In reply to comment #11)
> Kai, if you can verify that the mp4creator in the sourceforge page does
> something useful for you, I can look into adding it.. I don't want to waste
> time on a application noone would need

If you can get libmp4v2-1.9.0 into shape to be compatible with portage's libfaac then I'd be happy to testdrive the mp4file utility provided by libmp4v2. I'm pretty sure it does what I need. (I used mp4creator's --optimize feature before although the tool could do a whole lot more other stuff, so total overkill anyway -- no need for mp4creator if mp4file does what I need)
Comment 13 Samuli Suominen gentoo-dev 2009-07-11 14:25:53 UTC
(In reply to comment #12)
> If you can get libmp4v2-1.9.0 into shape to be compatible with portage's
> libfaac then I'd be happy to testdrive the mp4file utility provided by
> libmp4v2. I'm pretty sure it does what I need. (I used mp4creator's --optimize
> feature before although the tool could do a whole lot more other stuff, so
> total overkill anyway -- no need for mp4creator if mp4file does what I need)

It should be compatible as it is, put both media-libs/libmp4v2 and media-libs/faac into package.keywords and package.unmask.. media-libs/faac-1.28-r1
Comment 14 Kai Krakow 2009-07-11 14:43:08 UTC
(In reply to comment #13)
> It should be compatible as it is, put both media-libs/libmp4v2 and
> media-libs/faac into package.keywords and package.unmask..
> media-libs/faac-1.28-r1

Argh! I wish sometimes portage could be a bit more helpful/verbose on dependency resolution (kudos to the portage guys who made many improvments on that point during the last months). I can emerge that now.

It looks like mp4file is doing what I need. However, I will apply it to my test data first to be sure. Can take a few days, I need to work on ffmpeg 0.5 compat and testing a little bit first and find a way to fix two-pass encoding in libx264 (the log file creation is not multitasking/multiprocess compatible).
Comment 15 Kai Krakow 2009-07-18 07:40:22 UTC
Samuli,

as far as I am concerned, the new libmp4v2 suite is a complete replacement of mp4creator. So no more need to bother about this mp4creator. :-)
Comment 16 lily 2009-07-20 13:21:07 UTC
(In reply to comment #15)
> Samuli,
> 
> as far as I am concerned, the new libmp4v2 suite is a complete replacement of
> mp4creator. So no more need to bother about this mp4creator. :-)
> 

using media-libs/libmp4v2-1.9.1 with utils USE, I should do what to instead of these two command? there is no "mp4creator" now.

mp4creator -create=/tmp/v.263 out.mp4
mp4creator -hint=3 out.mp4
Comment 17 Samuli Suominen gentoo-dev 2009-07-20 18:12:57 UTC
(In reply to comment #16)
> using media-libs/libmp4v2-1.9.1 with utils USE, I should do what to instead of
> these two command? there is no "mp4creator" now.
> 
> mp4creator -create=/tmp/v.263 out.mp4
> mp4creator -hint=3 out.mp4

See e.g., /usr/share/doc/libmp4v2-1.9.1/ToolGuide.txt.bz2

And people on Gentoo forums also suggest using media-video/gpac's MP4Box utility if I recall it's name right.
Comment 19 Samuli Suominen gentoo-dev 2009-08-02 10:00:47 UTC
gone; useless as gcc-4.4 is being unmasked