Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 2741 - wxGtk build fails
Summary: wxGtk build fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: SpanKY
Depends on:
Reported: 2002-05-14 22:26 UTC by Per Wigren
Modified: 2002-10-29 00:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Per Wigren 2002-05-14 22:26:36 UTC
creating samples/fl/fl_sample2/Makefile 
creating samples/fl/fl_sample3/Makefile 
creating utils/Makefile 
creating utils/wxrc/Makefile 
creating utils/wxrcedit/Makefile 
creating utils/convertrc/Makefile 
Makefile:141: src/motif/files.lst: No such file or directory 
make: *** No rule to make target `src/motif/files.lst'.  Stop. 
Makefile:141: src/motif/files.lst: No such file or directory 
make: *** No rule to make target `src/motif/files.lst'.  Stop. 
!!! ERROR: The ebuild did not complete successfully. 
!!! Function src_compile, Line 86, Exitcode 2 
!!! (no error message) 
!!! emerge aborting on  /usr/portage/x11-libs/wxGTK/wxGTK-2.3.2-r1.ebuild .
Comment 1 Tod M. Neidt (RETIRED) gentoo-dev 2002-05-15 08:31:38 UTC
Could you provide more details.

1. I assume you were trying to build against motif?
The wxGTK build can't handle gtk and motif at the same time.  
Comment 2 Per Wigren 2002-05-15 11:17:16 UTC
No, I have "-motif" in my USE-variable... 
Hmm, thinking about it, I have "-gtk" also... 
*retrying with USE="gtk -motif" emerge wxGTK* 
ok, it worked :) 
Still, since wxGTK *requires* gtk, it should depend on gtk anyway.. 
USE=-gtk should be for disabling *optional* gtk-support right? 
Comment 3 Tod M. Neidt (RETIRED) gentoo-dev 2002-05-15 11:47:10 UTC
Actually, it requires gtk or motif, despite the tarball name. And it can only
build against one and not both concurrently. (Similar circumstances have been
discussed on gentoo-dev recently.)

However, you are right that a user would be inclined to assume that it requires
gtk.  The default should be gtk, but I'm not quite sure how to handle this.  For
example how would we go about handling it if the user is expecting to get a
build against gtk but happends to have 'motif' in their USE  
Comment 4 Per Wigren 2002-05-15 12:03:31 UTC
I'd say that it should go like this:  
USE="-gtk -motif" : build gtk-version  
USE="gtk -motif"  : build gtk-version  
USE="gtk motif"   : build gtk-version  
USE="-gtk motif"  : build motif-version 
Seems reasonable? Not many want to build a motif-only system these days, but 
if the do want that, they should have "-gtk -qt -gnome -kde motif" in their 
USE-variable to force it :) 
Comment 5 Seemant Kulleen (RETIRED) gentoo-dev 2002-06-29 01:35:23 UTC
stroke, this is a tricky one.  good luck
Comment 6 Rigo 2002-10-03 08:50:20 UTC
To make it more interesting: 2.3.3 is released ;-)
Comment 7 SpanKY gentoo-dev 2002-10-26 15:13:58 UTC
i just added wxGTK-2.3.3 ...

i then run these series of commands:
env USE='-gtk -motif' emerge wxGTK
env USE='-gtk motif' emerge wxGTK
env USE='gtk -motif' emerge wxGTK
env USE='gtk motif' emerge wxGTK

and they all worked ... so do me a favor and try out 2.3.3 and see if it works 
for you
Comment 8 foser (RETIRED) gentoo-dev 2002-10-26 16:37:13 UTC
+gtk -motif worked fine for me, but after i look at the ebuild : you dont use
the motif flag ? So does motif get built when you want it or do i miss something
here ?
Comment 9 SpanKY gentoo-dev 2002-10-26 21:47:45 UTC
i didnt change much in the ebuild but bump it ... 
i guess ill check out the package some more ;) 
Comment 10 SpanKY gentoo-dev 2002-10-29 00:01:21 UTC
hmm, it seems that wxGTK will only compile by specifying one toolkit to compile 
that means we have 3 players (because of USE ... if we had more USE variables, 
there could be more :x) ... 
X, gtk, motif 
what i'm going to do is this ... 
if [ use gtk ] ; then 
    make gtk toolkit 
elif [ use X ] ; then 
    make x11 toolkit 
elif [ use motif ] ; then 
    make motif toolkit 
Comment 11 SpanKY gentoo-dev 2002-10-29 00:30:23 UTC
hmm, so the x11 and the motif toolkits do not compile ;)