Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273836 - net-ftp/kftpgrabber: fails to build with glibc-2.10
Summary: net-ftp/kftpgrabber: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-12 09:56 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-09 13:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (kftpgrabber-0.8.1-r1:20090612-023727.log,72.42 KB, text/plain)
2009-06-12 09:57 UTC, Diego Elio Pettenò (RETIRED)
Details
adds two consts and a const_cast to enable compilation with gcc44+glibc210 (kftpgrabber-0.8.1-glibc210.patch,1.37 KB, patch)
2009-08-05 17:33 UTC, Arttu Valo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-12 09:56:58 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-12 09:57:13 UTC
Created attachment 194371 [details]
Build log
Comment 2 Arttu Valo 2009-08-05 17:33:31 UTC
Created attachment 200271 [details, diff]
adds two consts and a const_cast to enable compilation with gcc44+glibc210

Patch isn't of kingly quality, but got the trivialities fixed so that kftpgrabber compiles. Upstream appears to have gone unmaintained for years, so since this needs kde 3.5, removal from the tree might be a possibility as well.
Comment 3 Samuli Suominen gentoo-dev 2009-08-09 13:21:56 UTC
Removal might come into question in future, but for now I've applied your patch. Thanks.