Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273819 - Emerging x11-misc/shared-mime-info-0.60 in Gentoo Prefix fails
Summary: Emerging x11-misc/shared-mime-info-0.60 in Gentoo Prefix fails
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-12 07:11 UTC by Rabbe Fogelholm
Modified: 2010-07-09 20:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rabbe Fogelholm 2009-06-12 07:11:01 UTC
Platform is Gentoo Prefix. Emerging x11-misc/shared-mime-info-0.60, pulled in by dev-python/pygtk, fails with console messages below. Successful emerge of the same version of shared-mime-info seen as late as 2009-06-11.

make[1]: Leaving directory `/local/scratch/portage/x11-misc/shared-mime-info-0.60/work/shared-mime-info-0.60/po'
CREATED freedesktop.org.xml
if test -n /local/tmp/c/usr/bin/xmllint ; then \
		xmllint --noout --valid ./freedesktop.org.xml;	\
	fi
./freedesktop.org.xml:1712: element com: validity error : No declaration for attribute type of element com
    <com type="application/x-rpm">
                                 ^
./freedesktop.org.xml:1720: parser error : Opening and ending tag mismatch: com line 1712 and mime-type
  </mime-type>
              ^
./freedesktop.org.xml:4371: parser error : Opening and ending tag mismatch: mime-type line 1708 and mime-info
</mime-info>/comment>
            ^
./freedesktop.org.xml:4410: parser error : Opening and ending tag mismatch: mime-info line 63 and mime-type
  </mime-type>
              ^
./freedesktop.org.xml:4411: parser error : Extra content at the end of the document
  <mime-type type="application/x-arc">
  ^
make: *** [check] Error 1
 * ERROR: x11-misc/shared-mime-info-0.60 failed:
Comment 1 Fabian Groffen gentoo-dev 2009-06-12 07:13:53 UTC
possibly related to xmlto update
Comment 2 Fabian Groffen gentoo-dev 2009-06-29 19:29:15 UTC
hmmm, 2009-06-12 a newer version of glib was added to the tree (which is a depend of this package), but I can't see how it can cause this error.

I also can't reproduce this on my machine(s).
Comment 3 Samuli Suominen gentoo-dev 2009-07-08 18:14:57 UTC
(In reply to comment #1)
> possibly related to xmlto update
> 

shared-mime-info doesn't use xmlto but xmllint from libxml2 (in a turn, xmlto is using xmllint from libxml2 too)

i've tried to reproduce this by "emerge -C docbook-xml-dtd" (as in remove all versions) and emerging shared-mime-info without luck, dunno what this is about
Comment 4 Joe Peterson (RETIRED) gentoo-dev 2009-09-07 14:54:04 UTC
If it helps, I had this exact problem in regular Gentoo (i.e. not prefix), building a fresh Gentoo amd64 system.  It happened during the emerge of kdebase-meta.

Simply running the emerge again caused the package to succeed (it was not the first to build in that next emerge).

I suspect either an intermittent failure (parallel compile?) or an order of package build issue - or something else mysterious.  But I figured I'd share this info if at all useful.
Comment 5 Samuli Suominen gentoo-dev 2009-10-09 10:40:28 UTC
0.70 in regular portage tree...
Comment 6 Tony Clark 2009-10-09 20:34:50 UTC
(In reply to comment #5)
> 0.70 in regular portage tree...
> 

I just found this to break vmplayer.  Complaining about not finding a .png file.  Sorry I dont have the info right now as I already back it out.
Comment 7 Willard Dawson 2009-10-09 21:46:01 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > 0.70 in regular portage tree...
> > 
> 
> I just found this to break vmplayer.  Complaining about not finding a .png
> file.  Sorry I dont have the info right now as I already back it out.
> 

A Me-Too story:

I emerge 0.70, and backed it out almost immediately. VMware Server 2.0.1.156745-r3 seems to start OK, but refused to actually display the Guest console.  And, all my images were nuked for Pidgin (both on the KDE tray and within the app).  0.70 would appear to be majorly hosed.
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-10-09 21:48:44 UTC
I find it hard to believe that you guys are all on Gentoo Prefix.. Considering 0.70 isn't even in the prefix tree yet, you should open a _NEW_ bug so it reaches the maintainers! Right now, your complaints are falling onto people that aren't listening...
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-10-09 21:49:16 UTC
(removing CC'd people that are on this bug for no reason)
Comment 10 Willard Dawson 2009-10-11 00:15:54 UTC
(In reply to comment #9)
> (removing CC'd people that are on this bug for no reason)
> 

Adding myself back. For no reason.
Comment 11 Fabian Groffen gentoo-dev 2010-07-09 20:18:04 UTC
closing this bug, as the version reported, and the version mentioned aren't even in the tree any mroe