Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273716 - net-im/naim: fails to build with glibc-2.10
Summary: net-im/naim: fails to build with glibc-2.10
Status: RESOLVED DUPLICATE of bug 215252
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard: Pending removal: 2009-10-08
Keywords: PMASKED
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-11 12:27 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-09 06:55 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (naim-0.11.8.3.1:20090611-121006.log,19.76 KB, text/plain)
2009-06-11 12:27 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-11 12:27:02 UTC
As per summary, check attached build log.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-11 12:27:29 UTC
Created attachment 194239 [details]
Build log
Comment 2 Víctor Ostorga (RETIRED) gentoo-dev 2009-06-11 21:58:05 UTC
Can't reproduce with gcc-4.4.0 with both debug and screen use flags.

Using:
sys-libs/ncurses-5.6-r2
app-misc/screen-4.0.3

Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.4.0, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5-0.3a i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-0.3a-i686-Intel-R-_Xeon-TM-_CPU_2.80GHz-with-gentoo-1.12.11.1
Timestamp of tree: Sun, 07 Jun 2009 01:45:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://gentoo.mirrors.tera-byte.com/ http://gentoo.arcticnetwork.ca/source/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl bash-completion berkdb bzip2 cli cracklib crypt dri fortran gdbm gif gpm iconv ipv6 isdnlog jpeg jpeg2k jpg midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl png pppd python readline reflection session spl ssl sysfs tcpd tiff unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-11 22:03:26 UTC
Switching blocker then.
Comment 4 David Gardner 2009-08-08 22:45:07 UTC
Is it possible that this is related an an issue on the naim tracker regarding naim not building correctly with make -j?
http://code.google.com/p/naim/issues/detail?id=11&colspec=ID%20Component%20Type%20Status%20Priority%20Owner%20Modified%20Summary
Comment 5 Samuli Suominen gentoo-dev 2009-08-08 22:48:04 UTC
Indeed. It's possible. I'll look into this again tomorrow, unless someone else beats me to it..
Comment 6 Samuli Suominen gentoo-dev 2009-08-09 06:55:13 UTC

*** This bug has been marked as a duplicate of bug 215252 ***