Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273538 - media-video/gnome-mplayer-0.9.6 autoconf fails without gnome-base/gconf
Summary: media-video/gnome-mplayer-0.9.6 autoconf fails without gnome-base/gconf
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL: http://dev.gentoo.org/~ssuominen/gnom...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-10 11:34 UTC by Mark Huijgen
Modified: 2009-06-21 18:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output from autoconf (autoconf.out,304 bytes, text/plain)
2009-06-10 11:35 UTC, Mark Huijgen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Huijgen 2009-06-10 11:34:25 UTC
Gconf is optional for gnome-mplayer, however without it autoconf seems to fail. Version 0.9.5 did not do an eautoreconf in the ebuild, so did not suffer from this problem and compiles fine without gconf.


Steps to reproduce:
1. make sure gconf is not installed
2. emerge media-video/gnome-mplayer-0.9.6
3. fails on autoconf due to missing macro:


>>> Preparing source in /var/tmp/portage/media-video/gnome-mplayer-0.9.6/work/gnome-mplayer-0.9.6 ...
 * Applying gnome-mplayer-0.9.6-asneeded.patch ...                                                                    [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-video/gnome-mplayer-0.9.6/work/gnome-mplayer-0.9.6' ...
 * Running aclocal ...                                                                                                [ ok ]
 * Running libtoolize --copy --force --automake ...                                                                   [ ok ]
 * Running aclocal ...                                                                                                [ ok ]
 * Running autoconf ...                                                                                               [ !! ]

 * Failed Running autoconf !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/media-video/gnome-mplayer-0.9.6/temp/autoconf.out
Comment 1 Mark Huijgen 2009-06-10 11:35:14 UTC
Created attachment 194143 [details]
Output from autoconf
Comment 2 Samuli Suominen gentoo-dev 2009-06-15 05:48:03 UTC
Looks like upstream (of gnome-mplayer) should bundle a copy of gconf-2.m4 from gconfd's package or stop using the macro (and use only e.g. pkgconfig to check if it's around) to prevent such failure(s) in the future.
Comment 3 Samuli Suominen gentoo-dev 2009-06-21 18:56:50 UTC
Fixed in portage, sync in an hour or so.