Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273282 - New QA check: warn about invalid/deprecated paths
Summary: New QA check: warn about invalid/deprecated paths
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Conceptual/Abstract Ideas (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 280853 (view as bug list)
Depends on:
Blocks: 335925 361759
  Show dependency tree
 
Reported: 2009-06-09 02:01 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2012-03-20 23:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 02:01:27 UTC
This is one of the tests I'm currently running on the tinderbox, but might actually be extended a bit more with actually a whitelist of directories we should allow.

For now I'm testing these directories:

/usr/man /usr/info /usr/X11R6 /usr/doc /usr/locale

while my /usr is this:

yamato ~ # ls /usr
GNUstep  X11R6  cyrus  displays  dx   games    i486-pc-linux-gnu  include  lib      local   man      nagios  sbin     share     src           tmp
NX       bin    diet   doc       etc  grass63  i686-pc-linux-gnu  kde      libexec  locale  modules  qt      shaders  shutdown  ti-linux-gnu  var


(get the results you want from that ;))

Note that X11R6 requires the xorg-x11 compatibility ebuild _not_ to be merged (maybe we should ask X11 to get rid of that?).
Comment 1 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2009-10-19 07:46:37 UTC
Hi Diego,

I don't get exactly what you are asking for here.  I assume the end result is that:

Files should not be installed into these paths.  We can possibly utilize sandbox here.

We can't disallow use of all these paths because existing ebuilds may need to clean up old data in old locations.  Is this the extent of your request?

-A
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2009-10-19 07:52:16 UTC
*** Bug 280853 has been marked as a duplicate of this bug. ***
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2009-10-19 07:54:26 UTC
I wanted same for X11 app-defaults directory in bug 280853 which should always be in /usr/share/X11/app-defaults or otherwise it simply won't work. It used to be in /etc and before that, in /usr/X11R6 and we still have unupdated ebuilds in tree.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-09-10 18:36:49 UTC
Can we _please_ revisit this? Seems like new packages get actually added using these paths still, and at least those should be stopped.

Please at least add a warning in the build, and die only on stricter, for now if you prefer.
Comment 6 Zac Medico gentoo-dev 2010-09-10 20:28:52 UTC
This is fixed in 2.1.9.3 and 2.2_rc79.