Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272749 - java jre doesn't clean up after running java applet from browser, next time app doesn't start
Summary: java jre doesn't clean up after running java applet from browser, next time a...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Java team
Depends on:
Reported: 2009-06-05 10:33 UTC by Akarki
Modified: 2009-06-05 16:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (,5.68 KB, text/plain)
2009-06-05 10:33 UTC, Akarki

Note You need to log in before you can comment on or make changes to this bug.
Description Akarki 2009-06-05 10:33:04 UTC
I have an java applet to use on a daily basis (cisco asdm for pix/asa firewalls).
I run them from mozilla firefox or seamonkey. It used to work fine for years.
Recently the following happens:
I start firefox, open the page which loads in the applet.
Applett runs fine, I exit.
Applet won't run anymore, when I want to start it up again.

I have to clear java cache and firefox cache manually, then restart browser, then it runs once again, but next time it fails again.
The applet code itself haven't changed.

[I--] [  ] dev-java/sun-jre-bin- (1.5)
[I--] [  ] dev-java/sun-jre-bin- (1.6)
[I--] [  ] virtual/jre-1.6.0 (1.6)
[I--] [  ] dev-java/sun-jdk- (1.6)
[I--] [  ] virtual/jdk-1.6.0 (1.6)

eselect java-vm list
Available Java Virtual Machines:
  [1]   sun-jdk-1.5
  [2]   sun-jdk-1.6
  [3]   sun-jre-bin-1.5
  [4]   sun-jre-bin-1.6  system-vm user-vm

[I--] [  ] www-client/mozilla-firefox-3.0.10 (0)
Comment 1 Akarki 2009-06-05 10:33:58 UTC
Created attachment 193616 [details]
emerge --info
Comment 2 Akarki 2009-06-05 10:35:25 UTC
eselect java-nsplugin list
Available Java browser plugins
  [1]   sun-jdk-1.6
  [2]   sun-jdk-1.6-plugin2  
  [3]   sun-jre-bin-1.5
  [4]   sun-jre-bin-1.6
  [5]   sun-jre-bin-1.6-plugin2 current
Comment 3 Akarki 2009-06-05 10:38:01 UTC
I've tried usinig sun-jdk-1.6 for system vm instead of sun-jre-bin-1.6 and vica versa, it seems to work the same way. 

I'm not sure, but it may relate the upgrade from to
I remember it was working fine with But I don't know exactly what has changed first, as firefox keeps upgrading, too.
Comment 4 Serkan Kaba (RETIRED) gentoo-dev 2009-06-05 16:43:59 UTC
I've been having this issue since the introduction of plugin2, the only option is to try the old plugin if you're an x86 user. Anyway resolving as upstream.