Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 272681 - net-analyzer/ettercap-0.7.3-r3 fails to build with libtool 2.2
Summary: net-analyzer/ettercap-0.7.3-r3 fails to build with libtool 2.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: Bugzilla (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 272399 (view as bug list)
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2009-06-04 18:56 UTC by Diego Stamigni
Modified: 2011-10-30 23:15 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,210.22 KB, text/plain)
2009-06-04 18:57 UTC, Diego Stamigni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Stamigni 2009-06-04 18:56:29 UTC
net-analyzer/ettercap-0.7.3-r3 fail to build.

                                       

Reproducible: Always

Steps to Reproduce:
1.emerge ettercap
2.
3.




error build:
ec_plugins.c: In function 'plugin_filter':                                                      
ec_plugins.c:134: error: expected ')' before 'LTDL_SHLIB_EXT'                                   
make[2]: *** [ettercap-ec_plugins.o] Error 1                                                    
make[2]: *** Waiting for unfinished jobs....                                                    
make[2]: Leaving directory `/var/tmp/portage/net-analyzer/ettercap-0.7.3-r3/work/ettercap-NG-0.7.3/src'                                                                                         
make[1]: *** [all-recursive] Error 1                                                            
make[1]: Leaving directory `/var/tmp/portage/net-analyzer/ettercap-0.7.3-r3/work/ettercap-NG-0.7.3/src'                                                                                         
make: *** [all-recursive] Error 1                                                               
 *  

emerge --info:
Portage 2.2_rc33 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-gentoo-r5 x86_64)                                                                                              
=================================================================                               
System uname: Linux-2.6.29-gentoo-r5-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.0.1                                                                                    
Timestamp of tree: Thu, 04 Jun 2009 17:45:01 +0000                                              
app-shells/bash:     4.0_p24                                                                    
dev-java/java-config: 2.1.8                                                                     
dev-lang/python:     2.6.2-r1                                                                   
dev-util/cmake:      2.6.4                                                                      
sys-apps/baselayout: 2.0.1                                                                      
sys-apps/openrc:     0.4.3-r2                                                                   
sys-apps/sandbox:    2.0                                                                        
sys-devel/autoconf:  2.13, 2.63-r1                                                              
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                     
sys-devel/binutils:  2.19.1-r1                                                                  
sys-devel/gcc-config: 1.4.1                                                                     
sys-devel/libtool:   2.2.6a                                                                     
virtual/os-headers:  2.6.29                                                                     
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                  
CBUILD="x86_64-pc-linux-gnu"                                                                    
CFLAGS="-march=k8 -O2 -pipe"                                                                    
CHOST="x86_64-pc-linux-gnu"                                                                     
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"                                                                                        
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                                                          
CXXFLAGS="-march=k8 -O2 -pipe"                                                                  
DISTDIR="/usr/portage/distfiles"                                                                
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                    
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.mneisen.org/ ftp://ftp.unina.it/pub/linux/distributions/gentoo "
LANG="it"
LDFLAGS="-Wl,-z,now,-O1,-enable-new-dtags,-as-needed,-hash-style=gnu"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl amd64 apm arts avi berkdb bitmap-fonts bzip2 cli consolekit cracklib crypt cups dbus dri dvd embedded emerald encode f77 foomaticdb fortran gdbm gif glitz gnome gpm gtk hal iconv imlib ipv6 isdnlog jpeg kde libg++ libwww mad midi mikmod mmx mng motif mpeg mudflap multilib mysql ncurses nls nptl nptlonly oggvorbis opengl openmp oss pam pcre pdflib perl png pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl sqlite sse sse2 ssl startup-notification svg sysfs tcpd truetype unicode webkit xcb xml2 xorg xscreensaver xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPT
Comment 1 Diego Stamigni 2009-06-04 18:57:28 UTC
Created attachment 193572 [details]
config.log

The emerge config.log of ettercap
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 18:59:11 UTC
*** Bug 272399 has been marked as a duplicate of this bug. ***
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 19:11:56 UTC
Okay this is due to regenerating autotools with libtool 2.2 (I also hit it on the tinderbox). I have a workaround in the form of

append-flags '-DLTDL_SHLIB_EXT=".so"'

(Yes it's an explicit DOUBLE quote) or an equivalent sed on the file that fails.
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2009-06-05 15:06:57 UTC
Thank you Diego for report.
...and thank you Diego for the fix! :)

A bit more quotation was required, so I've commited:
append-flags "-DLTDL_SHLIB_EXT='\".so\"'"