Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272659 - Drop midi use flag from media-libs/alsa-libs
Summary: Drop midi use flag from media-libs/alsa-libs
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo ALSA team
URL:
Whiteboard:
Keywords:
: 232128 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-04 17:59 UTC by Steve Dibb (RETIRED)
Modified: 2009-10-06 18:17 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Dibb (RETIRED) gentoo-dev 2009-06-04 17:59:14 UTC
ALSA team is going to drop the "midi" use flags from alsa-lib starting with 1.0.19-r1 and alsa-lib-1.0.20-r1 ebuilds.

There are a few reverse dependencies that check for alsa-lib w/midi use flag support, either through EAPI2 alsa-lib[midi] or --built-with-use.  They need to be updated to allow both versions.

I'll post deps as I come across them, and CC maintainers and probably fix them myself unless there are any objections.
Comment 1 Steve Dibb (RETIRED) gentoo-dev 2009-06-04 18:06:46 UTC
Revere dependencies:

http://tinderbox.dev.gentoo.org/misc/rindex/media-libs/alsa-lib

Gonna have to dig to see which ones use midi.
Comment 2 Navid Zamani 2009-06-08 05:38:44 UTC
Please look at bug #273137 and bug #273129, for things that should get into this (or at least the next) ebuild too. I added two fixes to it.

alsa-lib and alsa-tools 1.0.20-r2 installed and running fine here.
And revdep-rebuild also does not find any problems. :)
Comment 3 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-06-10 08:46:28 UTC
=games-simulation/openttd-0.7.0 depends on alsa-utils[midi].
Comment 4 Navid Zamani 2009-06-10 09:17:46 UTC
The following ebuilds do too:
games-engines/scummvm-0.12.0
kde-base/kdelibs-4.2.4
app-emulation/wine-1.1.22
kde-base/kdelibs-4.2.3
Comment 5 Chris Larson 2009-07-30 22:37:22 UTC
A quick grep of my current portage tree:

app-emulation/wine/wine-1.1.21		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.22		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.23		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.24		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-9999		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.13		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.14		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.15		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.16		alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.17                  alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.18                  alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.19                  alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.20                  alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.25                  alsa? ( media-libs/alsa-lib[midi] )
app-emulation/wine/wine-1.1.26                  alsa? ( media-libs/alsa-lib[midi] )
games-emulation/dosbox-cvs/dosbox-cvs-20030809	alsa? ( media-libs/alsa-lib[midi] )
games-emulation/dosbox/dosbox-0.72              alsa? ( media-libs/alsa-lib[midi] )
games-emulation/dosbox/dosbox-0.73              alsa? ( media-libs/alsa-lib[midi] )
games-engines/scummvm/scummvm-0.12.0            alsa? ( >=media-libs/alsa-lib-0.9[midi] )
games-engines/scummvm/scummvm-0.13.1            alsa? ( >=media-libs/alsa-lib-0.9[midi] )
games-engines/freesci/freesci-0.6.4             media-libs/alsa-lib[midi]
games-simulation/openttd/openttd-0.7.0          alsa? ( media-sound/alsa-utils[midi] )
games-simulation/openttd/openttd-0.7.1          alsa? ( media-sound/alsa-utils[midi] )
kde-base/kdelibs/kdelibs-4.2.4-r3               alsa? ( media-libs/alsa-lib[midi] )
media-gfx/gimp/gimp-9999                        alsa? ( >=media-libs/alsa-lib-1.0.14a-r1[midi] )
media-gfx/gimp/gimp-2.4.6                       alsa? ( >=media-libs/alsa-lib-1.0.14a-r1[midi] )
media-gfx/gimp/gimp-2.4.7                       alsa? ( >=media-libs/alsa-lib-1.0.14a-r1[midi] )
media-gfx/gimp/gimp-2.6.4                       alsa? ( >=media-libs/alsa-lib-1.0.14a-r1[midi] )
media-gfx/gimp/gimp-2.6.5                       alsa? ( >=media-libs/alsa-lib-1.0.14a-r1[midi] )
media-gfx/gimp/gimp-2.6.6                       alsa? ( >=media-libs/alsa-lib-1.0.14a-r1[midi] )
media-sound/lash/lash-0.5.4-r1                  alsa? ( media-libs/alsa-lib[midi] )
media-sound/qjackctl/qjackctl-0.3.4             alsa? ( media-libs/alsa-lib[midi] )
media-sound/timidity++/timidity++-2.13.2-r10    alsa? ( media-libs/alsa-lib[midi] )
media-sound/timidity++/timidity++-2.13.2-r11    alsa? ( media-libs/alsa-lib[midi] )
media-sound/fluidsynth/fluidsynth-1.0.8-r1      alsa? ( media-libs/alsa-lib[midi]
media-sound/fluidsynth/fluidsynth-1.0.9         alsa? ( media-libs/alsa-lib[midi]
media-sound/rosegarden/rosegarden-1.7.2-r1      alsa? ( >=media-libs/alsa-lib-1.0[midi]
media-sound/rosegarden/rosegarden-1.7.3         alsa? ( >=media-libs/alsa-lib-1.0[midi]
media-sound/seq24/seq24-0.9.0                   >=media-libs/alsa-lib-0.9[midi]
media-sound/jack-rack/jack-rack-1.4.7-r1        alsa? ( media-libs/alsa-lib[midi] )
media-sound/zynaddsubfx/zynaddsubfx-2.2.1-r4    alsa? ( media-libs/alsa-lib[midi] )
media-sound/ardour/ardour-2.7.1                 >=media-libs/alsa-lib-1.0.14a-r1[midi]
media-sound/qtractor/qtractor-0.4.2             media-libs/alsa-lib[midi]
media-sound/gmorgan/gmorgan-0.25-r1             media-libs/alsa-lib[midi]"
media-sound/ecasound/ecasound-2.6.0             alsa? ( media-libs/alsa-lib[midi] )
media-sound/hydrogen/hydrogen-0.9.3-r4          alsa? ( media-libs/alsa-lib[midi] )
Comment 6 Chris Larson 2009-07-30 22:38:51 UTC
Well, that wrapped pretty poorly. Sorry about that, but I reckon it''ll do.
Comment 7 Steve Dibb (RETIRED) gentoo-dev 2009-08-01 05:06:57 UTC
*** Bug 232128 has been marked as a duplicate of this bug. ***
Comment 8 Samuli Suominen gentoo-dev 2009-08-01 07:31:40 UTC
It's done and ALSA without [midi] is unmasked.
Comment 9 Fabio Bonfante 2009-08-04 10:35:57 UTC
Maybe could help an 'eselect news' ...some packages (for example kde-libs) installed with the alsa-lib[midi] dep give problems in updating world. 
The ebuild installed still depends on midi IUSE and the exact new revision of the package could be not unmasked (imho a common way to have a reasonably stable system even with unmasked packages). 
So the user take some time to figure that the problem could be in the installed packages (and related unmasked version).
Comment 10 Navid Zamani 2009-10-06 18:07:54 UTC
Just a question: Does dropping the flag mean, that now midi is always integrated, or that it never is. Because if it never is, how would you then play midi? Especially for example with Rosegarden to timidity or a midi sound card
Comment 11 Samuli Suominen gentoo-dev 2009-10-06 18:17:18 UTC
(In reply to comment #10)
> Just a question: Does dropping the flag mean, that now midi is always
> integrated, or that it never is. Because if it never is, how would you then
> play midi? Especially for example with Rosegarden to timidity or a midi sound
> card
> 

It's always enabled. There was no point in keeping it optional.