Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272505 - dev-libs/mpatrol: fails to build with glibc-2.10
Summary: dev-libs/mpatrol: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-03 22:18 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-07-07 18:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (mpatrol-1.4.8-r2:20090603-140056.log,579.22 KB, text/plain)
2009-06-03 22:19 UTC, Diego Elio Pettenò (RETIRED)
Details
mpatrol-gcc44-glibc210.patch (mpatrol-gcc44-glibc210.patch,2.16 KB, patch)
2009-06-09 06:18 UTC, Ryan Hill (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-03 22:18:44 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-03 22:19:07 UTC
Created attachment 193457 [details]
Build log
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2009-06-09 05:44:34 UTC
../../tools/dmalloc.c: In function 'char* bytestring(char*, size_t, char*, size_t)':
../../tools/dmalloc.c:412: error: invalid conversion from 'const char*' to 'char*'
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2009-06-09 06:10:29 UTC
and then..

../../src/mptrace.c:271: error: cast from 'Pixel*' to 'Cardinal' loses precision                                                            
../../src/mptrace.c:273: error: cast from 'void**' to 'Cardinal' loses precision                                                            
../../src/mptrace.c:275: error: cast from 'long unsigned int*' to 'Cardinal' loses precision                                                
../../src/mptrace.c:277: error: cast from 'Pixel*' to 'Cardinal' loses precision                                                            
../../src/mptrace.c:279: error: cast from 'Dimension*' to 'Cardinal' loses precision                                                        
../../src/mptrace.c:281: error: cast from 'Pixel*' to 'Cardinal' loses precision                                                            
../../src/mptrace.c:283: error: cast from 'long unsigned int*' to 'Cardinal' loses precision                                                
../../src/mptrace.c:285: error: cast from 'Pixel*' to 'Cardinal' loses precision                                                            
../../src/mptrace.c:287: error: cast from 'Dimension*' to 'Cardinal' loses precision                                                        
../../src/mptrace.c:289: error: cast from 'Dimension*' to 'Cardinal' loses precision                                                        
../../src/mptrace.c:291: error: cast from 'Dimension*' to 'Cardinal' loses precision      
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2009-06-09 06:18:46 UTC
Created attachment 193967 [details, diff]
mpatrol-gcc44-glibc210.patch
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2009-06-09 06:20:00 UTC
that's a vote for "Keep" in case you were wondering ;)
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-07-03 16:48:33 UTC
(In reply to comment #4)
> Created an attachment (id=193967) [edit]
> mpatrol-gcc44-glibc210.patch
> 

Someone with a glibc-2.10 host should apply this, *nudge*
Comment 7 Víctor Ostorga (RETIRED) gentoo-dev 2009-07-07 18:37:13 UTC
Thanks for the patch, tested and applied to dev-libs/mpatrol-1.4.8-r2