Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272270 - dev-util/motor removal request (was: fails to build with glibc-2.10)
Summary: dev-util/motor removal request (was: fails to build with glibc-2.10)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-02 14:43 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-22 16:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (motor-3.4.0-r2:20090602-023157.log,8.74 KB, text/plain)
2009-06-02 14:44 UTC, Diego Elio Pettenò (RETIRED)
Details
bumps ebuild to EAPI=2 and renames local strndup (motor-3.4.0-r2.ebuild.patch,904 bytes, patch)
2009-07-08 12:19 UTC, Arttu Valo
Details | Diff
Doesn't really work but adding for reference. (motor-3.4.0-strndup.patch,1.92 KB, patch)
2009-08-09 18:06 UTC, Samuli Suominen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-02 14:43:50 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-02 14:44:07 UTC
Created attachment 193294 [details]
Build log
Comment 2 Arttu Valo 2009-07-08 12:19:21 UTC
Created attachment 197171 [details, diff]
bumps ebuild to EAPI=2 and renames local strndup

This small change tries to bump the ebuild into EAPI-2 age and fixes the locally specified strndup by renaming it.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 12:20:35 UTC
If it's doing what it seems to be doing (otherwise it would have been broken on older glibc too), wouldn't it make more sense to simply _use_ the system copy instead of reinventing it, if present?
Comment 4 Samuli Suominen gentoo-dev 2009-08-09 18:05:27 UTC
(In reply to comment #3)
> If it's doing what it seems to be doing (otherwise it would have been broken on
> older glibc too), wouldn't it make more sense to simply _use_ the system copy
> instead of reinventing it, if present?
> 

I tried that.

kkstrtext.cc:434: error: cast from ‘void*’ to ‘int’ loses precision
kkstrtext.cc:434: error: cast from ‘void*’ to ‘int’ loses precision

This is the result.
Comment 5 Samuli Suominen gentoo-dev 2009-08-09 18:06:37 UTC
Created attachment 200710 [details, diff]
Doesn't really work but adding for reference.
Comment 6 Samuli Suominen gentoo-dev 2009-08-09 18:10:01 UTC
actually it fails even if they're just renamed so letting this one stay masked
Comment 7 Samuli Suominen gentoo-dev 2009-09-22 16:45:10 UTC
Bye.