Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272097 - app-office/abiword-2.8.4 version bump
Summary: app-office/abiword-2.8.4 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: GNOME Office (OBSOLETE)
URL: http://www.abisource.com/release-note...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-01 14:30 UTC by Thorsten Vollmer
Modified: 2010-04-20 15:48 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
abiword-2.7.2.ebuild (abiword-2.7.2.ebuild,2.26 KB, text/plain)
2009-06-01 14:40 UTC, Thorsten Vollmer
Details
diff for easier review (diff,4.03 KB, patch)
2009-06-01 14:42 UTC, Thorsten Vollmer
Details | Diff
The build log of failed attemp to compile AbiWord 2.7.2 (failed-build.log,39.12 KB, text/plain)
2009-06-08 09:15 UTC, Sergey S. Starikoff
Details
fix build failures with libtool-1 (abiword-2.7.2.ebuild,2.38 KB, text/plain)
2009-06-08 23:39 UTC, Thorsten Vollmer
Details
new dependency on media-libs/jpeg (abiword-2.7.6.ebuild,2.18 KB, text/plain)
2009-07-09 18:31 UTC, Thorsten Vollmer
Details
abiword-2.7.6.ebuild (abiword-2.7.6.ebuild,2.85 KB, text/plain)
2009-07-15 00:08 UTC, Will Lepofsky
Details
strace of russian localized interface abiword 'Help -> Search' click (abiword.trace.bz2,45.87 KB, text/plain)
2009-07-15 05:30 UTC, Sergey S. Starikoff
Details
abiword-2.7.10.ebuild (abiword-2.7.10.ebuild,2.09 KB, text/plain)
2009-08-30 13:04 UTC, Thorsten Vollmer
Details
abiword 2.8.2 sample ebuild (abiword-2.8.2.ebuild,2.86 KB, text/plain)
2010-03-31 03:36 UTC, Anthony Waters
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Vollmer 2009-06-01 14:30:49 UTC
AbiWord-2.7 gained several new features, including support for annotations and smart quotes, and also the ability to view multiple pages side by side.

I adapted the ebuild to the new build system and the changed dependencies.

The OpenDocument plugin is built by default. It can be disabled, but I think it is worth being included in app-office/abiword instead of app-office/abiword-plugins.
Comment 1 Thorsten Vollmer 2009-06-01 14:40:05 UTC
Created attachment 193150 [details]
abiword-2.7.2.ebuild
Comment 2 Thorsten Vollmer 2009-06-01 14:42:32 UTC
Created attachment 193151 [details, diff]
diff for easier review
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-06-01 18:40:42 UTC
please this is a dev release...
Comment 4 Thorsten Vollmer 2009-06-01 19:19:45 UTC
Feel free to use the ebuild for reference, once 2.8 is available. I do not expect many changes.
Thanks for your efforts.
Comment 5 daniel.sommerseth 2009-06-04 19:28:46 UTC
In a distant past, Gentoo used to have development releases in its main tree (masked, of course). Now they are in some obscure overlays. This is unnecessarily complicated. But I’m off topic...
I meant to say that Abiword 2.7 is a huge improvement and seems very stable. Thanks for the ebuild, Thorsten!
Comment 6 Sergey S. Starikoff 2009-06-08 09:12:14 UTC
(In reply to comment #1)
> Created an attachment (id=193150) [edit]
> abiword-2.7.2.ebuild
> 

As a check for bug http://bugs.gentoo.org/show_bug.cgi?id=272410 I've tryed to build AbiWord 2.7.2.
But this attemp failed.
The build.log will be attached.
Comment 7 Sergey S. Starikoff 2009-06-08 09:15:37 UTC
Created attachment 193860 [details]
The build log of failed attemp to compile AbiWord 2.7.2
Comment 8 Thorsten Vollmer 2009-06-08 23:39:05 UTC
Created attachment 193947 [details]
fix build failures with libtool-1
Comment 9 Sergey S. Starikoff 2009-06-09 06:42:06 UTC
(In reply to comment #8)
> Created an attachment (id=193947) [edit]
> fix build failures with libtool-1
> 
Thank you.
The update to AbiWord-2.7.2 fixes at least the problem with exporting to pdf (the crash at print command should be fixed too).

But after this update most commands in 'help' menu (in Russian translation) doesn't works and hangs up the application.
It's much less actual, than crash at printing, but, I think, should be fixed.
Comment 10 Lukas Zavodny 2009-06-30 10:35:26 UTC
Actual dev version is 2.7.5 Renaming of the ebuild works
Comment 11 Romain Perier (RETIRED) gentoo-dev 2009-06-30 18:07:21 UTC
Like gilles said, it's a dev release and not a stable release...
Comment 12 Lukas Zavodny 2009-07-06 11:17:52 UTC
(In reply to comment #11)
> Like gilles said, it's a dev release and not a stable release...
> 

However stable release doesn't support open office 3.x odt format. At least for me it was unable to open until emerge this dev. versions
Comment 13 Gilles Dartiguelongue gentoo-dev 2009-07-06 11:49:50 UTC
please stop arguing. gnome-office does not have the man-power to maintain develepment releases in tree for now so abiword as well as gnumeric will have to wait for an upstream _stable_ release to hit the tree. I too am displeased with 2.6 series status but that's all we'll have for a while.
Comment 14 Romain Perier (RETIRED) gentoo-dev 2009-07-06 15:52:53 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Like gilles said, it's a dev release and not a stable release...
> > 
> 
> However stable release doesn't support open office 3.x odt format. At least for
> me it was unable to open until emerge this dev. versions
> 

Feel free to write an ebuild and to commit/push it into your own overlay
Comment 15 Zsolti 2009-07-07 12:27:09 UTC
renaming to 2.7.6 works. runs and works fine. finally a functioning odt importer plugin.
Comment 16 Thorsten Vollmer 2009-07-09 18:29:17 UTC
(In reply to comment #9)
> But after this update most commands in ‘help’ menu (in Russian translation)
> doesn’t works and hangs up the application.
I cannot reproduce this problem.  Please provide a backtrace if you still experience these hangs.
Comment 17 Thorsten Vollmer 2009-07-09 18:31:53 UTC
Created attachment 197382 [details]
new dependency on media-libs/jpeg
Comment 18 Sergey S. Starikoff 2009-07-10 09:56:54 UTC
(In reply to comment #16)
> I cannot reproduce this problem.  Please provide a backtrace if you still
> experience these hangs.
> 
I've updated to 2.7.6 and built it with debug USE on.
The problem with the Help menu are the same.
For example I click 'Help -> Search'.
And (when AbiWord was started from gdb) see nothing.
After a time (any action doesn't take a response) in console I see just:

** (abiword:13620): WARNING **: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
DEBUG: SEVIOR: e->button = 1 
DEBUG: hit new tab
DEBUG: SettingTabStop: 138.6mm
DEBUG: m_draggingCenter = 10153
DEBUG: iTab: -2, m_draggingTab: -1
DEBUG: TopRuler: Tab Stop [138.6mm/L0,122.4mm/L0,124.9mm/L0]
DEBUG: !!!!!!!!!!Created CR ID number 4 Doc UUID c5200ff0-6d36-11de-9e1a-d0462676efc5 
DEBUG: fl_DocListener::change
DEBUG: SectionBreak from start 
DEBUG: SectionBreak from start 
DEBUG: Doing view notification 
DEBUG: SectionBreak from start 
DEBUG: fp_Page:: Total avail after margins subtracted 13957 
DEBUG: Page number 0 
DEBUG: NumWrapped 0 
DEBUG: Scroll Adjustment set to 0 upper 12280.000000 size 12345.000000
DEBUG: Scroll Adjustment set to 0 upper 12280.000000 size 12345.000000

and the clean window of AbiWord again.
Comment 19 Zsolti 2009-07-10 10:01:57 UTC
(In reply to comment #18)
> (In reply to comment #16)
> > I cannot reproduce this problem.  Please provide a backtrace if you still
> > experience these hangs.
> > 
> I've updated to 2.7.6 and built it with debug USE on.
> The problem with the Help menu are the same.
> For example I click 'Help -> Search'.
> And (when AbiWord was started from gdb) see nothing.
> After a time (any action doesn't take a response) in console I see just:
> 
for me help works fine.
help opens in a browser (firefox) window. did you have installed a browser on your system?
Comment 20 Thorsten Vollmer 2009-07-10 16:49:31 UTC
(In reply to comment #18)
Did I understand correctly that AbiWord is completely unresponsive after clicking the menu item? If this is true, a stack trace would show where the execution stops.
AbiWord calls gtk_show_uri to launch the web browser, and thus the actual problem might be unrelated to AbiWord.
Comment 21 Will Lepofsky 2009-07-15 00:08:44 UTC
Created attachment 197990 [details]
abiword-2.7.6.ebuild

Added use flags for clipart, emacs, print, templates, tidy, and vim.

Default enable for clipart, print, spell, and templates. 

emacs and vim only set key bindings, they don't pull in either.

Enable support for gnome-vfs.
Comment 22 Sergey S. Starikoff 2009-07-15 05:29:08 UTC
(In reply to comment #20)
> Did I understand correctly that AbiWord is completely unresponsive after
> clicking the menu item? If this is true, a stack trace would show where the
> execution stops.
> AbiWord calls gtk_show_uri to launch the web browser, and thus the actual
> problem might be unrelated to AbiWord.
> 
If started normally (not via gdb or strace) abiword window becomes completely unresponsive.

P.S. Yes, I have two browsers installed: firefox 3.0 and lynx.
With what language is built your abiword (which works correctly), and/or localized your system?
Comment 23 Sergey S. Starikoff 2009-07-15 05:30:33 UTC
Created attachment 198011 [details]
strace of russian localized interface abiword 'Help -> Search' click
Comment 24 Thorsten Vollmer 2009-07-15 11:40:26 UTC
(In reply to comment #21)
> Created an attachment (id=197990)

You have added too many USE flags. Why do you want to use gnome-vfs when gio/gvfs is available? You gain nothing. Why do you want to disable printing when it does not reduce the dependencies? The key bindings are enabled by default and can be selected at runtime. [1] Again, no need for USE flags.

1: You may need to add KeyBindingsCycle=”1“ to your AbiWord profile.
Comment 25 Thorsten Vollmer 2009-07-15 11:44:00 UTC
(In reply to comment #22)
> Yes, I have two browsers installed: firefox 3.0 and lynx.

Could you please try if 'gnome-open http://www.abisource.com/help/ru-RU/search.html' starts a web browser on your system? gnome-open is part of gnome-base/libgnome.
Comment 26 Sergey S. Starikoff 2009-07-15 13:43:02 UTC
(In reply to comment #25)
> Could you please try if 'gnome-open
> http://www.abisource.com/help/ru-RU/search.html' starts a web browser on your
> system? gnome-open is part of gnome-base/libgnome.
> 
I've checked it without gnome-open and seen that the documentation is available only for three languages:
    * English
    * French
    * Polish

I'm not shure about localization of this issue (ebuild, localization pack or AbiWord itself). But I think, the action of click 'Help' items should first contains check the availability of requested item for selected language and only after that try to open it in a browser (availability of browser should be also checked).

P.S. Excuse me my English.
Comment 27 Thorsten Vollmer 2009-07-15 14:40:29 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > Could you please try if 'gnome-open
> > http://www.abisource.com/help/ru-RU/search.html' starts a web browser on your
> > system? gnome-open is part of gnome-base/libgnome.
> > 
> I’ve checked it without gnome-open and seen that the documentation is available
> only for three languages:

Please do test gnome-open. If gnome-open fails similarly, your problem is not with AbiWord.
Comment 28 Sergey S. Starikoff 2009-07-16 05:14:19 UTC
(In reply to comment #27)
> Please do test gnome-open. If gnome-open fails similarly, your problem is not
> with AbiWord.
> 
You was right:

$ gnome-open http://www.abisource.com/help/ru-RU/search.html   
Ошибка отображения URL: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Comment 29 Thorsten Vollmer 2009-07-16 11:55:33 UTC
(In reply to comment #28)
> You was right:
> $ gnome-open http://www.abisource.com/help/ru-RU/search.html   
> Ошибка отображения URL: DBus error org.freedesktop.DBus.Error.NoReply

Thanks for your feedback. I am pretty sure that your problems with AbiWord and gnome-open have the same root because both programs use the same API to launch the web browser.
dbus-monitor should give you an idea of what goes wrong. Please file a separate report if you need more help on this issue.
Comment 30 Sergey S. Starikoff 2009-07-20 08:08:37 UTC
BTW, currently installed version of AbiWord (2.7.6) again crashes at print command.
But it causes only at real print, export to pdf works fine, wrint peview --- also OK (attemping to print via print preview window send a connamd to the printer and printer prints some symbols, but not the requested document.).
Comment 31 Thorsten Vollmer 2009-08-30 13:04:08 UTC
Created attachment 202704 [details]
abiword-2.7.10.ebuild

* re-add dependency on libxml2, which was accidentally removed
* remove workaround for libtool-1; libtool-1.5.26 was used for this release
Comment 32 Thorsten Vollmer 2009-09-07 04:19:40 UTC
(In reply to comment #30)
> BTW, currently installed version of AbiWord (2.7.6) again crashes at print command.

Sergey, please start AbiWord from a shell with 'GTK_MODULES=foo abiword' and ignore the warning. Does it still crash?
Comment 33 Sergey S. Starikoff 2009-09-07 05:42:41 UTC
(In reply to comment #32)
> Sergey, please start AbiWord from a shell with 'GTK_MODULES=foo abiword' and
> ignore the warning. Does it still crash?
> 
Currently I've updated to abiword-2.7.10

The bug with printing was posted to upstream
http://bugzilla.abisource.com/show_bug.cgi?id=12341

If done as you recommended AbiWord prints the selected page successfully and not crashes.
Comment 34 Thorsten Vollmer 2009-09-07 09:22:18 UTC
(In reply to comment #33)
> If done as you recommended AbiWord prints the selected page successfully
> and not crashes. The bug with printing was posted to upstream

Thanks for testing. I am not convinced that this is a bug in AbiWord. The nature of the workaround and the stack trace indicate a problem with Gentoo's GTK+.
Comment 35 Stefan de Konink 2009-11-05 02:52:20 UTC
We are at 2.8.1 now... any progress?
Comment 36 skobk.in 2009-11-24 19:00:06 UTC
http://www.abisource.com/downloads/abiword/2.8.1/source/abiword-2.8.1.tar.gz
Please, make ebuild for it.
Comment 37 Anthony Waters 2009-12-04 04:30:56 UTC
I downloaded abiword-2.7.10.ebuild and renamed it to abiword-2.8.1 and it seems to work okay for now.  I'm not sure how the plugins are handled though.
Comment 38 djkrysak 2009-12-05 17:29:16 UTC
The new version of abiword actually includes all of the plugins from the abiword-plugins package inside the source tarball now.  I didn't look at it very hard but it looks as if you can only enable everything with the --enable-plugins option (someone correct me if I am wrong on this though), so in addition to changing the name of the ebuild, the --enable-plugins option and all of the dependencies from abiword-plugins has to be put into the ebuild as well.

Maybe we can just have a 'plugins' USE flag for them?  If I have time later tonight I will make an ebuild for it.
Comment 39 Anthony Waters 2009-12-08 02:21:02 UTC
I was under the impression from reading ./configure --help

"
  --enable-plugins        ="foo bar baz", list of plugins to build. Use
                          --disable-plugins to disable plugin loading support,
                          resulting in a smaller binary size.
"

that the parameters to enable plugins would be the directories listed under the plugins/ directory.  I'll look into this more to see if it is true or not

(In reply to comment #38)
> The new version of abiword actually includes all of the plugins from the
> abiword-plugins package inside the source tarball now.  I didn't look at it
> very hard but it looks as if you can only enable everything with the
> --enable-plugins option (someone correct me if I am wrong on this though), so
> in addition to changing the name of the ebuild, the --enable-plugins option and
> all of the dependencies from abiword-plugins has to be put into the ebuild as
> well.
> 
> Maybe we can just have a 'plugins' USE flag for them?  If I have time later
> tonight I will make an ebuild for it.
> 
Comment 40 Xake 2010-01-21 22:19:52 UTC
Nobody has had the time to look "officially" on this yet for inclusion into portage?
Comment 41 A. Person 2010-01-27 15:43:38 UTC
Has anyone found a non-workaround solution for the printing issue?
Comment 42 hitachi 2010-02-25 08:13:40 UTC
We are at 2.8.2 now.
Comment 43 Jeroen Roovers gentoo-dev 2010-02-25 11:57:05 UTC
(In reply to comment #42)
> We are at 2.8.2 now.

Sure, so update the Summary. :)
Comment 44 hitachi 2010-02-25 12:05:01 UTC
(In reply to comment #43)
> 
> Sure, so update the Summary. :)
> 
I tried this with other bugs but normaly I can't do that.
"You tried to change the Summary field from app-office/abiword-2.8.2 version bump  to app-office/abiword-2.8.2 version bump cant  , but only the assignee or reporter of the bug, or a sufficiently empowered user may change that field."
Comment 45 Anthony Waters 2010-03-31 03:36:26 UTC
Created attachment 225907 [details]
abiword 2.8.2 sample ebuild

this is a sample ebuild for 2.8.2 based off of the earlier versions posted

-for some reason putting --enable-builtin-plugins in G2CONF wouldn't work properly so I moved it into src_configure and used econf.
-not all of the plugins that could be enabled are exposed in the use flags
-first ebuild so give feedback please
Comment 46 Gilles Dartiguelongue gentoo-dev 2010-04-16 14:47:19 UTC
I've been working on a cleaned up ebuild yesterday, hopefully will push it before next week. Thanks all for your patience.
Comment 47 Gilles Dartiguelongue gentoo-dev 2010-04-19 23:22:54 UTC
commited with hopefully the same level of flexibility the old abiword+abiword-plugins had. Thanks everyone.
Comment 48 Thorsten Vollmer 2010-04-20 04:33:08 UTC
Thanks for providing this ebuild, Gilles. It exposed a bug in AbiWord’s build system. The compilation will fail if dev-cpp/asio is not installed and USE=collab is _not_ set.
See http://bugzilla.abisource.com/show_bug.cgi?id=12701 (You may need to patch plugin-configure.m4 instead.)
Comment 49 Jeroen Roovers gentoo-dev 2010-04-20 15:48:03 UTC
(In reply to comment #48)
> Thanks for providing this ebuild, Gilles. It exposed a bug in AbiWord’s build
> system. The compilation will fail if dev-cpp/asio is not installed and
> USE=collab is _not_ set.

We find that bug reports with generally 50 comments usually don't work that well any more, so please file a NEW bug report for that issue. It's basically unrelated to getting the ebuild into the tree in the first place, which is what this bug is about.