Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271876 - media-sound/quodlibet-2.0-r3 doesn't find my plugins
Summary: media-sound/quodlibet-2.0-r3 doesn't find my plugins
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-30 13:51 UTC by Tassilo Horn
Modified: 2009-05-30 16:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tassilo Horn 2009-05-30 13:51:19 UTC
I use media-sound/quodlibet-2.0-r3 and installed some plugins:

root@thinkpad> paludis -q quodlibet-{notify,autorating,wikipedia,cddb}
* media-plugins/quodlibet-notify
    gentoo:                  3316(~) {:0} 
    installed:               3316* {:0} 
* media-plugins/quodlibet-autorating
    gentoo:                  3316(~) {:0} 
    installed:               3316* {:0} 
* media-plugins/quodlibet-wikipedia
    gentoo:                  3017(~) {:0} 
    installed:               3017* {:0} 
* media-plugins/quodlibet-cddb
    gentoo:                  3198(~) {:0} 
    installed:               3198* {:0} 

Unfortunately, none of them appears in the Music > Plugins.  They're installed in:

% ls -R /usr/share/quodlibet/
/usr/share/quodlibet/:
plugins

/usr/share/quodlibet/plugins:
events  songsmenu

/usr/share/quodlibet/plugins/events:
quodlibet-autorating-3316.py   quodlibet-notify-3316.py
quodlibet-autorating-3316.pyc  quodlibet-notify-3316.pyc
quodlibet-autorating-3316.pyo  quodlibet-notify-3316.pyo

/usr/share/quodlibet/plugins/songsmenu:
quodlibet-cddb-3198.py   quodlibet-wikipedia-3017.py
quodlibet-cddb-3198.pyc  quodlibet-wikipedia-3017.pyc
quodlibet-cddb-3198.pyo  quodlibet-wikipedia-3017.pyo

When I start quodlibet, there's no warning/error concerning plugins, too.

% quodlibet 
Initializing audio backend (xinebe)
Initializing main library (~/.quodlibet/songs)
Supported formats: mod, mp3, mp4, mpc, spc, trueaudio, wav, wavpack, wma, xiph
/usr/lib64/python2.6/site-packages/quodlibet/__init__.py:114: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  try: return old_import(module, *args, **kwargs)

The Help > Output Log viewer doesn't show what's broken, too...
Comment 1 Tassilo Horn 2009-05-30 14:10:46 UTC
It seems that quodlibet looks only in ~/.quodlibet/plugins, so one should symlink /usr/share/quodlibet/plugins.  Maybe the plugin ebuilds could tell the user to do so.

Another way would be to install the plugins like the quodlibet homepage states, e.g. svn co them to ~/.quodlibet/plugins.  I've done so and it works flawlessly.  So maybe there shouldn't be ebuilds for plugins at all.  Of course, then there's no dependency tracking, but on the other hand tracking each plugin separately is not too easy to maintain...
Comment 2 Samuli Suominen gentoo-dev 2009-05-30 15:51:31 UTC
I've fixed all the plugins that media-plugins/quodlibet-* has in Portage. They all show up in Quod Libet now.
Comment 3 Samuli Suominen gentoo-dev 2009-05-30 15:51:45 UTC
Oh yeah, wait like an hour before syncing.
Comment 4 Tassilo Horn 2009-05-30 16:45:32 UTC
Thanks for the quick fix, Samuli.