Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 27183 - nvidia-kernel won't compile if NVIDIA chipset support selected for kernel
Summary: nvidia-kernel won't compile if NVIDIA chipset support selected for kernel
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: x86-kernel@gentoo.org (DEPRECATED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-23 12:01 UTC by Whit Blauvelt
Modified: 2003-09-01 11:32 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Whit Blauvelt 2003-08-23 12:01:07 UTC
Using vanilla-sources 2.4.21, then make dep, then emerge nvidia-kernel, then
going back to make menuconfig and selecting []NVIDIA chipset support (under
/dev/agpgart) results in failure of make bzImage (after another make dep of
course) at:

gcc -D__KERNEL__ -I/usr/src/linux-2.4.21/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=athlon   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=agpgart_be  -DEXPORT_SYMTAB -c agpgart_be.c
agpgart_be.c: In function `agp_generic_create_gatt_table':
agpgart_be.c:583: warning: assignment from incompatible pointer type
agpgart_be.c: In function `nvidia_generic_setup':
agpgart_be.c:4304: structure has no member named `num_of_masks'
agpgart_be.c: At top level:
agpgart_be.c:674: warning: `agp_generic_insert_memory' defined but not used
agpgart_be.c:736: warning: `agp_generic_remove_memory' defined but not used
make[4]: *** [agpgart_be.o] Error 1
make[4]: Leaving directory `/usr/src/linux-2.4.21/drivers/char/agp'
make[3]: *** [first_rule] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.21/drivers/char/agp'
make[2]: *** [_subdir_agp] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.21/drivers/char'
make[1]: *** [_subdir_char] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.21/drivers'
make: *** [_dir_drivers] Error 2

Note getting the patch from Nvidia, installing it manually, then trying to
compile with that option selected also fails - so this may be incompatibility
between the patch and 2.4.21 - even though it installs cleanly. (It looks like
the 2.6 kernels support Nvidia AGP - but I also need the nforce modules for NIC
and sound, and these don't appear to be available for 2.6 yet.)

Is NVIDIA chipset support not supposed to be selected anyway? Does nvidia-kernel
just assemble a module for AGP outside of the kernel build process? If so, this
should be documented. The main Gentoo installation doc suggests that "extra
configuration" is needed for nvidia-kernel, but doesn't specify what, so
checking off the obvious new option in the kernel menu seemed suggested.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




Portage 2.0.48-r5 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1)
=================================================================
System uname: 2.4.21 i686 AMD Athlon(tm) XP 2500+
GENTOO_MIRRORS="http://gentoo.oregonstate.edu
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
CONFIG_PROTECT="/usr/kde/2/share/config /etc /var/qmail/control /var/bind
/usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/kde/3/share/config
/usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
PORTDIR="/usr/portage"
DISTDIR="/usr/portage/distfiles"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR_OVERLAY=""
USE="x86 oss 3dnow apm avi crypt cups encode foomaticdb gif jpeg kde libg++ mad
mikmod mmx mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv
zlib gdbm berkdb slang readline arts tetex svga tcltk guile mysql X sdl gpm tcpd
pam libwww ssl perl python esd imlib oggvorbis gtk qt motif opengl mozilla cdr
-java -gnome mbox -apache2"
COMPILER="gcc3"
CHOST="i686-pc-linux-gnu"
CFLAGS="-mcpu=athlon-xp -O3 -pipe"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
ACCEPT_KEYWORDS="x86"
MAKEOPTS="-j2"
AUTOCLEAN="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
FEATURES="sandbox ccache"
Comment 1 Whit Blauvelt 2003-08-23 15:43:25 UTC
emerging nvidia-glx got past this problem to the next one (an error about a variable named "name"), which nvidia-kernel-1.0.4496-r1.ebuild has solved. 
Comment 2 Seemant Kulleen (RETIRED) gentoo-dev 2003-08-23 15:59:28 UTC
so can this bug be closed then?
Comment 3 Whit Blauvelt 2003-08-23 16:51:32 UTC
err - sorry have too many puzzles before me at once. The "solution" I just posted was to a subsequent puzzle where it failed to build even after removing agpgart from selection in the kernel menus. So I think the "right" way to do this is to _not_ have agpgart or NVIDIA selected in the kernel menus, and then to use the more recent masked version if using a 2.6 kernel. But I haven't fully tested that. Both of these were from hints I found in the forums. 

So, eh, the original report may still be pointing to a problem, although a work-around may be at hand. 
Comment 4 Martin Schlemmer (RETIRED) gentoo-dev 2003-08-24 00:26:03 UTC
The nvidia-kernel side should be fixed.  Please try to keep the bugs seperate,
iow, file a bug for the kernel failing, and another for nvidia-kernel failing.

Anyhow, If I understand correctly, he had an issue with the recent drop in
dev.name variable for 2.6.0-test3-bk5, but also a failing in  2.4.21 not
compiling the nvidia agp module.  The nvidia-kernel issue is fixed, but I have
no idea about the kernel side.  Is that a gentoo kernel, or vanilla sources ?
Comment 5 Whit Blauvelt 2003-08-24 06:28:28 UTC
Vanilla sources - so that issue's a kernel problem.
Comment 6 Guy 2003-08-27 04:28:30 UTC
Martin,

You may also want to look at bug # 27412. I'm off the 2.4.x kernels now and I don't know how much of the new ACPI stuff may have been back ported.

Best regards,
Guy
Comment 7 Martin Schlemmer (RETIRED) gentoo-dev 2003-09-01 11:32:46 UTC
Nobody kernel side seems to take this.  If you have a problem with non vanilla
sources (meaning a kernel you 'emerge'd, please file a bug against that kernel.
That is what they are there for - to fix issues with vanilla, plus enhancements.